OVH Community, your new community space.

Mi servidor no envía correos..


oceano
07/10/2012, 18:47
Hola Tito,

No, no te recomiendo que lo deshabilites. Ni tampoco modifiques los anteriores archivos comentados.

Como bien dice, deberías analizar

Restarting IMAP/POP3 mail server: dovecotLast died with error (see error log for more information): Time just moved backwards by 17 seconds. This might cause a lot of problems, so I'll just kill myself now.

y posteriormente buscar una solucióin aquí, http://wiki.dovecot.org/TimeMovedBackwards

o si sucede esto,
If you have trouble with authentication failures,

realizar esta acción,
enable auth_debug setting.

Siguiendo este archivo See http://wiki.dovecot.org/WhyDoesItNotWork

y como indica aquí,
This message goes away after the first successful login.


seguramente el problema esté solucionado.


Un saludo

Tito
07/10/2012, 11:09
Cita Publicado inicialmente por oceano
Hola,

Parece que lo tienes bien configurado, por lo menos buena pinta tiene...

Yo cuando realicé la primera instalación de Postfix sólo podía enviar correo, pero recibir no me dejaba, firewall activo en el puerto correspondiente, y todo bien configurado.

He visto que tienes instalado un sistema sasl, imagino estará bien configurado, verdad ?

smtpd_sasl_auth_enable = yes


a mi no me dejaba entrar correo con sasl instalado, pero fue instalar esto y empezó a permitirme entrar correo con sasl instalado.

apt-get install libsasl2-modules sasl2-bin

pegale un vistazo por google a ver que te parece, quizá pueda ser esta la solución.

Un saludo, ya comentas !
La verdad es que no tenía ni idea de esto.. Ya que está como me venía en el servidor.
Mi servidor es el ISPconfig 3 64bit (Debian 6 Squeeze) que ya viene montado por OVH y así estaba ya esto, entonces no tenía ni idea de que estaba eso..

¿Me recomiendas deshabilitarlo? O dime que hago..

Mil gracias.

EDITO:
He reiniciado dovecot una vez más y me aparece esto:
Restarting IMAP/POP3 mail server: dovecotLast died with error (see error log for more information): Time just moved backwards by 17 seconds. This might cause a lot of problems, so I'll just kill myself now. http://wiki.dovecot.org/TimeMovedBackwards
If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.

oceano
06/10/2012, 20:02
Hola,

Parece que lo tienes bien configurado, por lo menos buena pinta tiene...

Yo cuando realicé la primera instalación de Postfix sólo podía enviar correo, pero recibir no me dejaba, firewall activo en el puerto correspondiente, y todo bien configurado.

He visto que tienes instalado un sistema sasl, imagino estará bien configurado, verdad ?

smtpd_sasl_auth_enable = yes


a mi no me dejaba entrar correo con sasl instalado, pero fue instalar esto y empezó a permitirme entrar correo con sasl instalado.

apt-get install libsasl2-modules sasl2-bin

pegale un vistazo por google a ver que te parece, quizá pueda ser esta la solución.

Un saludo, ya comentas !

Tito
06/10/2012, 19:09
Cita Publicado inicialmente por suicidal
actualizaste algun paquete? un poco raro que antes fuera y ahora no... o reiniciaste el servidor?
No.
Sobre el reinicio del servidor sí, acabo de ver el último correo recibido y es del día 25, ese mismo día se reinició el servidor..

suicidal
06/10/2012, 18:14
actualizaste algun paquete? un poco raro que antes fuera y ahora no... o reiniciaste el servidor?

Tito
06/10/2012, 18:06
Cita Publicado inicialmente por oceano
Hola Tito,

Posiblemente tengas la configuración mal realizada.

Podrías facilitar mayor información ?

1.- Antes iba, ahora no ?
2.- Tienes algún panel de administración via web como, webmin ?
3.- Algún firewall instalado ?
4.- Podrías indicar la configuración qué tienes puesta en /etc/postfix/main.cf y /etc/postfix/master.cf
5.- Qué sistema operativo utilzas ?

Saludos !
Primero que nada, gracias por responder

1. Exacto
2. ISPConfig
3. No.
4. /etc/postfix/main.cf: http://pastebin.com/0afXYfWq
/etc/postfix/master.cf: http://pastebin.com/mzqv37nA
5. Debian 6 (Squeeze)

Gracias & saludos!

oceano
06/10/2012, 15:33
Hola Tito,

Posiblemente tengas la configuración mal realizada.

Podrías facilitar mayor información ?

1.- Antes iba, ahora no ?
2.- Tienes algún panel de administración via web como, webmin ?
3.- Algún firewall instalado ?
4.- Podrías indicar la configuración qué tienes puesta en /etc/postfix/main.cf y /etc/postfix/master.cf
5.- Qué sistema operativo utilzas ?

Saludos !

Tito
06/10/2012, 12:46
Buenas.

Tengo un Kemsirve 24G con ISPConfig 3(Debian 6 Squeeze) y el servidor no me envía los correos..

Al comprobar el estado de dovecot & postfix ambos me dicen 'is running'
¿Qué puede pasar? ¿Ideas?

Gracias & saludos.