We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Your ClamAV installation is OUTDATED!


Guille
07/05/2013, 07:52
Cita Publicado inicialmente por oceano
Hola Guille,

Esto que comentas también te actualiza la versión ?
Sí. Con ese comando se pasa a tener la 0.97.8
En efecto freshclam actualiza la bbdd pero, como es un servicio, suele hacerlo automaticamente, por lo que no me preocupo.
Cita Publicado inicialmente por oceano
Según la configuración que tengas, yo lo tengo para mucho más que analizar correos, también analiza zonas con metodología heurística, que no es más que un análisis avanzado del sistema.
Para análisis de ficheros uso Linux Malware Detect (LMD)
Pero es verdad que éste también usa el motor de detección de Clamav.

Saludos,

oceano
06/05/2013, 21:17
Hola Guille,

Yo siempre utilicé INSTALL para instalar, REINSTALL, para reinstalar el programa y UPDATE para actualizar. Esto que comentas también te actualiza la versión ? Yo el fallo que tenía era con actualizar la versión de Clamav, ahora está en la 0.97.8, pero la BBDD del programa si lo hacía con freshclam

Según la configuración que tengas, yo lo tengo para mucho más que analizar correos, también analiza zonas con metodología heurística, que no es más que un análisis avanzado del sistema. Yo de momento no tengo problemas con realizar un doble análisis, la verdad funciona todo bien y no da ningún tipo de fallos, eso si, debes configurarlo para que no se solape y trabaje con soltura.

Cuando he actualizado alguna vez el sistema, si ha detectado alguna anomalía y como tengo un lugar concreto para enviar lo que va detectando, luego lo puedo salvar si veo que realmente no es nada grabe.


Un saludo !

Guille
06/05/2013, 18:24
Cita Publicado inicialmente por oceano
PROXMOX trabaja con Debian, no con CentOS, así que de momento no hay solución para cstream, en el momento que la encuentre la postearé.
Para actualizar clamav en Debian se usa

apt-get install clamav-freshclam
que actualiza tanto clamav, como freshclam.

En cualquier caso no veo la ventaja de tener el clamav funcionando en el host Proxmox ya que su uso suele ser analizar ficheros adjuntos de correo, cuyos servidores estan dentro de los VM. Asi que mejor instalo clamav dentro de cada VM.

oceano
02/05/2013, 13:55
Hola, buenas tardes.

La actualización de Clamav a la última versión se puede solucionar siguiendo éste enlace, funciona a la primera http://foros.ovh.es/showthread.php?p...ed=1#post72147

Por el tema de cstream, bajo SolusVM, mejor no tocarlo y dejar a los repositorios que hagan su trabajo y actualicen cuando crean conveniente el sistema.


Un saludo !

oceano
02/05/2013, 09:34
Hola, buenos días.

PROXMOX trabaja con Debian, no con CentOS, así que de momento no hay solución para cstream, en el momento que la encuentre la postearé.


Un saludo !

oceano
01/05/2013, 12:26
Hola, buenos días

Bajo el entorno de SolusVM, si se borra cstream-2.7.4-3.el5.rf.i386 , posteriormente surgen errores.

leer más
http://foros.ovh.es/showthread.php?p=72126#post72126


La anterior configuración imagino que para un sistema virtualizado bajo PROXMOX si debería de funcionar correctamente, aunque si se diera el caso de que existe una duplicidad de versiones, yo no lo tocaría.


Un saludo !

oceano
21/03/2013, 10:31
Hola, buenos días

Al añadir el repositorio indicado anteriormente, tras iniciar un yum update nos dará un error como este, (teniendo el repositorio anteriormente instalado)
http://wiki.centos.org/AdditionalRes...ories/RPMForge

Protected multilib versions: cstream-3.1.0-1.el6.rf.x86_64 != cstream-2.7.4-3.el5.rf.i386

con realizar un yum remove para la arquitectura no deseada, se actualiza correctamente después con un simple yum update, es decir:

1.- Creamos/añadimos dentro de /etc/yum.repos.d/dag.repo

[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag/
gpgcheck=1
gpgkey=http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
enabled=1

2.- Ejecutamos yum update el cuál indicará que existe una duplicidad de versiones, tomando nota y eliminando la de arquitectura no funcional.

3.- yum remove XXX

4.- yum update

Running Transaction

Updating : clamav-db-0.97.7-1.el6.rf.x86_64
.
.
.

Complete.

5.- freshclam

Un saludo !

oceano
15/03/2013, 15:57
Hola, buenas tardes

Siguiendo estas guías se puede actualizar correctamente.

https://github.com/vrtadmin/clamav-f...q/Upgrading.md

https://github.com/vrtadmin/clamav-f...ling.md#CentOS


Un saludo !

oceano
14/03/2013, 20:42
Hola, buenas tardes

WARNING: Local version: 0.97.6 Recommended version: 0.97.7

Ha salido una nueva RELEASE para clamav, pero no consigo actualizarla.

He bajado, como indica en la página de clamav para RedHat and Fedora

" A very good repository is maintained by Dag Wieers dag at wieers*com: "

http://packages.sw.be/clamav/

y he añadido dentro de /etc/yum.repos.d mediante wget http://packages.sw.be/clamav

Podría indicarme alguien por qué no se actualiza o cual es el método que utiliza correctamente ?

Muchas gracias, un saludo !