OVH Community, your new community space.

Error al hacer update con yum y el bind


oceano
27/08/2013, 06:00
Hola DMZ_HOST

Pásate por aquí cuando tengas un rato... Este de propina !
http://foros.ovh.es/showthread.php?t=11289

* Nota, al final tienes un enlace a otro más, es decir hay dos !


Un saludo !

DMZ_HOST
26/08/2013, 22:28
Genial ese script para actualizar el server automáticamente, no sabia yo eso y funciona perfectamente. Gracias

oceano
25/08/2013, 22:37
Hgonzale

El servidor debe actualizar TODOS los días, uno detrás de otro.

Cita Publicado inicialmente por hgonzale
gracias amigo, el servidor tendra unos 4 o 6 meses, y he actualizado un par de veces, o una vez. Tampoco tiene mucho tiempo, y si te fijas, enel bind soloes una version menor lo que debe de subir, pero me da algo de que tiene 32 bits, pero ya no se.
Mil gracias por tu tiempo y ayuda, y veremos si alguien da con esto.

Super y feliz noche
Haz esto !

Código:
ACTUALIZADO !!!

# primero haz esto !

mkdir /etc/up/
touch /etc/up/up.log

vi /usr/bin/up

# letra i para escribir

# y dentro mete esto

echo "" >> /etc/up/up.log
echo "********************************************" >> /etc/up/up.log
echo "" >> /etc/up/up.log
echo "$(date)" >> /etc/up/up.log
echo "" >> /etc/up/up.log
echo "$(yum update -y --skip-broken)" >> /etc/up/up.log
echo "" >> /etc/up/up.log
echo "$(date)" >> /etc/up/up.log
echo "" >> /etc/up/up.log
echo "$(yum upgrade -y --skip-broken)" >> /etc/up/up.log
echo "" >> /etc/up/up.log
echo "********************************************" >> /etc/up/up.log

Mayúsculas + esc + q! # para dejar de escribir y salir sin guardar.
Mayúsculas + esc + x ( minúscula )# para dejar de escribir, guardar y salir. 

chmod +x /usr/bin/up # hacemos ejecutable por cualquiera

# ejecuta 

crontab -e

# añade

3 * * * * /usr/bin/up > /dev/null 2>&1
Con esto, TODAS las noches a las 3 se te actualizará el servidor.

Luego, si ejecutas un 1 desde consola se ejecutará el script

1* # up

y con un 2 verás como van las actualizaciones y si ha habido algún fallo durante ellas.
2* # vi /etc/up/up.log


Un saludo !

oceano
25/08/2013, 22:32
Hola Hgonzale

Mira este post, a ver que te parece...
http://wiki.centos.org/FAQ/General#h...39677aaca528e9

No olvides hacer copias antes de nada, por si algo no va como se esperaba.


Un saludo !

hgonzale
25/08/2013, 22:29
gracias amigo, el servidor tendra unos 4 o 6 meses, y he actualizado un par de veces, o una vez. Tampoco tiene mucho tiempo, y si te fijas, enel bind soloes una version menor lo que debe de subir, pero me da algo de que tiene 32 bits, pero ya no se.
Mil gracias por tu tiempo y ayuda, y veremos si alguien da con esto.

Super y feliz noche

oceano
25/08/2013, 22:28
Cita Publicado inicialmente por hgonzale
yum --skip-broken update -y && yum --skip-broken upgrade -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.ovh.net
* extras: mirror.ovh.net
* updates: mirror.ovh.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
---> Package bash.x86_64 0:4.1.2-15.el6_4 will be an update
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.2 will be an update
---> Package irqbalance.x86_64 2:1.0.4-3.el6 will be updated
---> Package irqbalance.x86_64 2:1.0.4-4.el6_4 will be an update
--> Processing Dependency: kernel >= 2.6.32-279 for package: 2:irqbalance-1.0.4-4.el6_4.x86_64
---> Package kernel-headers.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.14.1.el6 will be an update
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be an update
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package openswan.x86_64 0:2.6.32-20.el6_4 will be updated
---> Package openswan.x86_64 0:2.6.32-21.el6_4 will be an update
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package kernel.x86_64 0:2.6.32-358.14.1.el6 will be installed
--> Processing Dependency: kernel-firmware >= 2.6.32-358.14.1.el6 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Processing Dependency: dracut-kernel >= 002-18.git413bcf78 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package dracut-kernel.noarch 0:004-303.el6 will be installed
--> Processing Dependency: dracut = 004-303.el6 for package: dracut-kernel-004-303.el6.noarch
---> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package dracut.noarch 0:004-303.el6 will be installed
--> Processing Dependency: plymouth >= 0.8.0-0.2009.29.09.19.1 for package: dracut-004-303.el6.noarch
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be installed
--> Processing Dependency: libdrm_radeon.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm_nouveau.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm_intel.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm.so.2()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package libdrm.x86_64 0:2.4.39-1.el6 will be installed
--> Processing Dependency: libpciaccess.so.0()(64bit) for package: libdrm-2.4.39-1.el6.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package libpciaccess.x86_64 0:0.13.1-2.el6 will be installed
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind-libs = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
--> Running transaction check
---> Package bind-libs.i686 32:9.8.2-0.17.rc1.el6_4.4 will be installed
--> Processing Dependency: libz.so.1 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libxml2.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT) for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libcrypto.so.10 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libcap.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Running transaction check
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.4 will be installed
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libcom_err.so.2 for package: krb5-libs-1.10.3-10.el6_4.4.i686
---> Package libcap.i686 0:2.16-5.5.el6 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.16-5.5.el6.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.16-5.5.el6.i686
---> Package libxml2.i686 0:2.7.6-12.el6_4.1 will be installed
---> Package openssl.i686 0:1.0.0-27.el6_4.2 will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package libattr.i686 0:2.4.44-7.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-14.el6_4.2 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
---> Package bash.x86_64 0:4.1.2-15.el6_4 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-libs.i686 32:9.8.2-0.17.rc1.el6_4.4 will be installed
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package dracut.noarch 0:004-303.el6 will be installed
---> Package dracut-kernel.noarch 0:004-303.el6 will be installed
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.2 will be an update
---> Package irqbalance.x86_64 2:1.0.4-3.el6 will be updated
---> Package irqbalance.x86_64 2:1.0.4-4.el6_4 will be an update
---> Package kernel.x86_64 0:2.6.32-358.14.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed
---> Package kernel-headers.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.14.1.el6 will be an update
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.4 will be installed
---> Package libattr.i686 0:2.4.44-7.el6 will be installed
---> Package libcap.i686 0:2.16-5.5.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-14.el6_4.2 will be installed
---> Package libdrm.x86_64 0:2.4.39-1.el6 will be installed
---> Package libpciaccess.x86_64 0:0.13.1-2.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
---> Package libxml2.i686 0:2.7.6-12.el6_4.1 will be installed
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be an update
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package openssl.i686 0:1.0.0-27.el6_4.2 will be installed
---> Package openswan.x86_64 0:2.6.32-20.el6_4 will be updated
---> Package openswan.x86_64 0:2.6.32-21.el6_4 will be an update
---> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
32:bind-9.8.2-0.17.rc1.el6_4.5.x86_64 from updates
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for bind-libs which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of bind-libs of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude bind-libs.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of bind-libs installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of bind-libs installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686 != 32:bind-libs-9.8.2-0.17.rc1.el6_4.5.x86_64
You could try running: rpm -Va --nofiles --nodigest
Me refiero a este post !

oceano
25/08/2013, 22:27
Hola Hgonzale,

Hacía un tiempo que no actualizabas por lo que se muestra, verdad ?

Quizá el fallo venga por esto, por no haber actualizado en su momento. No sabría que decirte más...


Un saludo !

hgonzale
25/08/2013, 22:23
Si ejecuto el nodigest me devuelve sin error, pero sigo sin poder hacer el update.

Por otro lado, no quiero hacer que rompa la verificacion de multilib, porque alli si la puedo cagar.....

oceano
25/08/2013, 22:23
Hola Hgonzale,

Prueba con esto también, a ver que dice !

Código:
yum remove bind-libs-9.8.2-0.17.rc1.el6_4.4
Un saludo !

hgonzale
25/08/2013, 22:22
Lo mas raro, es que ese bind i686 (32 bits) NO lo tengo instalado....

hgonzale
25/08/2013, 22:21
yum --skip-broken update -y && yum --skip-broken upgrade -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.ovh.net
* extras: mirror.ovh.net
* updates: mirror.ovh.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
---> Package bash.x86_64 0:4.1.2-15.el6_4 will be an update
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.2 will be an update
---> Package irqbalance.x86_64 2:1.0.4-3.el6 will be updated
---> Package irqbalance.x86_64 2:1.0.4-4.el6_4 will be an update
--> Processing Dependency: kernel >= 2.6.32-279 for package: 2:irqbalance-1.0.4-4.el6_4.x86_64
---> Package kernel-headers.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.14.1.el6 will be an update
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be an update
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package openswan.x86_64 0:2.6.32-20.el6_4 will be updated
---> Package openswan.x86_64 0:2.6.32-21.el6_4 will be an update
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package kernel.x86_64 0:2.6.32-358.14.1.el6 will be installed
--> Processing Dependency: kernel-firmware >= 2.6.32-358.14.1.el6 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Processing Dependency: dracut-kernel >= 002-18.git413bcf78 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package dracut-kernel.noarch 0:004-303.el6 will be installed
--> Processing Dependency: dracut = 004-303.el6 for package: dracut-kernel-004-303.el6.noarch
---> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package dracut.noarch 0:004-303.el6 will be installed
--> Processing Dependency: plymouth >= 0.8.0-0.2009.29.09.19.1 for package: dracut-004-303.el6.noarch
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be installed
--> Processing Dependency: libdrm_radeon.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm_nouveau.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm_intel.so.1()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: libdrm.so.2()(64bit) for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package libdrm.x86_64 0:2.4.39-1.el6 will be installed
--> Processing Dependency: libpciaccess.so.0()(64bit) for package: libdrm-2.4.39-1.el6.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package libpciaccess.x86_64 0:0.13.1-2.el6 will be installed
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind-libs = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
--> Running transaction check
---> Package bind-libs.i686 32:9.8.2-0.17.rc1.el6_4.4 will be installed
--> Processing Dependency: libz.so.1 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libxml2.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT) for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libcrypto.so.10 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
--> Processing Dependency: libcap.so.2 for package: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Running transaction check
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.4 will be installed
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6_4.4.i686
--> Processing Dependency: libcom_err.so.2 for package: krb5-libs-1.10.3-10.el6_4.4.i686
---> Package libcap.i686 0:2.16-5.5.el6 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.16-5.5.el6.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.16-5.5.el6.i686
---> Package libxml2.i686 0:2.7.6-12.el6_4.1 will be installed
---> Package openssl.i686 0:1.0.0-27.el6_4.2 will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package libattr.i686 0:2.4.44-7.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-14.el6_4.2 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
---> Package bash.x86_64 0:4.1.2-15.el6_4 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-libs.i686 32:9.8.2-0.17.rc1.el6_4.4 will be installed
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.5 will be an update
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package dracut.noarch 0:004-303.el6 will be installed
---> Package dracut-kernel.noarch 0:004-303.el6 will be installed
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.2 will be an update
---> Package irqbalance.x86_64 2:1.0.4-3.el6 will be updated
---> Package irqbalance.x86_64 2:1.0.4-4.el6_4 will be an update
---> Package kernel.x86_64 0:2.6.32-358.14.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed
---> Package kernel-headers.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.14.1.el6 will be an update
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.4 will be installed
---> Package libattr.i686 0:2.4.44-7.el6 will be installed
---> Package libcap.i686 0:2.16-5.5.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-14.el6_4.2 will be installed
---> Package libdrm.x86_64 0:2.4.39-1.el6 will be installed
---> Package libpciaccess.x86_64 0:0.13.1-2.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
---> Package libxml2.i686 0:2.7.6-12.el6_4.1 will be installed
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be an update
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package openssl.i686 0:1.0.0-27.el6_4.2 will be installed
---> Package openswan.x86_64 0:2.6.32-20.el6_4 will be updated
---> Package openswan.x86_64 0:2.6.32-21.el6_4 will be an update
---> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
32:bind-9.8.2-0.17.rc1.el6_4.5.x86_64 from updates
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for bind-libs which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of bind-libs of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude bind-libs.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of bind-libs installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of bind-libs installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686 != 32:bind-libs-9.8.2-0.17.rc1.el6_4.5.x86_64
You could try running: rpm -Va --nofiles --nodigest

hgonzale
25/08/2013, 22:19
CentOS, el que instala OVH.
y voy a probar en el orden que me has dado.
Gracias Oceano

oceano
25/08/2013, 22:06
Hola Hgonzale,

Qué sistema operativo utilizas ? Si preguntas, es pq no lo tienes, olvídate...

Cita Publicado inicialmente por hgonzale
Gracias de nuevo amigo, pero por curiosidad, porque crees que es en eso del kernel, y como sabes o se, que es un openvz?
Protected multilib versions: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686 != 32:bind-libs-9.8.2-0.17.rc1.el6_4.5.x86_64

Código:
yum --skip-broken update -y && yum --skip-broken upgrade -y

# y luego prueba esto, a ver que dice !
rpm -Va --nofiles --nodigest
Un saludo !

hgonzale
25/08/2013, 22:03
rpm -e vzkernel-firmware
error: package vzkernel-firmware is not installed

hgonzale
25/08/2013, 22:01
Gracias de nuevo amigo, pero por curiosidad, porque crees que es en eso del kernel, y como sabes o se, que es un openvz?

oceano
25/08/2013, 21:52
Hola, Hgonzale

Cita Publicado inicialmente por hgonzale
Ya he leido y no debo estar con OpenVz, es un servidor propio, no virtualizado, es un ks de los de 9 euros (que ya no existen)
Eso que te he pasado se aplica en la matriz, no en un servidor virtualizado ya.
Aunque el virtualizado, si fuera el caso, hereda de la matriz.


Un saludo !

hgonzale
25/08/2013, 21:39
Ya he leido y no debo estar con OpenVz, es un servidor propio, no virtualizado, es un ks de los de 9 euros (que ya no existen)

hgonzale
25/08/2013, 21:35
Que es openvz amigo? ni idea.

Y el error con el kernel? no con el bind jajaja? jajaja

Mira esto que me ha dado, buscando cosas


yum update --exclude bind

--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for bind-libs which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of bind-libs of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude bind-libs.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of bind-libs installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of bind-libs installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.i686 != 32:bind-libs-9.8.2-0.17.rc1.el6_4.5.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
root@xxxxxx [~]# yum remove bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: bind-libs-9.8.2-0.17.rc1.el6_4.4.i686
Loading mirror speeds from cached hostfile
* base: mirror.ovh.net
* extras: mirror.ovh.net
* updates: mirror.ovh.net
Package(s) bind-libs-9.8.2-0.17.rc1.el6_4.4.i686 available, but not installed.
No Packages marked for removal

Gracias

oceano
25/08/2013, 21:21
Hola, buenas noches Hgonzale.


Estás con OpenVz, verdad ?

Bueno, el problema lo tienes con esto realmente:
# Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed

La solución aquí, posiblemente:
http://wiki.openvz.org/Vzkernel-firmware



Un saludo !

hgonzale
25/08/2013, 21:11
Tengo un problemita que no acabo de entender, y a ver si alguno me puede ayudar un poco.

Estoy haciendo un yum update en un servidorcito que tengo, y tengo un error con el bind de que por algo, creo que tengo librerias doble o no lo se bien, y aqui muestro el error que me da, a ver si alguno me puede ayudar un poco.

Gracias

primero, este es mi servidor


uname -ra
Linux xxxxxxx.kimsufi.com 3.2.13-grsec-xxxx-grs-ipv6-64 #1 SMP Thu Mar 29 09:48:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

--> Finished Dependency Resolution
Error: Package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64 (@updates)
Requires: bind = 32:9.8.2-0.17.rc1.el6_4.4
Removing: 32:bind-9.8.2-0.17.rc1.el6_4.4.x86_64 (@updates)
bind = 32:9.8.2-0.17.rc1.el6_4.4
Updated By: 32:bind-9.8.2-0.17.rc1.el6_4.5.x86_64 (updates)
bind = 32:9.8.2-0.17.rc1.el6_4.5
Available: 32:bind-9.8.2-0.17.rc1.el6.x86_64 (base)
bind = 32:9.8.2-0.17.rc1.el6
Available: 32:bind-9.8.2-0.17.rc1.el6.3.x86_64 (updates)
bind = 32:9.8.2-0.17.rc1.el6.3

Eso es lo ultimo que me sale.

Mas arriba, en referencia al bind tengo esto:



---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package kernel.x86_64 0:2.6.32-358.14.1.el6 will be installed
--> Processing Dependency: kernel-firmware >= 2.6.32-358.14.1.el6 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Processing Dependency: dracut-kernel >= 002-18.git413bcf78 for package: kernel-2.6.32-358.14.1.el6.x86_64
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64
---> Package dracut-kernel.noarch 0:004-303.el6 will be installed
--> Processing Dependency: dracut = 004-303.el6 for package: dracut-kernel-004-303.el6.noarch
---> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be installed
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.17.rc1.el6_4.4 for package: 32:bind-chroot-9.8.2-0.17.rc1.el6_4.4.x86_64


Si alguno me ayuda, se agradece mucho, mil gracias