OVH Community, your new community space.

Ispconfig no consigue resolver DNS


accdl
30/08/2013, 14:17
Muchas gracias a todos por vuestra ayuda, es una alegría la rapidez, sumado a la experiencia y conocimientos que tenéis, con la que respondéis a los distintos post.

Felicidades a todos por ello, un saludo
accdl

accdl
30/08/2013, 14:10
Cita Publicado inicialmente por maxpaynecu
consejo sano nunca des en un foro público tus IPS o nombre de SERVIDORES REALES ..
Gracias, lo tendré en cuenta.


Efectivamente era un problema del bind que no "escuchaba", muchas gracias por todo.


Cita Publicado inicialmente por Guille
En /etc/bind/named.conf.options:

Asegurate que listen-on está así:

Para el que el servidor DNS escuche en cualquier IP.
Si quieres restringirlo por tu IP o tu IP failover la puedes poner en lugar de any.
-
Añado:
Y reinicia bind por supuesto

Guille
30/08/2013, 13:28
En /etc/bind/named.conf.options:

Asegurate que listen-on está así:

listen-on { 127.0.0.1;any; };
Para el que el servidor DNS escuche en cualquier IP.
Si quieres restringirlo por tu IP o tu IP failover la puedes poner en lugar de any.
-
Añado:
Y reinicia bind por supuesto
service bind9 restart

maxpaynecu
30/08/2013, 13:26
tambien fijate en tailf /var/log/syslog | grep named para ver si cuando intenta transferir las zonas da algún error

maxpaynecu
30/08/2013, 13:25
consejo sano nunca des en un foro público tus IPS o nombre de SERVIDORES REALES ..

accdl
30/08/2013, 13:02
Soy un poco novato pero creo que esta todo correcto:

netstat -lp | grep named

tcp 0 0 localhost.locald:domain *:* LISTEN 2541/named
tcp 0 0 localhost.localdoma:953 *:* LISTEN 2541/named
tcp6 0 0 ip6-localhost:domain [::]:* LISTEN 2541/named
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 2541/named
udp 0 0 localhost.locald:domain *:* 2541/named
udp6 0 0 ip6-localhost:domain [::]:* 2541/named

iptables -S

-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
-N fail2ban-dovecot-pop3imap
-N fail2ban-pureftpd
-N fail2ban-sasl
-N fail2ban-ssh
-A INPUT -p tcp -m multiport --dports 110,995,143,993 -j fail2ban-dovecot-pop3imap
-A INPUT -p tcp -m multiport --dports 21 -j fail2ban-pureftpd
-A INPUT -p tcp -m multiport --dports 25 -j fail2ban-sasl
-A INPUT -p tcp -m multiport --dports 22 -j fail2ban-ssh
-A fail2ban-dovecot-pop3imap -j RETURN
-A fail2ban-pureftpd -j RETURN
-A fail2ban-sasl -j RETURN
-A fail2ban-ssh -j RETURN

iptables -L

-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
-N fail2ban-dovecot-pop3imap
-N fail2ban-pureftpd
-N fail2ban-sasl
-N fail2ban-ssh
-A INPUT -p tcp -m multiport --dports 110,995,143,993 -j fail2ban-dovecot-pop3imap
-A INPUT -p tcp -m multiport --dports 21 -j fail2ban-pureftpd
-A INPUT -p tcp -m multiport --dports 25 -j fail2ban-sasl
-A INPUT -p tcp -m multiport --dports 22 -j fail2ban-ssh
-A fail2ban-dovecot-pop3imap -j RETURN
-A fail2ban-pureftpd -j RETURN
-A fail2ban-sasl -j RETURN
-A fail2ban-ssh -j RETURN
root@ks3296918:~# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
fail2ban-dovecot-pop3imap tcp -- anywhere anywhere multiport dports pop3,pop3s,imap2,imaps
fail2ban-pureftpd tcp -- anywhere anywhere multiport dports ftp
fail2ban-sasl tcp -- anywhere anywhere multiport dports smtp
fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain fail2ban-dovecot-pop3imap (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere

Chain fail2ban-pureftpd (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere

Chain fail2ban-sasl (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere

Chain fail2ban-ssh (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere

djbill
30/08/2013, 12:48
Creo recordar cuando realice la mismo instalacion que tu que iptables no viene limpio de serie en el Debian 7 de OVH.

Con iptables -L lo puedes ver

Guille
30/08/2013, 12:35
netstat -lp | grep named
iptables -S

Kilburn
30/08/2013, 12:17
Tu servidor DNS no responde. Eso puede ser o bien porque tienes el servicio parado (mira la parte de monitoring), o bien porque tienes un firewall que está cortando las peticiones.

Siento no poder ayudarte más pero no conozco cómo funciona ISPConfig...

accdl
30/08/2013, 12:07
Resuelto

Buenas tardes;

Soy nuevo en este foro, hace unos días contraté un servidor dedicado de la gama ks, y como no me convenció como venía por defecto, hice su instalación a partir de Debian 7 según http://www.howtoforge.com/perfect-se...ot-ispconfig-3 e instalar RoundCube

Tras configurar la dns (ksxxxxx.kimsufi.com y ns.kimsufi.com), registrar el dominio en el panel OVH (dns secundaria) y registrarla en el panel de Ispconfig: http://img407.imageshack.us/img407/6288/4div.png

Y permitir transferencia a la zona:http://img703.imageshack.us/img703/3405/5t90.png

Además de configurar las IPs en el panel: http://img580.imageshack.us/img580/1360/5h9.png

La página no me resuelve la dirección y éste es el resultado del Dig:

Resultado de las operaciones
dig
; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> xxxxx.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 4685
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;xxxxx.com. IN A

;; Query time: 12 msec
;; SERVER: 10.1.38.3#53(10.1.38.3)
;; WHEN: Fri Aug 30 13:03:07 2013
;; MSG SIZE rcvd: 35
No sé si a alguno se le ocurre alguna idea para echar a andar el servidor, gracias de ante mano.