We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problema con openvpn en KS2G


Guzmanus
09/09/2013, 17:47
Vale, trasteando he descubierto que la ipv6 que me daba era la de mi adaptador TAP. He desactivado en windows el protocolo ipv6 en éste y ahora parece que no suelta el error, a ver si funciona.

Guzmanus
09/09/2013, 16:05
Cita Publicado inicialmente por PacoSS
Prueba a deshabilitar completamente ipv6 de tu servidor.

Depende tu distribución, se hace de una manera o de otra, busca en google.
Nada, añado estas lineas a sysctl
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
Y el error sigue saliendo por mucho que reinicie. He estado mirando y la ipv6 que sale ni siquiera es la de mi servidor. Alguna idea?

PacoSS
08/09/2013, 23:13
Prueba a deshabilitar completamente ipv6 de tu servidor.

Depende tu distribución, se hace de una manera o de otra, busca en google.

Guzmanus
08/09/2013, 22:23
Buenas, estoy teniendo un montón de problemas motandome una VPN con openvpn en un servidor de estos. Lo tengo con apache, un servidor ftp y nada más.

Todo funciona a la perfección durante unos minutos, hasta que empiezan a salir estos errores en el log del servidor openvpn

Sun Sep 8 22:08:35 2013 us=323006 cliente1/147.96.XXX:XXX:1194 MULTI: bad source address from client [fe80::e11a:XXXX:XXXX:XXXX], packet dropped
y las páginas web dejan de cargar. El resto de tráfico funciona bien; los pings van sin problema ni retardo alguno, las descaras en curso siguen fucnionando, pero el resto de webs no cargan absolutamente nada.

Por eso mismo pensaba que era un problema de DNSs, pero vamos, he probado un montón de cosas y nada.

La primera IP la IP desde la que me conecto, y la segunda una ipv6 que no tengo ni zorra de por qué sale. En todos los sitios de internet sale cómo arreglar ese error pero claro, cuando sale que el cliente usa una ipv4. Cuando usa ipv6 sale éste resultado pero no tengo ni zorra de qué hacer

https://forums.openvpn.net/topic11324.html

Este es mi server.conf
port 1194
proto udp
dev tun
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key
dh /etc/openvpn/dh1024.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 10.8.0.1"
push "dhcp-option DNS 8.8.8.8"
keepalive 10 120
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 4
log server.log
y mi client.ovpn
client
dev tun
proto udp
remote 37.xx.xx.xx 1194
resolv-retry infinite
user nobody
group nogroup
persist-key
persist-tun
mute-replay-warnings
ca ca.crt
cert cliente1.crt
key cliente1.key
ns-cert-type server
comp-lzo
verb 3