We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problema con emerge portage en release2 gentoo


jabenitez
05/10/2013, 11:25
Buenos días a todos,

Hoy se me ocurrió hacer un emerge sync y me cargué el portage.... recibía este error:

Código:
!!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
!!! Is the symlink correct? Is your portage tree complete?
Así que hice lo que viene aquí http://guias.ovh.es/printPage/Release2Portage

Pero al crear el enlace simbólico me doy cuenta de que este directorio no existe:

Código:
# rm -rf /etc/make.profile
# ln -sf /usr/portage/profiles/default/linux/amd64/13.0/server /etc/make.profile
Con lo cual lo que hice fue

Código:
 ln -sf /usr/portage/profiles/default/linux/amd64/13.0/desktop /etc/make.profile
Después de eso probé a hacer un emerge portage y recibo el siguiente error:

Código:
!!! One of the following masked packages is required to complete your request:
- sys-apps/portage-2.1.6.7_p1 (masked by: package.mask)
/usr/portage/profiles/releases/13.0/package.mask:
# Andreas K. Huettel  (14 Jan 2013)
# Mask portage versions not supporting EAPI=5

- sys-apps/portage-2.1.11.62 (masked by: required EAPI 2, supported EAPI 1)
- sys-apps/portage-2.1.12.2 (masked by: required EAPI 2, supported EAPI 1)
- sys-apps/portage-2.2.1 (masked by: required EAPI 2, supported EAPI 1)
- sys-apps/portage-2.2.6 (masked by: required EAPI 2, supported EAPI 1)
- sys-apps/portage-2.2.7 (masked by: required EAPI 2, supported EAPI 1)
- sys-apps/portage-9999 (masked by: required EAPI 3, supported EAPI 1)

For more information, see MASKED PACKAGES section in the emerge man page or 
refer to the Gentoo Handbook.
¿Sugerencias para volver a restaurar lo que estaba o solucionar esto?

SOLUCIÓN:

Bueno pues, fue sencillo, el enlace simbólico que tuve que crear a /etc/make.profile fue al directorio -> /usr/portage/profiles/default-linux/amd64/2007.0/desktop

Código:
# ls -al /etc/make.profile
lrwxrwxrwx 1 root root 56 oct  7 10:11 /etc/make.profile -> /usr/portage/profiles/default-linux/amd64/2007.0/desktop
Y ya vuelve a funcionar mi emerge, aunque no pueda tener todo actualizado, al menos vuelve a funcionar