We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problemas con gtld-servers.net y resolucion de ip/dns


Yhoni1
03/11/2013, 22:58
Cita Publicado inicialmente por pepejlr
Te aconsejo que en vez de usar ns.kimsufi.com uses la IP del servidor secundario como ns2.tudominio.com.

Por lo que veo no hay ningún problema al no ser que los root server tarden más en cachear pero si los secundarios no tienen problema entonces no deberias preocuparte en un principio.

Aún así revisa los glue host a ver si están correctamente apuntados a la nueva IP.
Pues parece que, efectivamente, el problema estaba en que no tenía configurado el "glue host".

Yo no entendía la utilidad del "glue host" y no sabía que había que configurar, desde el manager, un glue host indicando cual sería el servidor primario dns y su ip.

Solo unos minutos después de añadir el nombre del host "ns1.networksmon.com" y su ip correspondiente 91.121.82.xx se han actualizados los root servers y ya devuelven la ip actual correcta.
admin@ks2698x:~$ dig @a.gtld-servers.net networksmon.com

; <<>> DiG 9.7.0-P1 <<>> @a.gtld-servers.net networksmon.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20111
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;networksmon.com. IN A

;; AUTHORITY SECTION:
networksmon.com. 172800 IN NS ns.kimsufi.com.
networksmon.com. 172800 IN NS ns1.networksmon.com.

;; ADDITIONAL SECTION:
ns.kimsufi.com. 172800 IN AAAA 2001:41d0:3:1c7::1
ns.kimsufi.com. 172800 IN A 213.186.33.199
ns1.networksmon.com. 172800 IN A 91.121.82.xx

;; Query time: 114 msec
;; SERVER: 192.5.6.30#53(192.5.6.30)
;; WHEN: Sun Nov 3 22:54:27 2013
;; MSG SIZE rcvd: 136
El problema está solucionado .

Ahora seguiremos con otros.

Gracias a todos por estar ahí.

pepejlr
03/11/2013, 13:25
Te aconsejo que en vez de usar ns.kimsufi.com uses la IP del servidor secundario como ns2.tudominio.com.

Por lo que veo no hay ningún problema al no ser que los root server tarden más en cachear pero si los secundarios no tienen problema entonces no deberias preocuparte en un principio.

Aún así revisa los glue host a ver si están correctamente apuntados a la nueva IP.

Yhoni1
02/11/2013, 23:11
Cita Publicado inicialmente por pepejlr
Estás teniendo algún tipo de problema con la actualización de las DNS cuando haces un cambio?

Yo la zona de los root server nunca la he tocado y me va bien... No sé si has modificado ese fichero de zonas root.
Todas las dns que he configurado se han propagado correctamente.

Es como si los root server tuviesen cacheada la ip antigua de mi servidor primario y no la actualizaran a la nueva.

Cuando hago un dig utilizando uno de los root server me responde así:
admin@ks2698x:~$ dig @a.gtld-servers.net networksmon.com

; <<>> DiG 9.7.0-P1 <<>> @a.gtld-servers.net networksmon.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8860
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;networksmon.com. IN A

;; AUTHORITY SECTION:
networksmon.com. 172800 IN NS ns.kimsufi.com.
networksmon.com. 172800 IN NS ns1.networksmon.com.

;; ADDITIONAL SECTION:
ns.kimsufi.com. 172800 IN AAAA 2001:41d0:3:1c7::1
ns.kimsufi.com. 172800 IN A 213.186.33.199
ns1.networksmon.com. 172800 IN A 91.121.141.xxx (todo es correcto menos esta ip que es antigua y hace meses que la cambié. La actual es 91.121.82.xx)

;; Query time: 111 msec
;; SERVER: 192.5.6.30#53(192.5.6.30)
;; WHEN: Sat Nov 2 22:56:57 2013
;; MSG SIZE rcvd: 136
Y en el archivo de zona del dominio netwoksmon.com tengo una linea A:

ns1 IN A 91.121.82.xx
Y si hago un dig al servidor secundario me responde correctamente:

admin@ks2698x:~$ dig @ns.kimsufi.com ns1.networksmon.com

; <<>> DiG 9.7.0-P1 <<>> @ns.kimsufi.com ns1.networksmon.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27799
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;ns1.networksmon.com. IN A

;; ANSWER SECTION:
ns1.networksmon.com. 32719 IN A 91.121.82.xx

;; Query time: 4 msec
;; SERVER: 213.186.33.199#53(213.186.33.199)
;; WHEN: Sat Nov 2 23:07:46 2013
;; MSG SIZE rcvd: 53
¿ esto alumbra alguna solución ?

pepejlr
02/11/2013, 22:39
Estás teniendo algún tipo de problema con la actualización de las DNS cuando haces un cambio?

Yo la zona de los root server nunca la he tocado y me va bien... No sé si has modificado ese fichero de zonas root.

Yhoni1
02/11/2013, 20:10
Cita Publicado inicialmente por kennysamuerto
¿Usas panel de control? ¿Plesk?

Mira la configuracion de la zona DNS del dominio.

Saludos
Uso el Manager v3 para indicar en la configuración de mi servidor privado cual será el servidor secundario que se utilizará en los dominios alojados y también, desde el manager v3 , configuro cual va a ser el servidor primario y secundario del dominio. El archivo de zona está configurado directamente sobre el Bind9 instalado en el servidor primario que es un kemsirve privado.

Parece correr sin errores , y en un principio, los root servers se actualizaron con la primera ip correspondiente a ns1.networksmon.com pero desde que cambié de servidor no se ha actualizado la ip nueva en los root servers.

¿Alguna sugerencia ? :confused:

kennysamuerto
02/11/2013, 19:13
¿Usas panel de control? ¿Plesk?

Mira la configuracion de la zona DNS del dominio.

Saludos

Yhoni1
02/11/2013, 10:26
HOla, tengo un problema que no se resolver con las dns, tengo un KS con Bind instalado y corriendo correctamente, o eso parece, uno de mis dominios "networksmon.com" utiliza como servidor primario el propio ks y como secundario el de ovh ns.kimsufi.com y los dos resuelven correctamente.

El problema está en que mi servidor primario "ns1.networksmon.com" tiene la ip actual 91.121.82.xx y anteriormente tenía otro alojamiento con ip 91.121.141.xx y parece que , desde hace más de un año que lo cambié, los root servers a/b/c/d/e/f/g/h.gtld-servers.net no se han enterado del cambio de ip y siguen resolviendo la ip antigua.

¿ Como puede ser que los servidores primario y secundario resuelvan correctamente y los root servers no se enteren de la actualización de la ip?.

¿ alguien sabe porque no se propagan las dns hasta ese nivel ?¿ sería necesario forzar la actualización de alguna manera ?

Gracias.