OVH Community, your new community space.

Problema con la velocidad via FTP


pepejlr
10/12/2013, 23:37
Cita Publicado inicialmente por uiketekaes
Hola, hace años que tengo un servidor dedicado en OVH, hasta que caducó y debido al sold out, estoy esperando a unos más baratos de los que hay ahora.

Pues bien la necesidad me ha hecho cogerlo en otra web, y me pasa una cosa muy curiosa que antes a veces tb me pasaba en OVH y no se de quien es el problema.

Vereis si me bajo 1 solo archivo FTP a mi casa no funciona al maximo posible (10 MB/s) si no que me funciona de forma variable, a veces a 2 MB/s a veces a 4 MB/s y sin embargo si pongo varios a la vez consigo la velocidad total de mi linea.

Cosas a tener en cuenta y que preguntareis xD:

-El servidor esta sin consumir RED por lo que no es normal que teniendo ethernet a 100mbps me de igual 20 o 30.
-Mi proveedor de internet no es dado que de otros FTP o webs online bajo archivos al maximo que da mi linea.
-Le pasa a mas amigos mios .
-No siempre pasa, pero casi siempre.

Podria entender que de alguna forma priorizaran el trafico a horas punta, pero no entiendo que si pones mas transferencias a la vez no se divida la velocidad de bajada si no que se sume.


Sabeis el motivo? Os ha pasado? Puede ser la distribucion de linux?

Muchisimas gracias en lo que podais ayudar, porque esto me trae de cabeza.
A mi me solia pasar también pero no siempre. Es como si de algún modo limitan el tráfico por conexiones el proveedor de tu servidor (Ni idea de los motivos) pero me pasaba en dias sueltos y rara vez.

Cita Publicado inicialmente por diegoabel
Me suena que tienes un ADSL de HASTA 10Mb
Si vas a ayudar de esa forma con chorradas, mejor ni postees.

trasno
10/12/2013, 18:42
Nunca he usado proftp, pero viendo la documentación:

SocketOptions
Name
SocketOptions -- Tune socket-level options
Synopsis

SocketOptions [ [maxseg ] [rcvbuf ] [sndbuf ]]

Default

None

Context

"server config",

Module

mod_core

Compatibility

1.2.9rc1 and later

Description

The rcvbuf and sndbuf parameters are used for setting the TCP send/receive window sizes. The maxseg parameter is used for setting a MSS (Maximum Segment Size) via setsockopt(2)'s TCP_MAXSEG option. If the MSS is larger than the interface's MTU, it is ignored and has no effect.

If the send/receive window size is increased, it is helpful for performance to increase the internal buffer size. See the --enable-buffer-size argument to ./configure.
El tamaño máximo que podrías usar es 1460, si lo encriptas con ssl, tendría que ser menor. El tamaño de los bufferes, pues en principio cuanto mayor mejor.
Para realizar pruebas tanto de mss como de perdida de paquetes, puedes utilizar iperf.

uiketekaes
09/12/2013, 21:48
Cita Publicado inicialmente por trasno
Hola,

Parece un problema de la ventana TCP. Podría explicarse que otros servidores funcione bién, si la latencia es menor. Otra posibilidad sería que la velocidad de las conexiones se reduzca por perdida de paquetes, lo que explicaría que con varias conexiones en paralelo, la velocidad aumente.
Como puedo comprobar si tengo perdida de paquetes? . Tengo que hacerlo desde el servidor hacia mi casa y de mi casa al servidor?
Como os he comentado a otro amigo tb le pasa, el tiene ONO y yo jazztel.

Me dijeron que usara MTR en linux para lo de la perdida de paquetes y me dio en los saltos 0% de perdida
La latencia es unos 35 ms (esta en Francia).
Uso el proftp y he visto algo de tcpwindows sice e intento ponerla a 65XXX ....y me da error.
Uso SO linux.

Alguna web para informarme, manual o tutorial?

Muchisimas gracias

trasno
09/12/2013, 21:34
Hola,

Parece un problema de la ventana TCP. Podría explicarse que otros servidores funcione bién, si la latencia es menor. Otra posibilidad sería que la velocidad de las conexiones se reduzca por perdida de paquetes, lo que explicaría que con varias conexiones en paralelo, la velocidad aumente.

uiketekaes
09/12/2013, 16:55
Cita Publicado inicialmente por diegoabel
Me suena que tienes un ADSL de HASTA 10Mb
Gracias por la respuesta pero que ancho te has quedao xDD

Espero respuestas un poco más serias....y no, no tengo ni adsl ni 10 megas(tengo 100 megas y ftth, lo de 10MB/s que decia yo antes son REALES) de linea, y el servidor tiene 100 mbps (simetricos)

un saludo

diegoabel
09/12/2013, 16:30
Me suena que tienes un ADSL de HASTA 10Mb

uiketekaes
09/12/2013, 16:11
Hola, hace años que tengo un servidor dedicado en OVH, hasta que caducó y debido al sold out, estoy esperando a unos más baratos de los que hay ahora.

Pues bien la necesidad me ha hecho cogerlo en otra web, y me pasa una cosa muy curiosa que antes a veces tb me pasaba en OVH y no se de quien es el problema.

Vereis si me bajo 1 solo archivo FTP a mi casa no funciona al maximo posible (10 MB/s) si no que me funciona de forma variable, a veces a 2 MB/s a veces a 4 MB/s y sin embargo si pongo varios a la vez consigo la velocidad total de mi linea.

Cosas a tener en cuenta y que preguntareis xD:

-El servidor esta sin consumir RED por lo que no es normal que teniendo ethernet a 100mbps me de igual 20 o 30.
-Mi proveedor de internet no es dado que de otros FTP o webs online bajo archivos al maximo que da mi linea.
-Le pasa a mas amigos mios .
-No siempre pasa, pero casi siempre.

Podria entender que de alguna forma priorizaran el trafico a horas punta, pero no entiendo que si pones mas transferencias a la vez no se divida la velocidad de bajada si no que se sume.


Sabeis el motivo? Os ha pasado? Puede ser la distribucion de linux?

Muchisimas gracias en lo que podais ayudar, porque esto me trae de cabeza.