OVH Community, your new community space.

mi sevidor ks falla más que una escopeta de feria


tfwfactory
15/05/2014, 14:52
Parece que tienen un cron para hacer un backup de o base de datos o de archivos del sistema , si el backup es muy grande el problema es que la CPU se te disparará y el servidor se puede volver inestable totalmente , debes ver como tienes configurado este backup

Tambien es el proceso del antivirus clam el que te está fastidiando el tema , debe estar recorriendo la máquina constantemente y consume mucha cpu , deberías desactivarlo y usar un detector en todo caso de rootkits como el rootkit hunter , desinstala clam o configura el scaneo


Saludos

tuas2k
15/05/2014, 10:40
hola tfwfactory y gracias. captura de htop. el proceso amavis se está llevando el 88%. no tengo claro para qué sirve, pero creo que está relacionado con correo, no sé cómo pararlo o atenuarlo. debajo del pantallazo te dejo otra captura sobre la info del server

CPU[||||||||||||||||||||||||100.0%] Tasks: 89, 106 thr; 2 running
Mem[||||||||||||||||||||875/1986MB] Load average: 2.08 1.79 1.85
Swp[| 6/510MB] Uptime: 07:10:09
Hostname: ks34331.kimsufi.com

PID USER PRI NI VIRT RES SHR S CPU% MEM% TIME+ Command
15385 amavis 20 0 299M 258M 6668 R 88.0 13.0 0:20.30 /usr/bin/clamscan
5552 root 20 0 1960 260 168 S 7.0 0.0 35:07.94 ttymon tymon
15390 root 20 0 26444 2000 1348 R 5.0 0.1 0:01.64 htop
15107 amavis 20 0 206M 90896 3996 S 0.0 4.5 0:01.68 amavisd (ch1-1510
15387 bind 20 0 21700 1560 400 S 0.0 0.1 0:00.09 /usr/sbin/named -
15388 web1 20 0 231M 41976 9624 S 0.0 2.1 0:02.39 /usr/bin/php-cgi
13631 web1 20 0 233M 42116 9780 S 0.0 2.1 0:13.40 /usr/bin/php-cgi
4565 mysql 20 0 357M 51680 3704 S 0.0 2.5 0:46.70 /usr/sbin/mysqld
27211 mysql 20 0 357M 51680 3704 S 0.0 2.5 0:00.75 /usr/sbin/mysqld
9496 mysql 20 0 357M 51680 3704 S 0.0 2.5 0:01.55 /usr/sbin/mysqld
1 root 20 0 8564 668 608 S 0.0 0.0 0:01.34 init [2]
1727 root 16 -4 17020 372 288 S 0.0 0.0 0:00.36 udevd --daemon
3069 root 20 0 75584 15884 1484 S 0.0 0.8 0:00.96 [kjournald]
3076 root 20 0 73500 14356 312 S 0.0 0.7 0:00.00 [kjournald]
3728 root 20 0 115M 1720 888 S 0.0 0.1 0:04.31 /usr/sbin/rsyslog
3729 root 20 0 115M 1720 888 S 0.0 0.1 0:01.77 /usr/sbin/rsyslog

con un cat /proc/meminfo, obtengo esto

MemTotal: 2034276 kB
MemFree: 597964 kB
Buffers: 40740 kB
Cached: 480068 kB
SwapCached: 5596 kB
Active: 815228 kB
Inactive: 482420 kB
Active(anon): 487240 kB
Inactive(anon): 291012 kB
Active(file): 327988 kB
Inactive(file): 191408 kB
Unevictable: 0 kB
Mlocked: 0 kB
SwapTotal: 523260 kB
SwapFree: 516860 kB
Dirty: 144 kB
Writeback: 0 kB
AnonPages: 771308 kB
Mapped: 34796 kB
Shmem: 1412 kB
Slab: 102396 kB
SReclaimable: 53012 kB
SUnreclaim: 49384 kB
KernelStack: 2000 kB
PageTables: 15124 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 1540396 kB
Committed_AS: 1682928 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 271192 kB
VmallocChunk: 34359464932 kB
DirectMap4k: 3840 kB
DirectMap2M: 2076672 kB

y de lo que me he dado cuenta es que, constante mente estoy recibiendo correo al root en estos términos:

From root@ks34331.kimsufi.com Thu May 15 11:38:59 2014
Return-Path:
X-Original-To: root@ks34331.kimsufi.com
Delivered-To: root@ks34331.kimsufi.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by ks34331.kimsufi.com (Postfix) with ESMTP id E8F37386A096
for ; Thu, 15 May 2014 11:38:59 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ks34331.kimsufi.com
Received: from ks34331.kimsufi.com ([127.0.0.1])
by localhost (ks34331.kimsufi.com [127.0.0.1]) (amavisd-new, port 10024)
with ESMTP id 99bca6mgjEZU for ;
Thu, 15 May 2014 11:37:52 +0200 (CEST)
Received: by ks34331.kimsufi.com (Postfix, from userid 0)
id 99834386A119; Thu, 15 May 2014 07:36:02 +0200 (CEST)
From: root@ks34331.kimsufi.com (Cron Daemon)
To: root@ks34331.kimsufi.com
Subject: Cron /usr/local/sbin/dbbackup (failed)
Content-Type: text/plain; charset=ISO-8859-1
X-Cron-Env:

de nuevo, gracias

tfwfactory
15/05/2014, 01:34
Hazle una captura de imagen a lo que te muestra el HTOP , pero mira el % de CPU y que procesos están dando alto , pueden ser varias cosas , tambien sería bueno saber que tienes en el server , cuantas webs , capacidad del server , etc , asi pues vemos si puede ser de la RAM que se queda corta , etc , si usas webs como wordpress o cms por ejemplo el uso de sistemas de caché como APC , te bajará el consumo , de vez en cuando mira los recursos de forma rápida con el comando free -m que te da una idea de la RAM libre y ves acorde a esto si está muy ocupada

Pero primero sería ver la captura con una hora que por ejemplo te esté tirando más el server y luego pues saber la información adicional , un saludo

tuas2k
14/05/2014, 11:12
gracias tfwfactory, lo que creo que pasa es que el en servidor se carga excesivamente (no sé de qué), la cpu, luego la ram y luego la swap, y entonces no responde a nada. me interesaría saber, y no sé si me puedes ayudar aquí, es qué es lo que carga tanto la cpu. supongo que será algún proceso pero no sé cómo verlo. he instalado htop, pero no sé leerlo.

antonio

tfwfactory
14/05/2014, 02:39
Eso no es un error en si mismo , si mal no recuerdo esa es la ip de monitoring de OVH , algo en tu servidor está bloqueando esa ip o su acceso para verificar si tu server está ok o no , si no quieres que tu servidor sea monitorizado por ovh puedes quitar el monitoring pero perderás la opción de ver como está o bien pones un monitoring externo a ovh

Si no quieres recibir ese mensaje es eso o bien ver si hay algún firewall bloqueando lo que es esa ip para monitorizar , lo cual debe ir asociado a algún puerto , si tienes csf debes autorizar el uso de ese puerto , etc

Si ovh por otro lado ve que no hay ping entiende que el servidor da fallo aunque en este caso si todas tus webs siguen operativas , el fallo no existe , es tema de monitoring , con arreglar eso en el sentido de anularlo o bien permitirlo correctamente , ya no recibirás ese fallo

Un saludo !!!

tuas2k
13/05/2014, 20:57
gracias tfwfactory por la rápida contestación.
que errores...: no sé, lo que me dice ovh es

Logs:
----------------------
PING ks34331.kimsufi.com (94.23.250.116) from 213.186.33.13 : 56(84) bytes of data.
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable

pero por qué? ni idea. probablemente por lo mismo por lo que anda lento. necesito saber por qué, pero no sé cómo.

sistema operativo: debian lenny
panel de control: isp config
tres blogs con wordpress
un moodle

lo que sí te puedo decir es que la cpu está cargadisima. un 80% la mayor parte del tiempo y con el tiempo se me carga la ram y luego la swap..., la da el "jamacuco" y adios muy buenas. lo he medio resuelto programando dos reboots al dia. con eso voy tirando y las más de las veces llega al reboot sin haberse "petado". pero como digo, no sé por qué está tan cargado: no sé si es defecto de la maquina (el servidor) o del animal (o sea, yo).

de nuevo muchas gracias

tfwfactory
13/05/2014, 19:38
Podrias indicar que errores y las características de tu máquina , etc , para poder ayudarte , como el sistema operativo , panel de control , etc

Saludos

tuas2k
13/05/2014, 11:44
pués eso, que tengo un kimsufi y ultimamente recibo, dia sí, dia no, una notificación de error y otra de fin de error por parte de ovh. la verdad es que va bastante lentorro, tengo montados 3 páginas y una plataforma moodle (educativa), y no sé por donde empezar para intentar solucionar las dos cosas: que no dé tantos errores (que no sé de que son porque ovh no me da la información, al ser un kimsufi) y que no vaya tan lento. cualquier ayuda será bienvenida.

gracias
antonio