OVH Community, your new community space.

403 Forbidden - nginx en Plesk


Artifexsoft
09/06/2014, 11:02
Cita Publicado inicialmente por gomhermar
Eso seguramente sea un problema con los ficheros de configuración de Apache o Nginx. Prueba con estos comandos para volver a generarlos:
Buenas gomhermar.

Las rutas que me comentas no existe en mi máquina.
Las más parecidas son
#/opt/psa/bin
#/opt/psa/admin/sbin
En ninguna de estas rutas se encuntran ni reconfigurator ni httpdmng.
Este sería el contenido de /opt/psa/bin
Código:
apache_cleanup.sh  chrootsh  php-cli  sw-engine-pleskrun
Y el contenido de /opt/psa/admin/sbin
Código:
apache-config           mail_auth_view           poppassd
apache_control_adapter  mailbox_usage            proftpd-config
autoinstaller           mail_handlers_control    proftpd_control_adapter
backup-agent            mailmng                  proftpd_quota_adapter
buildmodule.sh          mailmng-black-white      quotacheck_wrapper.sh
cfmng                   mailmng-core             relink-vhost-logs
chrootmng               mailmng-domain           sappmng
copy_file               mailmng-mailname         serverconf
crontabmng              mailmng-server           site-copy
deployer                mailmng-service          spammng
dirmng                  mailnames_lc             statistics_collector
dnsmng                  mailqueuemng             statistics_log_processor
filemng                 mail_responders_control  sysinfo
ftp_filemng             mchk                     tomcatmng
ftpwho                  mk_reverse_zone          update_plesk_completion
get_dir_size            nginx-config             update-vhosts-structure
get_fs                  nginx_control            usermng
glmng                   nginx_proxy              vhostmng-content
httpd_modules_ctl       packagemng               vhostmng-structure
ifmng                   pdmng                    websrvmng
kavmng                  php_handlers_control     web_statistic_executor
libxml-proxy            phpinimng                webstatmng
listmng                 pipelog                  wrapper
logrot_mng              pkey2rsapkey
¿Me serviría algo de esto?

Saludos y gracias!!

gomhermar
08/06/2014, 23:29
Eso seguramente sea un problema con los ficheros de configuración de Apache o Nginx. Prueba con estos comandos para volver a generarlos:

# /usr/local/psa/bin/reconfigurator --autoconfigure
# /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
# /etc/init.d/nginx restart

tfwfactory
06/06/2014, 16:18
Al no poder acceder a Plesk la única solución es la Linea de Comando , a no ser que puedas acceder al WebMail , no se si puedes acceder

La ruta es con Qmail : /var/qmail/mailnames/domain.com/username/

Puedes hacer una copia mediante SSH o con FileZilla , a gusto del consumidor

Despues una vez reinstalado puedes pasar esos archivos , pero antes crea la cuenta en el nuevo servidor y debes dar permisos de usuario , es decir si el usuario fuese root para esos archivos deberias darle permisos de usuario root , etc , o lo que tu tengas asignado

~# chown popuseropuser /var/qmail/mailnames///Maildir/cur/*
~# chmod 600 /var/qmail/mailnames///Maildir/cur/

Creo que sale una carita ----- mira el código fuente , .............


Saludos

Artifexsoft
06/06/2014, 15:22
Ok, muchas gracias.

Una última duda: si reinstalamos plesk, ¿perdemos también todo lo del servidor de correo?

Saludos!!

tfwfactory
06/06/2014, 14:16
OVH no te da ningún backup a no ser que lo contrates , eso lo tienes que hacer tu

Para hacer un backup puedes hacerlo desde consola fácilmente


tar -cvf /carpeta destino/backup.tar /home/carpeta a copiar

Para un BackUp completo de tus bases de datos :

mysqldump -u root -p -h localhost --all-databases > /carpeta destino/all-databases.sql


Con esto lo tendrás todo fácilmente , te lo bajas y listo , eso si cambia los paths o ruta por las tuyas

Son comandos que te permitirán en cosa de unos segundos tener un completo respaldo de toda tu carpeta con todas las webs del tirón como de tus bases de datos , despues la base de datos podrás recuperarlas desde la linea de comandos , o bien puedes bajar base a base y no copiarla toda , una recomendación que te doy es subir la db en local con un servidor tipo Appserv y luego bajas lo que te interesa o no y lo pasas al server , es cuestión de gustos


Saludos

Artifexsoft
06/06/2014, 13:35
Ok,
Instalamos Plesk, porque OVH nos lo vendió y nos cobró por instalarlo.

En cuanto a la reinstalación, ¿Qué datos se perderían?
Los subdominios instalados y esas cosas??

Y otra alternativa a la reinstalación podría ser recuperar un backup.
¿En OVH cuentan con algún tipo de backup de las máquinas enteras como el que hay en Amazon?

Saludos y gracias!!

tfwfactory
06/06/2014, 13:29
Yo te recomendaría varias cosas , una de ellas sería no usar Plesk , a mi en lo particular no me gusta nada , da muchos problemas y mucho más en los upgrades
Te recomendará ZpanelX , gratis y va como un tiro , es uno de los paneles Open Source que usamos y es increible

En cuanto a Plesk reinstalarlo , sería la mejor opción , ya que el soporte de Plesk no es nada bueno , por otro lado la reinstalación implica perder los datos , por ello lo mejor será que hicieses un backup de lo que tengas y a posteriori hicieses la reinstalación , sin duda es la mejor opción para no seguir perdiendo tiempo , o bien otra opción ya que tus webs funcionan es adquirir un VPS temporal en OVH , instalar el sistema , puede ser ZpanelX e ir pasando las webs de forma gradual , de este modo no perderás apenas tiempo

Yo me cambiaría de panel pero ya es cosa de gustos claro


Saludos !!!

Artifexsoft
06/06/2014, 13:09
Hola,
He reinstalado PEAR y sigue sin funcionar.
El PEAR aparentemente funciona.
Creo que lo que está ocurriendo es que los archivos de Plesk no se encuentran donde deberían estar.
Tengo esa creencia por esta linea del log anterior
Código:
===> Checking for previous installation ... not found.
¿Reinstalar Plesk de nuevo podría ser una solución?
¿Qué consecuencias podría tener una reinstalación?
Por otro lado el horde tampoco me funciona.

Saludos!!

tfwfactory
06/06/2014, 12:29
Como plesk ha cambiado la estructura en sus últimas versiones en los upgrades se dan problemas , parece que puede ser un problema con PEAR

Haz lo que pone aqui para reinstalar PEAR :


Disculpa esto es para Windows :

http://kb.parallels.com/es/995

La correcta sería esta , como es extenso te dejo el link :

https://kb.mediatemple.net/questions...your+server#gs


Asegúrate aun asi de que PEAR funcione en tu server o esté instalado en la ruta precisa

Reinicia todo despues

Intenta acceder al admin de Plesk

Si no puedes acceder al admin de Plesk , Inicia la reparación otra vez y mira si esta vez te tira problemas en el log , si se da todo bien , intenta acceder a Plesk otra vez


Saludos

Artifexsoft
06/06/2014, 12:07
Este es el contenido del /tmp/plesk_11.5.30_repair.log:
Código:
**** Product repair started.

===> Checking for previous installation ... not found.
Started bootstrapper repair procedure. This may take a while.
Certain actions may be skipped if not applicable.

 Trying to start service mysql... /usr/sbin/mysqld (pid 15590) is running...
done
 Trying to establish test connection... connected
done
 Trying to find psa database... version is 011005030
Version is OK, no need to create psa database.
 Trying to backup MySQL database... done
 MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.-11.5.30.20140605-222735.dump.gz
 Finishing up upgrade procedures and rerunning previously failed upgrade actions...
===> Cumulative Plesk database upgrade and repair (revertable stage) has been started.
Upgrade or repair for 'core' (stage 'prep') is not required
===> Preparing Plesk database upgrade (revertable stage).
 Trying to resolve hostname 'ks311889.kimsufi.com' and validate its IP address... done

 Trying to set psa database version to 011005030... done
===> Cumulative upgrade and repair of Plesk database (revertable stage) has been completed.
===> Cumulative Plesk upgrade and repair (final stage) has been started.
Upgrade or repair for 'core' (stage 'post') is not required
===> Preparing Plesk upgrade (final stage).
===> Cumulative upgrade and repair of Plesk (final stage) has been completed.
 Trying to upgrade APS controller database... ===> Cumulative APS controller database (apsc) upgrade and repair has been started.
Upgrade or repair for 'apsc' (stage 'db') is not required
 Trying to backup MySQL database... done
 MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.apsc.-11.5.30.20140605-222736.dump.gz
===> Upgrade and repair of APS controller database has been completed.
done
 Trying to upgrade and repair SpamAssassin service configuration... Upgrade or repair for 'spamassassin' (stage 'files') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (prep stage)... Upgrade or repair for 'courier_imap' (stage 'prep') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (post stage)... Upgrade or repair for 'courier_imap' (stage 'post') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (bootstrapper-post stage)... Upgrade or repair for 'courier_imap' (stage 'bootstrapper-post') is not required
done
 Trying to condrestart service courier-imapd... done
 Trying to condrestart service courier-imaps... done
 Trying to condrestart service courier-pop3d... done
 Trying to condrestart service courier-pop3s... done
 Trying to upgrade and repair Horde webmail configuration... 
ERROR while trying to act on PEAR packages - description directory is not specified or does not exist
Check the error reason(see log file: /tmp/plesk_11.5.30_repair.log), fix and try again

Can't handle upgrader critical failure - upgrader state is broken. Probably a programming error.

===> Restoring database from backup /var/lib/psa/dumps/mysql.preupgrade.-11.5.30.20140605-222735.dump.gz


**** Product repair failed.

*****  problem report *****
ERROR while trying to act on PEAR packages - description directory is not specified or does not exist
Check the error reason(see log file: /tmp/plesk_11.5.30_repair.log), fix and try again
STOP Bootstrapper 11.5.30 repair AT Thu Jun  5 22:28:52 CEST 2014
Saludos

tfwfactory
06/06/2014, 11:53
Las cosas fueron bien pero hay un componente o algo que está fastidiando la recuperación , que te dice en el log : (see log file: /tmp/plesk_11.5.30_repair.log)

Saludos

Artifexsoft
06/06/2014, 08:16
Este es el log completo:
Código:
**** Product repair started.

===> Checking for previous installation ... not found.
Started bootstrapper repair procedure. This may take a while.
Certain actions may be skipped if not applicable.

 Trying to start service mysql... /usr/sbin/mysqld (pid 15590) is running...
done
 Trying to establish test connection... connected
done
 Trying to find psa database... version is 011005030
Version is OK, no need to create psa database.
 Trying to backup MySQL database... done
 MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.-11.5.30.20140605-222735.dump.gz
 Finishing up upgrade procedures and rerunning previously failed upgrade actions...
===> Cumulative Plesk database upgrade and repair (revertable stage) has been started.
Upgrade or repair for 'core' (stage 'prep') is not required
===> Preparing Plesk database upgrade (revertable stage).
 Trying to resolve hostname 'ks311889.kimsufi.com' and validate its IP address... done

 Trying to set psa database version to 011005030... done
===> Cumulative upgrade and repair of Plesk database (revertable stage) has been completed.
===> Cumulative Plesk upgrade and repair (final stage) has been started.
Upgrade or repair for 'core' (stage 'post') is not required
===> Preparing Plesk upgrade (final stage).
===> Cumulative upgrade and repair of Plesk (final stage) has been completed.
 Trying to upgrade APS controller database... ===> Cumulative APS controller database (apsc) upgrade and repair has been started.
Upgrade or repair for 'apsc' (stage 'db') is not required
 Trying to backup MySQL database... done
 MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.apsc.-11.5.30.20140605-222736.dump.gz
===> Upgrade and repair of APS controller database has been completed.
done
 Trying to upgrade and repair SpamAssassin service configuration... Upgrade or repair for 'spamassassin' (stage 'files') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (prep stage)... Upgrade or repair for 'courier_imap' (stage 'prep') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (post stage)... Upgrade or repair for 'courier_imap' (stage 'post') is not required
done
 Trying to upgrade and repair Courier-IMAP services configuration (bootstrapper-post stage)... Upgrade or repair for 'courier_imap' (stage 'bootstrapper-post') is not required
done
 Trying to condrestart service courier-imapd... done
 Trying to condrestart service courier-imaps... done
 Trying to condrestart service courier-pop3d... done
 Trying to condrestart service courier-pop3s... done
 Trying to upgrade and repair Horde webmail configuration... 
ERROR while trying to act on PEAR packages - description directory is not specified or does not exist
Check the error reason(see log file: /tmp/plesk_11.5.30_repair.log), fix and try again

Can't handle upgrader critical failure - upgrader state is broken. Probably a programming error.

===> Restoring database from backup /var/lib/psa/dumps/mysql.preupgrade.-11.5.30.20140605-222735.dump.gz


**** Product repair failed.

*****  problem report *****
ERROR while trying to act on PEAR packages - description directory is not specified or does not exist
Check the error reason(see log file: /tmp/plesk_11.5.30_repair.log), fix and try again
Saludos!!

tfwfactory
05/06/2014, 22:12
Qué pone el log /tmp/plesk_11.5.30_repair.log ?

Saludos

Artifexsoft
05/06/2014, 21:33
Cita Publicado inicialmente por tfwfactory
Si no hay solución hasta el momento , lo mejor es intentar reparar Plesk , dependiendo de tu versión de Plesk , haz esto :


Si tu versión es la 11.5 , cámbialo si es otra


Saludos
No funciona.
Este es el log del error de/tmp/plesk_11.5.30_repair.log
Código:
**** Product repair failed.

*****  problem report *****
ERROR while trying to act on PEAR packages - description directory is not specified or does not exist
Check the error reason(see log file: /tmp/plesk_11.5.30_repair.log), fix and try again
¿Qué puedo hacer?

Artifexsoft
05/06/2014, 16:57
Ok, esta noche pruebo.

Saludos y Gracias!!

tfwfactory
05/06/2014, 16:52
Si no hay solución hasta el momento , lo mejor es intentar reparar Plesk , dependiendo de tu versión de Plesk , haz esto :
/usr/local/psa/bootstrapper/pp11.5.30-bootstrapper/bootstrapper.sh repair
Si tu versión es la 11.5 , cámbialo si es otra


Saludos

Artifexsoft
05/06/2014, 16:47
Cita Publicado inicialmente por tfwfactory
Eso que me pones es el auto instalador que se ha descargado a root , entonces es que si hiciste un upgrade a Plesk 11 no ?

Saludos
Creo recordar que la última versión que teniamos instalada era la 11.5
El plesk estaba configurado para que se instalasen las actualizaciones automáticamente.

Artifexsoft
05/06/2014, 16:45
Con Chrome tampoco funciona.

En mi server /usr/local/psa/admin no existe.
Lo más parecido es /opt/psa/admin y tampoco hay ningún archivo. este sería su contenido:
Código:
.  ..  archives  bu_pubkey.txt  domains  images  locales  migration.log  skins  theme
Saludos!!

tfwfactory
05/06/2014, 16:41
Eso que me pones es el auto instalador que se ha descargado a root , entonces es que si hiciste un upgrade a Plesk 11 no ?

Saludos

tfwfactory
05/06/2014, 16:36
Mira por curarnos en salud , porque a veces pasa que da error y la página se queda en caché en Firefozx ya que veo que es el que usas

Abre el Google Chrome u otro que uses y mira si te da el mismo error accediendo asi :

https://Tu ip443
https://Tu ip443/login_up.php3

Vacia la caché antes de los navegadores y tambien haz lo mismo si puede ser accediendo desde un proxy para descartar esto

Accede tambien a /usr/local/psa/admin/ y haz un list con ls-a de archivos a ver si sale login_up.php3

A lo mejor hay que reinstalar Plesk o se han corrompido archivos , si faltan hay un fix que puede solucionarlo


Saludos

Artifexsoft
05/06/2014, 16:30
El login_up.php3 no está donde me comentas.
haciendo locate se encuentra en /root/parallels/PSA_11.5.30/microupdates/MU44/common/htdocs/login_up.php3
Mi S.O es ubuntu 12.04

Artifexsoft
05/06/2014, 16:27
panels.log
Código:
[04-Jun-2014 10:51:56 Europe/Berlin] PHP Fatal error:  Class 'Doctrine\ORM\Query\Parser' not found in /opt/plesk-billing/thirdparty-libs/doctrine-orm/Doctrine/ORM/Query.php on line 229
root@ks311889:/opt/psa/admin/logs# tail -30 panel.log 

stdout:
filemng: stat failed: No such file or directory

System error 2: No such file or directory


stderr:
filemng: stat failed: No such file or directory

System error 2: No such file or directory

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 38
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(60): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(26): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction))
#2 /opt/psa/admin/plib/Service/Agent.php(140): Service_Agent_Transport_Local->process('80cb69e6b95c043...', Array)
#3 /opt/psa/admin/plib/Service/Agent.php(210): Service_Agent->commit()
#4 /opt/psa/admin/plib/Service/Driver/Filesystem/Plesk/Unix.php(300): Service_Agent->execAndGetResponse('filemng', Array)
#5 /opt/psa/admin/plib/Service/Driver/Filesystem/Plesk/Unix.php(31): Service_Driver_Filesystem_Plesk_Unix->_execAndGetResponse(Array)
#6 /opt/psa/admin/plib/FileManager.php(307): Service_Driver_Filesystem_Plesk_Unix->ls('artifex', '/var/www/vhosts...', 'dirs', 'blocks', true)
#7 /opt/psa/admin/plib/FileManager.php(293): FileManager->ls_wrapper('dirs', '/var/www/vhosts...', true)
#8 /opt/psa/admin/plib/ui_common/DirectoryBrowser.php(48): FileManager->ls_dirs_wrapper('/var/www/vhosts...')
#9 /opt/psa/admin/plib/ui/client.domain.hosting.ftp-users.browser.php(12): DirectoryBrowser->accessItem('GET')
#10 /opt/psa/admin/plib/UIPointer.php(619): plesk__client__domain__hosting__ftp_users__browser->accessItem('GET', NULL)
#11 /opt/psa/admin/htdocs/plesk.php(36): UIPointer->access('GET')
#12 {main}

[04-Jun-2014 10:51:56 Europe/Berlin] PHP Fatal error:  Class 'Doctrine\ORM\Query\Parser' not found in /opt/plesk-billing/thirdparty-libs/doctrine-orm/Doctrine/ORM/Query.php on line 229
root@ks311889:/opt/psa/admin/logs# tail -30 panel.log 

stdout:
filemng: stat failed: No such file or directory

System error 2: No such file or directory


stderr:
filemng: stat failed: No such file or directory

System error 2: No such file or directory

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 38
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(60): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(26): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction))
#2 /opt/psa/admin/plib/Service/Agent.php(140): Service_Agent_Transport_Local->process('80cb69e6b95c043...', Array)
#3 /opt/psa/admin/plib/Service/Agent.php(210): Service_Agent->commit()
#4 /opt/psa/admin/plib/Service/Driver/Filesystem/Plesk/Unix.php(300): Service_Agent->execAndGetResponse('filemng', Array)
#5 /opt/psa/admin/plib/Service/Driver/Filesystem/Plesk/Unix.php(31): Service_Driver_Filesystem_Plesk_Unix->_execAndGetResponse(Array)
#6 /opt/psa/admin/plib/FileManager.php(307): Service_Driver_Filesystem_Plesk_Unix->ls('artifex', '/var/www/vhosts...', 'dirs', 'blocks', true)
#7 /opt/psa/admin/plib/FileManager.php(293): FileManager->ls_wrapper('dirs', '/var/www/vhosts...', true)
#8 /opt/psa/admin/plib/ui_common/DirectoryBrowser.php(48): FileManager->ls_dirs_wrapper('/var/www/vhosts...')
#9 /opt/psa/admin/plib/ui/client.domain.hosting.ftp-users.browser.php(12): DirectoryBrowser->accessItem('GET')
#10 /opt/psa/admin/plib/UIPointer.php(619): plesk__client__domain__hosting__ftp_users__browser->accessItem('GET', NULL)
#11 /opt/psa/admin/htdocs/plesk.php(36): UIPointer->access('GET')
#12 {main}

[04-Jun-2014 10:51:56 Europe/Berlin] PHP Fatal error:  Class 'Doctrine\ORM\Query\Parser' not found in /opt/plesk-billing/thirdparty-libs/doctrine-orm/Doctrine/ORM/Query.php on line 229
httpsd_access_log
Código:
80.28.16.233 - - [05/Jun/2014:15:28:37 +0200] "GET / HTTP/1.1" 403 162 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0" "-"'/' '' '/opt/psa/admin/htdocs'
80.28.16.233 - - [05/Jun/2014:15:28:38 +0200] "GET / HTTP/1.1" 403 162 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0" "-"'/' '' '/opt/psa/admin/htdocs'
80.28.16.233 - - [05/Jun/2014:15:28:40 +0200] "GET / HTTP/1.1" 403 162 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0" "-"'/' '' '/opt/psa/admin/htdocs'
80.28.16.233 - - [05/Jun/2014:15:28:43 +0200] "GET / HTTP/1.1" 403 162 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0" "-"'/' '' '/opt/psa/admin/htdocs'
127.0.0.1 - - [05/Jun/2014:15:31:08 +0200] "POST /check-plesk.php HTTP/1.1" 404 27 "-" "Dr.Web Daemon/Plesk Edition" "-"'/check-plesk.php' '' '/opt/psa/admin/htdocs'
127.0.0.1 - - [05/Jun/2014:15:31:51 +0200] "POST /check-plesk.php HTTP/1.1" 404 27 "-" "Dr.Web Daemon/Plesk Edition" "-"'/check-plesk.php' '' '/opt/psa/admin/htdocs'
80.28.16.233 - - [05/Jun/2014:16:10:36 +0200] "GET / HTTP/1.1" 403 162 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0" "-"'/' '' '/opt/psa/admin/htdocs'
sitebuilder.log

Código:
	[INFO]	[System]		Cannot download demo config from http://download1.parallels.com/SiteBuilder/11.0/demo/config.ini
	127.0.0.1		
2013-11-28T06:27:36+01:00	[INFO]	/enterprise/control/agent.php	Switching on sign-up scenario support	127.0.0.1		
2013-11-28T06:27:52+01:00	[INFO]	/enterprise/control/agent.php	Switching on sign-up scenario support	127.0.0.1
Saludos y Gracias!!

tfwfactory
05/06/2014, 16:23
Mira tambien si existe el archivo de logueo - login_up.php3 - en /usr/local/psa/admin/

Cuál es tu sistema operativo ?

Saludos

tfwfactory
05/06/2014, 16:19
Consulta los logs de Plesk en : /usr/local/psa/admin/logs y mira que te sale a ver si asi descubrimos que puede afectar

Saludos

Artifexsoft
05/06/2014, 16:18
Al restart no da ningun error.

Al hacer sudo service psa status: sw-engine-fpm (pid 15541) is running...
Al acceder https://2xxxxxxxxx443/login_up.php3: Me aparece: File Not Found

Saludos y Gracias

tfwfactory
05/06/2014, 16:12
Pero cuando haces un restart de Plesk , te da algún error ? o te dice que si se inicia Plesk

Accedes asi a tu Plesk ? : https://2xxxxxxxxx443/login_up.php3


Saludos

Artifexsoft
05/06/2014, 16:04
No such file or directory :'(
Probé tambien:
/var/opt/psa
/opt/psa
/opt/psa/var

Y tampoco va

tfwfactory
05/06/2014, 15:57
Parece un problema de permisos entonces , haz esto :

chmod a+x /var/opt/pva/

Intenta luego acceder a ver si sigue tirando un error 403


Saludos

Artifexsoft
05/06/2014, 15:45
El drweb ya está totalmente eliminado.

La versión de plesk, no sé exactamente cual era, pero me suena que es la 11
¿Cómo podría averiguarlo?

Se hizo un upgrade de php pero no de plesk.
¿Cómo lo hago?

Saludos

PD: Llevo poco tiempo usando el plesk

tfwfactory
05/06/2014, 15:34
Debes usar el otro comando para eliminar totalmente la aplicación , asi no buscará ni iniciara

Por otro lado hiciste un upgrade de Plesk o solo de php y que versión tienes de Plesk , saludos

Artifexsoft
05/06/2014, 15:20
Este es el resultado de df -h:
Código:
Filesystem      Size  Used Avail Use% Mounted on
rootfs           20G  9,8G  8,8G  53% /
/dev/root        20G  9,8G  8,8G  53% /
devtmpfs         12G  4,0K   12G   1% /dev
none            2,4G  864K  2,4G   1% /run
none            5,0M     0  5,0M   0% /run/lock
none             12G     0   12G   0% /run/shm
/dev/sda2       1,8T  139G  1,6T   9% /var
Es un servidor linux con ubuntu 12.04.

He desinstalado el drweb con apt-get remove --purge
Tras reiniciar sigue apareciendo 403 Forbidden
Código:
sudo service psa start
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm                                         [ OK ] 
                                                                      done
Starting xinetd service...                                            done
Starting sw-cp-server service...                                      done
Starting mysql service...                                             done
Starting bind9 service...                                             done
Starting postgresql service...                                        not installed
Starting spamassassin service...                                      done
Plesk: Starting Mail Server...                                        done
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm                                         [ OK ] 
                                                                      done
Starting drwebd service...                                            not installed
¿Hay que borrar algo más?

Saludos

tfwfactory
05/06/2014, 15:00
Por cierto que máquina usas no vaya a ser que no tengas espacio , haz esto : df -h y pega lo que te sale

Saludos

tfwfactory
05/06/2014, 14:57
Las webs te funcionan porque los servicios están levantados y no caidos, pero en Plesk hay un plugin que parece ser el drweb que está la licencia terminada o al menos corrompida , puedes eliminar ese plugin perfectamente , es mejor poner otras cosas para la seguridad , te recomiendo eliminarlo y luego reiniciar Plesk con los comandos del principio

Para remover desde SSH : yum remove drweb-base drweb-bases drweb-common drweb-daemon drweb-updater psa-drweb-configurator

Dime si luego te sale todo bien , Saludos

Artifexsoft
05/06/2014, 14:47
Hago service psa stopall. Sale esto:
Código:
Stopping psa...                                                      done
Plesk: Stopping Mail Server...                                       done
Stopping mailer service...                                           not installed
Stopping sw-cp-server service...                                     done
Stopping mysql service...                                            done
Stopping postgresql service...                                       not installed
Stopping spamassassin service...                                     done
Stopping drwebd service...                                           done
Stopping tomcat6 service...                                          not installed
Stopping apache2 service...                                          done
service psa start:
Código:
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm      [ OK ] 
                                                                     done
Starting xinetd service...                                           done
Starting sw-cp-server service...                                     done
Starting mysql service...                                            done
Starting bind9 service...                                            done
Starting postgresql service...                                       not installed
Starting spamassassin service...                                     done
Plesk: Starting Mail Server...                                       done
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm      [ OK ] 
                                                                     done
Starting drwebd service...                                           failed
/etc/init.d/drwebd start
Código:
Starting Dr. Web daemon...
Dr.Web (R) daemon for Linux/Plesk Edition v6.0.2.1
Copyright (c) Igor Daniloff, 1992-2014
Doctor Web, Moscow, Russia
Support service: http://support.drweb.com
To purchase: http://buy.drweb.com
Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
A path to a valid license key file was not specified.
Plesk authorization failed: malformed response (no 'response=' field).
Error: Plesk Software not running.
Compruebo que /opt/drweb/drweb32.key efectivamente no está.

Ayer ya me dio algún error despues de instalar el paquete php5-mysqlnd
Me salió un error de psa corrupted database. Seguí unos pasos que ví en una web, que no soy capaz de encontrar en el historial, y aparentemente funcionó, pero hoy no funciona.

El caso es que todas las webs que están alojadas si que funcionan, lo único que no tenemos acceso al plesk.

Saludos!!

tfwfactory
05/06/2014, 14:21
Dame algo más de información sobre que has hecho , etc , copia y pega que te sale , saludos

P.D : Si te sale al intentar iniciar el servicio haz esto

service psa stopall
service psa start

Artifexsoft
05/06/2014, 14:09
Ok, me dice que no encuentra el keyfile.
¿Hay alguna forma de desactivarlo?

Saludos y Gracias!!

tfwfactory
05/06/2014, 14:03
Como adicional yo no usaría ese antivrus y lo dejaría sin utilizar , siempre da problemas y consume bastantes recursos

Saludos

tfwfactory
05/06/2014, 14:02
Veo que drwebd no te va , ......... intenta hacer esto desde consola y luego acceder a Plesk :

/etc/init.d/drwebd start


Saludos

Artifexsoft
05/06/2014, 13:55
He probado y no funciona.
Esto es lo que sale por la shell:
Código:
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm      [ OK ] 
                                                                     done
Starting xinetd service...                                           done
Starting sw-cp-server service...                                     done
Starting mysql service...                                            done
Starting bind9 service...                                            done
Starting postgresql service...                                       not installed
Starting spamassassin service...                                     done
Plesk: Starting Mail Server...                                       done
Starting psa...  * Starting Plesk engine pool manager sw-engine-fpm      [ OK ] 
                                                                     done
Starting drwebd service...                                           failed

tfwfactory
05/06/2014, 13:07
Reinicia Plesk a veces pasa eso , sigue esta guia :

http://kb.parallels.com/es/118


Saludos

Artifexsoft
05/06/2014, 12:25
Buenos días.

No puedo acceder al panel de Plesk. Me sale 403 forbidden.
Ayer funcionaba todo correctamente pero hoy no podemos acceder.

Al reiniciar los servicios desde la shell .
El resto de webs alojadas en el servidor funcionan perfectamente.

¿Qué puedo hacer?

Saludos y gracias