We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PLESK cambiar dominio acceso


chencho
10/03/2010, 20:48
Los has solventado?

Yo en /etc/sw-cp-server/applications.d/plesk.conf no veo ningún ServerName, ni kimsufi, ni similares y al añadirlo y reiniciar apache en el puerto 8443 me ha devuelto un bonito error 500.

MalastiC
10/01/2010, 16:54
Cita Publicado inicialmente por Alternate
Perdonad si revivo un post antiguo pero me e encontrado con este problema y lo estabasolventando y en este paso, el archivo que dice aqui a mi me sale totalmente vacio, a alguien mas le pasa? :S
Mira en: /etc/sw-cp-server/applications.d/plesk.conf

Un saludo,

AlejandroCastro
07/09/2009, 21:53
Cita Publicado inicialmente por eskary
Hola

Estoy buscando como puedo cambiar el dominio de acceso al panel de control plesk, actualmente si accedo desde http://midominio.com443 me redirecciona automaticametne a https://nsxxxxxx.ovh.net443.

En plesk he configurado como dominio predeterminado midominio.com
En hosts y hostname tambien he puesto midominio.com como predeterminado
En el manager de ovh he asignado como dns inversa midomino.com
El dominio esta correctamente alojado en el servidor y este tiene el control total de los DNS.

¿Que hago mal?

gracias de antemano
Facil, por que en vez de poner :
http://midominio.com443
Le pones la SSL. ASi.
https://midominio.com443

Le pones la SSl. para que no te redireccione. ASi te dejas de lios.

Alternate
01/09/2009, 13:24
Cita Publicado inicialmente por eskary
Modificamos el siguiente archivo
/usr/local/psa/admin/conf/httpsd.conf
Busando las siguientes lineas, canviamos el nombre nsXXXXX.ovh.net por nuestrodominio.com (es muy importante usar el dominio sin poner un subdominio delante)
ErrorDocument 400
ServerName
Perdonad si revivo un post antiguo pero me e encontrado con este problema y lo estabasolventando y en este paso, el archivo que dice aqui a mi me sale totalmente vacio, a alguien mas le pasa? :S

unwired
22/02/2008, 13:10
Sin problema alguno puedes purblicarlo.

hostingaldescubierto
22/02/2008, 12:27
de nada
si no te importa te la publico en la web

unwired
22/02/2008, 11:15
me alegra que mi aportación sea tan bien recivida.

hostingaldescubierto, gracias por toda tu ayuda, sin ti no hubiera sido posible hacer esta guia. Ya he instalado los paquetes adicionales del sitebuilder "a mano" instalados y funcionan.

Lo podeis ver en marcha en http://sitebuilder.hostingsoreinfo.com

Saludos

Vidal OVH
21/02/2008, 16:10
La guía está hecha (a mí me ha funcionado y por eso la he puesto).

De todos modos, dado que a uno de vosotros le ha dado problemas, se queda en estado "curso de realización"

http://guias.ovh.es/PleskSiteBuilder

hostingaldescubierto
20/02/2008, 16:47
hay que descargarlas a mano si no recuerdo mal

racamet
19/02/2008, 20:53
Todo esto ya lo habia hecho antes, excepto en la actualización, solo una vez fui una por una

Despues de hacer lo siguiente:

Cita Publicado inicialmente por eskary
Tenemos que indicar en los DNS que el subdominio: sitebuilder.nuestrodominio.com aputna a la IP del servidor

Vamos acceder a http://sitebuilder.nuestrodominio.com

Si no funciona ejecutar al SHELL lo siguiente:
/usr/local/bin/sb_config --sb_host_ip xx.xx.xx.xx (indicar nuestra ip)
/usr/local/bin/sb_config --sb_hostname sitebuilder.nuestrodominio.com

Reiniciamos el apache y el plesk
/etc/init.d/psa restart
/etc/init.d/httpd restart
el servidor deja de responder, apache aparece como arrancado en consola pero como parado en Plesk, y no hay manera de reiniciarlo; por eso, y ahora que tengo pocas paginas, decidi volver a instalarlo entero.

Power
19/02/2008, 16:25
Muy bueno el manual, eskary.
Muchas gracias.
Creo que es digno de que OVH lo ponga como guía.

unwired
19/02/2008, 15:55
A ver si alguien me puede decir como se instala en el SITEBUILDER el idioma español y los temas adicionales.

Saludos

unwired
19/02/2008, 15:52
Te paso un poco de manual que he hecho si tienes cualquier duda dimelo.

Una vez instalado el servidor al acceder por primera vez al plesk, tienes que dar de alta (siempre y cuando la quieras utilitzar) la ip failover (en mi caso la uso porque es una ip española y no francesa)
Ip adicional/255.255.255.0

Modificamos los archivos

/etc/HOSTNAME
/etc/hosts

indicando el dominio principal que vamos a usar.

reiniciamos el servicio network
/etc/init.d/network restart

Modificamos el siguiente archivo
/usr/local/psa/admin/conf/httpsd.conf
Busando las siguientes lineas, canviamos el nombre nsXXXXX.ovh.net por nuestrodominio.com (es muy importante usar el dominio sin poner un subdominio delante)
ErrorDocument 400
ServerName

Reiniciar plesk
/etc/init.d/psa restart

Ahora deberiamos poder acceder usando la nueva direccion
http://nuestrodominio.com443 deberia acceder a https://nuestrodominio.com443

Actualizaremos el plesk
Servifor > Actualizador

Ir actualizando el plesk VERSION POR VERSION y no directamente seleccionando la ultima, es muy importante pasar por todas las versiones en la actualizacion ya que de esta forma se instalan TODOS LOS COMPONENTES incluido el SITEBUILDER.

Una vez actualizado reiniciamos el servidor

Tenemos que indicar en los DNS que el subdominio: sitebuilder.nuestrodominio.com aputna a la IP del servidor

Vamos acceder a http://sitebuilder.nuestrodominio.com

Si no funciona ejecutar al SHELL lo siguiente:
/usr/local/bin/sb_config --sb_host_ip xx.xx.xx.xx (indicar nuestra ip)
/usr/local/bin/sb_config --sb_hostname sitebuilder.nuestrodominio.com

Reiniciamos el apache y el plesk
/etc/init.d/psa restart
/etc/init.d/httpd restart

Ahora deberia funcionar, recuerda que en la seccion MODULOS debermos configurar el usuario y contraseña los predeterminados son (admin/admin)

Espero no dejarme nada, para poner en marcha el plesk correctamente con el SITEBUILDER, me he dejado las configuraciones del plesk que ya cada uno se lo pone a su gusto.

Saludos

racamet
19/02/2008, 14:40
Si no te importa hacer un "paso a paso para muuuy torpes"?

Es que lo he intentado 4 o 5 veces y al final he tenido que reinstalar el servidor, porque empieza a "hacer aguas" por todos lados.

Muchas gracias.

unwired
19/02/2008, 14:14
Hola Racanet

El sitebuilder se instala automaticamente junto la ultima actualizacion del plesk siempre y cuando lo selecciones en el momento de realizar la actualizacion.

De todas formas yo he optado de contratar un servidor nuevo instalando el plesk de nuevo y configurando el host ANTES DE EMPEZAR A ACTUALIZAR EL PANEL, es la unica forma que he encotnrado para que funcione el panel con el sitebuilder.

Ahora solo me falta migrar los alojamientos, espero que la migracion funcione bien.

Por otra parte quisiera hacer una consulta a ver si alguien lo sabe.

¿como se instala el idioma en español en el sitebuilder?
¿y las plantillas adicionales?

Saludos

racamet
14/02/2008, 20:32
eskary, ¿como has instalado Sitebuilder?

Yo lo he intentado varias veces y he tenido que reinstalar el servidor entero, me lo ha dejado "loco"

si ves este mensaje, al final del todo el sistema se vuelve loco y apache no resuelve ninguna dirección y tuve que reinstalar.

¿Podrias poner un "paso a paso"? (tengo FC4)

PD: si pudieras crearme un usuario para ver como funciona sitebuilder?, si no me convence mucho no pruebo a instalarlo (si decides crear el usuario, puedes enviarme un privado)

Gracias.

hostingaldescubierto
14/02/2008, 18:49
Prueba esto a ver si está almacenado aquí:

mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "select * from module_3_sbm_sbservers ";

unwired
14/02/2008, 16:23
buenas

He seguido tus pasos y parece que esta todo bien, de hecho si accedo a traves de sitebuilder.midominio.com se ve correctamente y puedo acceder como admin/admin (ya he cambiado la contraseña) el problema esta en que desde el panel plesk donde tengo el menu de sitebuilder cuando accedo me sale "pagina no encontrada" es decir que sigue llamando a la ruta antigua http://sitebuilder.nsXXXXX.ovh.net/

¿Alguna idea?

Muchas gracias de nuevo

hostingaldescubierto
14/02/2008, 15:41
XDDD pues nada ya tienen para hacer un manual

Prueba lo siguiente para el sitebuilder :

/usr/local/bin/sb_config --sb_hostname
los cambios que hagas tienen que estar reflejados en el fichero: /usr/local/sitebuilder/config

Si aún así no funciona revisa el fichero:
/etc/httpd/conf.d/zz011_sitebuilder.conf
La linea
ServerName sitebuilder.midominio.com

Te mostrará el nombre que está usando, si no es correcta, cambiala y relanza el servicio apache.

ya me contarás

unwired
14/02/2008, 10:52
Muchas gracias

He seguido tu manual y me ha funcionado perfectamente a la primera. Es de agradecer que alguien sepa dar una respuesta, ya que he llamado dos veces a OVH y mandado 4 e-mails y ellos no saben responderme a esta duda, mas que no sabe, no quieren buscar la solucion, porque no me creo que nadie de OVH sepa hacer esto.

En fin muchas gracias de nuevo.

Lo que no entiendo es que aun sigue la ruta del sitebuilder incorrecta, me sigue llamando al a direccion http://sitebuilder.nsXXXXX.ovh.net/ServiceFacade/ ¿donde puedo cambiar esto?

Saludos

hostingaldescubierto
13/02/2008, 21:45
Tienes que modificar este fichero :

/usr/local/psa/admin/conf/httpsd.conf


De todas formas he creado un pequeño artículo en http://hostingaldescubierto.com/word...ceso-al-panel/

unwired
10/02/2008, 12:38
Buenas,

¿me podrias indicar cuales son las ubicaciones de dichos archivos? ¿y cual es el servidor web que utilitza plesk?
o si sabes de algun manual donde lo cuente, muchas gracias.

hostingaldescubierto
09/02/2008, 00:06
Tienes que modificar a mano los ficheros de configuración del servidor apache de Plesk.
Se ejecutan dos servicios web, uno para las páginas y otro para el Plesk. Este último guarda la configuración que haces en la instalación y sólo lo puedes moficiar a mano.

unwired
05/02/2008, 14:53
Hola

Estoy buscando como puedo cambiar el dominio de acceso al panel de control plesk, actualmente si accedo desde http://midominio.com443 me redirecciona automaticametne a https://nsxxxxxx.ovh.net443.

En plesk he configurado como dominio predeterminado midominio.com
En hosts y hostname tambien he puesto midominio.com como predeterminado
En el manager de ovh he asignado como dns inversa midomino.com
El dominio esta correctamente alojado en el servidor y este tiene el control total de los DNS.

¿Que hago mal?

gracias de antemano