OVH Community, your new community space.

Ip FailOver Configuracion


alvaroag
08/08/2014, 14:02
Debes verificar:

- Que la interfaz con la que estés haciendo el bridge de tu VM sea la correcta. No se bien en VMware, pero en Proxmox vienen dos Bridges, uno para Internet y otro para red interna.
- Que efectivamente tu VM esté tomando la dirección MAC correcta. Esto lo puedes ver, en Linux, con ifconfig -a, y en Windows, en las propiedades de la interfaz de red. Ten en cuenta que una vez que configures la MAC puedes requerir reiniciar la VM.

Además, considera la siguiente configuración de IP:

IP del servidor(incluída): a.b.c.d
IP failover: e.f.g.h
En todos los casos, la máscara de red debe ser 255.255.255.255, o /32 en notación CIDR.
La puerta de enlace o gateway debe ser siempre la IP principal, terminada en 254; es decir, a.b.c.254. Esto es igual para las IP FO.
SI la IP FO no está en la misma red de la IP principal(es decir, si a.b.c != e.f.g), podrías requerir algún cambio adicional. Windows maneja bien este aspecto, pero algunas distros de linux no lo manejan bien. Entonces, si ejecutas "route -n" y no ves que haya una ruta a 0.0.0.0/0, tendrías que modificar tu configuración de red para indicarle que la IP del gateway es alcanzable directamente en la interfaz de red. Esto se puede hacer manualmente, no persistente, con dos comandos: "route add a.b.c.254/32 dev eth0" y "route add -net 0.0.0.0/0 gw a.b.c.254", cambiando a.b.c y eth0 por los valores correspondientes.

Vidal OVH
07/08/2014, 15:08
Revisa si puedes hacer ping a la gateway desde la máquina virtual.

Si la configuración es correcta y sigue sin funcionar lo mejor es que nos contactes al soporte y nos envíes una copia de la configuración.

tootuyo
06/08/2014, 16:42
Hice todo de la guia y sigue aun asi .. utilizo Vmware Workstation 10.0.3 la ultima actualizacion de esta version de software de VMware
puse en modo bridge y le puse el Mac que me da la ip failover.. pero aun asi no logre nada :S

Vidal OVH
06/08/2014, 14:01
Para crear la MAC virtual consulta la guía:

http://guias.ovh.es/DedicadoMacVirtual

Para la configuración del VPS existe una guía paso a paso en la dirección:

http://guias.ovh.es/DedicadoBridgeCliente

alvaroag
06/08/2014, 13:48
Que solución de VPS estás utilizando? Recuerda que si trabajas en Proxmox o VMware, debes configurar la interfaz de red del VPS en modo bridged y asignarle una MAC virtual previamente creada desde el OVH Manager. De lo contrario, el router de OVH, al no conocer tu dirección MAC, descartará todos los paquetes provenientes de tu VPS.

tootuyo
06/08/2014, 08:58
Hola que tal. Bueno soy nuevo en OVH y hasta ahora me he orientado bien con el nuevo dedicado que compre
el problema ahora me surge cuando quiero asignar una IP failover a unos de mis vps con modo bridge
No importa la forma en que le ponga la configuracion ya sea esta:
Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.255
Puerta de enlace: 192.99.xxx.254(ipFailOver con ultimas 3 cifras cambiadas por 254)

O Esta:
Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.255
Puerta de enlace: 192.99.xxx.254(Ip del DEDICADO con ultimas 3 cifras cambiadas por 254)

Incluso trate de probar otras configuraciones como la de:
Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.0 (255 cambiada por 0)
Puerta de enlace: 192.99.xxx.254(ipFailOver con ultimas 3 cifras cambiadas por 254)

Y tambien de :
Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.0 (255 cambiada por 0)
Puerta de enlace: 192.99.xxx.254(ip DEDICADO con ultimas 3 cifras cambiadas por 254)

Tambien intente poner una configuracion anterior en otro dedicado de X empresa con la que me podia conectar normalmente

Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.0 (255 cambiada por 0)
Puerta de enlace: 192.99.xxx.xxx(ip DEDICADO )

Ip:192.99.xxx.xxx (FailOver)
NetMask: 255.255.255.255
Puerta de enlace: 192.99.xxx.xxx(ip DEDICADO )

Y todos configurados con el 213.186.33.99 como servidor DNS preferido.

Aun asi todos tienen el mismo error en comun que es de no poder conectarse a internet!
Averigue y trate de varias formas pero aun asi no logre nada .
Cambie el SO de mi dedicado varias veces para averiguar si es el problema el SO pero no es asi ya que probe en promox y EXSI
Actualmente me instale un Windows Server 2008 R2 para poner un Vmware Workstation y es el mismo error..
Tambien cambie la direccion MAC en mis VPS por las MAC creadas en la configuracion de las ip Failover y nada aun..
Ya no se que hacer... espero que alguien me ayude con este tema...
Desde ya muchas gracias por leer este post