We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

dominio sin www apunta a wwwdominio


MarcosBL
18/10/2014, 14:15
Mira el fichero .htaccess de la raiz de tu dominio, casi seguro está mal escrito redireccionando a wwwdominio en vez de a www.dominio

SRClacks
15/10/2014, 12:36
Apache revisado y tampoco.

Es un tanto raro. He actualizado plesk a la ultima versión y sigue igual. Tendré que resetear todo desde DNS, a panel, name servers ect.

Gracias por la ayuda!!

mgsalinero
14/10/2014, 19:31
Es extraño debería de funcionar. Quizas el error esté en Apache. Prueba a sustituir www.domain.com. CNAME domain.com por www.domain.com A [IP]

Aunque repito que me parece raro que no funcione. Comprueba tu configuración de apache ya que no tienes ninguna regla en el DNS que te redireccione a wwwdominio.com.

¿Qué servidores virtuales tienes configurados en apache y como?

SRClacks
14/10/2014, 15:42
aquí van:

*.webmail.domain.com. CNAME domain.com.
[IP] / 24 PTR domain.com.
domain.com. NS s01.domain.com.
domain.com. A [IP]
domain.com. MX (10) mail.domain.com.
domain.com. TXT v=spf1 +mx -all
ftp.domain.com. CNAME domain.com.
imap.domain.com. A [IP]
mail.domain.com. A [IP]
ns.domain.com. A [IP]
pop.domain.com. A [IP]
pop3.domain.com. A [IP]
s01.domain.com. A [IP-2]
smtp.domain.com. A [IP]
webmail.domain.com. A [IP]
ws01.domain.com. A [IP]
www.domain.com. CNAME domain.com.

mgsalinero
14/10/2014, 14:00
Copia la configuración completa de esa zona DNS por favor. (puedes sutituir "dominio" por **** para tu privacidad)

SRClacks
14/10/2014, 11:12
Gracias por la ayuda.

En principio todo esto esta configurado. El punto final fue un error al escribir el post que lo olvidé.

No se si será cosa de Plesk, tengo otros dominios con las mismas DNS y si funciona correctamente en http://dominio.com

Lo raro es que este dominio cuando introduces http://dominio.com te lleva a wwwdominio.com sin el punto entre las www y dominio. Ahi creo que esta la cuestión.

Puede ser por las NS principales?

mgsalinero
13/10/2014, 21:05
Prueba a añadir el registro A con www. Para una configuración básica de hosting-dominio se puede usar los registros A para este efecto sin usar CNAME.

dominio.com A [IP]
www.dominio.com A [IP]
Aún así en tu configuración si que echo en falta el punto final del dominio

www.dominio.com CNAME dominio.com. <-- este punto final

SRClacks
13/10/2014, 10:50
Buenas tardes,

Tengo un dominio que cuando introduces http://dominio.com sin las www apunta a http://wwwdominio.com sin el punto entre las www y dominio.

Tengo los DNS correcatmente configuradas, o eso espero:

dominio.com A [IP]
www.dominio.com CNAME dominio.com

Entre otros valores.

Qué está ocurriendo? Gracias.