We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

¿Como bajar la versión de PHP 5..5 a 5..3 en VPS con Ubuntu 14.04?


mgsalinero
22/11/2014, 18:34
No tiene por que.

Prueba esta solución:
http://kb.sp.parallels.com/es/118757

Pakete
22/11/2014, 17:00
Pues la hemos cagado...

Cuando intento acceder a Plex me marca este error: 502 Bad Gateway (nginx)

Creo que se debería de hacer por medio de plex, ya que todo lo instala plex, no?

mgsalinero
22/11/2014, 13:09
Deberás modificarlo según tus necesidades:

Código:
# upgrade system, so you can add to ignore all updates later
sudo apt-get update
sudo apt-get upgrade

# remove your php, apache, etc
sudo apt-get purge apache2 php5 libapache2-mod-php5 # add here your server packages

# change repositories to raring  (with backup)
sudo sed -i.bak "s/saucy/raring/g" /etc/apt/sources.list

# update and install server packages
sudo apt-get update
sudo apt-get install apache2 php5 libapache2-mod-php5 phpmyadmin #add here packages you need and make sure you install php5.4 and apache2.2

# change repositories back to saucy
sudo sed -i "s/raring/saucy/g" /etc/apt/sources.list

# ignore all current upgrades (package hold)
sudo apt-mark hold `aptitude -F%p --disable-columns search ~U`
O más facil, lo siguiente:
Código:
sudo apt-get remove --purge `dpkg -l | grep php | grep -w 5.4 | awk '{print $2}' | xargs`
sudo apt-get install php5=5.3.10-1ubuntu3.4 php5-cli=5.3.10-1ubuntu3.4 php5-common=5.3.10-1ubuntu3.4 libapache2-mod-php5=5.3.10-1ubuntu3.4
sudo apt-get install php5=5.3.10-1ubuntu3.4 php5-cli=5.3.10-1ubuntu3.4 php5-common=5.3.10-1ubuntu3.4 libapache2-mod-php5=5.3.10-1ubuntu3.4
sudo apt-get install php-pear=5.3.10-1ubuntu3.4 php5-curl=5.3.10-1ubuntu3.4 php5-gd=5.3.10-1ubuntu3.4 php5-intl=5.3.10-1ubuntu3.4 php5-mysql=5.3.10-1ubuntu3.4 php5-pspell=5.3.10-1ubuntu3.4 php5-recode=5.3.10-1ubuntu3.4 php5-snmp=5.3.10-1ubuntu3.4 php5-sqlite=5.3.10-1ubuntu3.4 php5-tidy=5.3.10-1ubuntu3.4 php5-xmlrpc=5.3.10-1ubuntu3.4 php5-xsl=5.3.10-1ubuntu3.4
Aquí tienes más info:
http://askubuntu.com/questions/11625...php-5-4-to-5-3

Pakete
22/11/2014, 10:14
Hola de nuevo, tengo algunos problemas con módulos del cms drupal e indagando el tema vi que es por culpa de la versión de php, la recomendada por drupal 7 es la 5.3 y yo tengo la 5.5.
A ver si me podéis ayudar para cambiar la versión.

Por cierto, tengo instalado Parallels Plesk v12.0.18, por si es relevante.


Gracias !!!!!!