We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Error postfix/smtpd


alvarofdogb
28/02/2015, 01:12
Bueno, le he añadido DKIM también para enviar. En Gmail parece que ya llegan a la bandeja de entrada... En Oulook sigue apareciendo en Correo no deseado (spam), y creo que es porque sigue apareciendo Localhost en la cabecera...

Es extraño, pongo aquí la configuración de los ficheros:

/etc/hostname

midominio.es
/etc/hosts

127.0.0.1 localhost
YY.YYY.YY.YY midominio.es vpsZZZZZZ.ovh.net vpsZZZZZZ phpmyadmin.midominio.es
/etc/postfix/main.cf

myhostname = midominio.es
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost.$mydomain, localhost, $mydomain
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
/etc/mailname

midominio.es
Me tiene mosca, porque es lo mismo que había cuando estuve trasteando con el SPF anteriormente, que salía como fail pero no aparecía localhost en la cabecera.

Creo que debe fallar alguna tontería, pero no consigo verlo...

Por cierto, el registro inverso de la IP YY.YYY.YY.YY ya apunta a midominio.es.

Gracias.

alvarofdogb
27/02/2015, 18:52
Ya llegan los correos!! :-). La verdad he tocado tantas cosas que no sé realmente cuál ha sido el cambio que lo ha hecho posible... Para el usuario administrador del dominio (administrador@midominio.es) creé con Modoboa un alias (*@midominio.es), ¿puede haber sido eso?

En la reconfiguración de postfix, en lugar de 127.0.0.1 para el host, he usado localhost (en teoría debe ser lo mismo...).

En cuanto al tema de SPAM, he dado un paso atrás. Vuelve a aparecer el "Received from localhost...". Y los ficheros /etc/hosts, /etc/hosname, /etc/mailname y /etc/postfix/main.cf { myorigin y myhostname } siguen apareciendo midominio.es.

El tema del SPF lo entendí, ahora hay una sola entrada TXT, en la que se permite por ip4 e ip6 y se deniega el resto. En la cabecera ya aparece como spf: PASS.

Lo del dig -x IP, que salga YY.YY.YYY.YY.in-addr.arpa. 66615 IN PTR YY.ip-YY-YYY-YY.eu., en lugar del nombre del dominio, ¿puede ser debido a la entrada de midominio.es. 0 A YY.YYY.YY.YY de la Zona DNS? Si es así, ¿bastaría con borrarlo?

Gracias de nuevo dgranda, me estás siendo de mucha ayuda.

dgranda
27/02/2015, 14:32
Cita Publicado inicialmente por alvarofdogb
Sí, los usuarios se crean en la tabla core_user de la BD modoboa. De hecho, puedo hacer login con ellos y enviar correos (SPAM).

¿Por qué dices que debería levantar sospechas esa configuración?
Que yo recuerde, no hubo ningún fallo en crear la BD y accede bien, probando con el usuario/clave que tiene en la configuración postfix, accedo a la BD modoboa sin problemas (vía web al menos).
El problema parece estar en que postfix no lee correctamente de la base de datos, por eso te indico por dónde empezar a mirar para encontrar el problema.

Del tema de SPAM. Resumen:

- Google:

Received: from midominio.es ([2001:41d0:52:100::edb])
spf=fail (google.com: domain of administrador@midominio.es does not designate 2001:41d0:52:100::edb as permitted sender)
Te estás identificando con una dirección de IPv6, pero dicha dirección no aparece en tus registros DNS, ¿cómo esperas que Google pueda verificarla?.

- Hotmail:

Authentication-Results: hotmail.com; spf=permerror (sender IP is YY.YYY.YY.YY) smtp.mailfrom=administrador@midominio.es; dkim=none
Tienes un lío descomunal con los registros SPF. Revisa la sintaxis y deja solamente 1 registro SPF (que es un TXT) en los DNS. Hay multitud de herramientas web que pueden verificar si está correcto. Desde línea de comandos con $ dig midominio.es TXT

; ANSWER SECTION:
YY.YY.YYY.YY.in-addr.arpa. 84517 IN PTR YY.ip-YY-YYY-YY.eu.

Algo raro? Muchas gracias de nuevo :-).
¿Te parece que "YY.ip-YY-YYY-YY.eu." se parece en algo a "midominio.es"?

Ahora ya deberías darte cuenta por qué se mueren algunos foros :-(

alvarofdogb
27/02/2015, 13:48
Gracias de nuevo dgranda.

Sí, los usuarios se crean en la tabla core_user de la BD modoboa. De hecho, puedo hacer login con ellos y enviar correos (SPAM).

¿Por qué dices que debería levantar sospechas esa configuración?
Que yo recuerde, no hubo ningún fallo en crear la BD y accede bien, probando con el usuario/clave que tiene en la configuración postfix, accedo a la BD modoboa sin problemas (vía web al menos).

He cambiado parte de los ficheros que comentas /etc/hosts, /etc/hostname y /etc/postfix/main.cf, ahora en todos aparece midominio.es, donde antes aparecía en algunos de ellos el nombre de la máquina VPS.

Cabecera en Gmail:
elivered-To: micorreopersonal@gmail.com
Received: by 10.112.95.115 with SMTP id dj19csp3888900lbb;
Fri, 27 Feb 2015 04:26:40 -0800 (PST)
X-Received: by 10.180.106.225 with SMTP id gx1mr5974393wib.53.1425040000157;
Fri, 27 Feb 2015 04:26:40 -0800 (PST)
Return-Path:
Received: from midominio.es ([2001:41d0:52:100::edb])
by mx.google.com with ESMTP id l18si3086313wie.95.2015.02.27.04.26.39
for ;
Fri, 27 Feb 2015 04:26:40 -0800 (PST)
Received-SPF: fail (google.com: domain of administrador@midominio.es does not designate 2001:41d0:52:100::edb as permitted sender) client-ip=2001:41d0:52:100::edb;
Authentication-Results: mx.google.com;
spf=fail (google.com: domain of administrador@midominio.es does not designate 2001:41d0:52:100::edb as permitted sender) smtp.mail=administrador@midominio.es
Received: from MiPC (XXX.Red-XX-XX-XXX.dynamicIP.rima-tde.net [XX.XX.XXX.XXX])
by midominio.es (Postfix) with ESMTPSA id 99C111DE21B6
for ; Fri, 27 Feb 2015 13:26:37 +0100 (CET)
Cabecera en Outlook

Authentication-Results: hotmail.com; spf=permerror (sender IP is YY.YYY.YY.YY) smtp.mailfrom=administrador@midominio.es; dkim=none header.d=midominio.es; x-hmca=none header.id=administrador@midominio.es
X-SID-PRA: administrador@midominio.es
X-AUTH-Result: NONE
X-SID-Result: NONE
X-Message-Status: n:n
X-Message-Delivery: Vj0xLjE7dXM9MDtsPTA7YT0wO0Q9MjtHRD0yO1NDTD02
X-Message-Info: 11chDOWqoTnGqtwvZoEWRqAVaETIEQizeRzHeCqYOsnGQN5TtH 1RKFw4Bvf2RD3dyFxXYpJJ+wCYxjU4Qt3YGucjWVtrUU5nh6xA q/cyKw2+AfO+Ybsni01Y8ccywxWay4TD12yVApo7vcZesYnkwf6B BP0f9r/Ho1Azt/Ql/x/tA7T6Pnj52eeYRr8xoQr/uzDeNEdHdzt3AN2/mYbdHbNtPjp4Tsj/
Received: from midominio.es ([YY.YYY.YY.YY]) by COL004-MC1F30.hotmail.com with Microsoft SMTPSVC(7.5.7601.22751);
Fri, 27 Feb 2015 04:26:56 -0800
Received: from MiPC (XXX.Red-XX-XX-XXX.dynamicIP.rima-tde.net [XX.XX.XXX.XXX])
by midominio.es (Postfix) with ESMTPSA id 8DFE11DE21B6
for ; Fri, 27 Feb 2015 13:26:55 +0100 (CET)
Parece que ahora el SPF falla... he seguido esta consulta de SO http://stackoverflow.com/questions/8...rk-spf-to-pass, añadiéndolo a mi registro, no sé si tardará mucho en replicar... qudando ahora así mi Zona DNS en OVH:

midominio.es. 0 NS dns200.anycast.me.
midominio.es. 0 NS ns200.anycast.me.
midominio.es. 0 MX 1 midominio.es.
_autodiscover._tcp.midominio.es. 0 SRV 0 0 443 mailconfig.ovh.net.
_imaps._tcp.midominio.es. 0 SRV 0 0 993 ssl0.ovh.net.
_submission._tcp.midominio.es. 0 SRV 0 0 465 ssl0.ovh.net.
midominio.es. 0 A YY.YYY.YY.YY
autoconfig.midominio.es. 0 CNAME mailconfig.ovh.net.
ftp.midominio.es. 0 CNAME midominio.es.
imap.midominio.es. 0 CNAME ssl0.ovh.net.
mail.midominio.es. 0 CNAME ssl0.ovh.net.
modoboa.midominio.es. 0 CNAME midominio.es.
phpmyadmin.midominio.es. 0 CNAME midominio.es.

pop3.midominio.es. 0 CNAME ssl0.ovh.net.
smtp.midominio.es. 0 CNAME ssl0.ovh.net.
www.midominio.es. 0 CNAME midominio.es.
midominio.es. 0 TXT "1|www.midominio.es"
midominio.es. 0 TXT "v=spf1 include:midominio.es -all"
midominio.es. 0 TXT "v=spf1 mx -all"

www.midominio.es. 0 TXT "3|welcome"
www.midominio.es. 0 TXT "l|es"
midominio.es. 600 SPF "v=spf1 a mx -all"
He remarcado en negrita las que yo he creado.

Por último, el comando dig -x IP me devuelve lo siguiente:

root@vpsZZZZZZ:~# dig -x YY.YYY.YY.YY

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> -x YY.YYY.YY.YY
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52382
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;YY.YY.YYY.YY.in-addr.arpa. IN PTR

;; ANSWER SECTION:
YY.YY.YYY.YY.in-addr.arpa. 84517 IN PTR YY.ip-YY-YYY-YY.eu.

;; AUTHORITY SECTION:
YY.YYY.YY.in-addr.arpa. 170916 IN NS dns107.ovh.net.
YY.YYY.YY.in-addr.arpa. 170916 IN NS ns107.ovh.net.

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Feb 27 13:41:33 2015
;; MSG SIZE rcvd: 123
Algo raro? Muchas gracias de nuevo :-).

dgranda
27/02/2015, 12:54
Cita Publicado inicialmente por alvarofdogb
Pues en la máquina el usuario administrador no existe, ya que lo que hago es crear los usuarios de correo a través de la web de modoboa. Si también tengo que crearlos en la máquina, no sé qué ventajas tiene eso entonces...
Las preguntas eran para ti: ¿se crea de alguna manera el usuario para que postfix sepa que existe?. Pistas:

- Modoboa interactúa con Postfix a través de base de datos. NO hace falta que tú crees manualmente nada.

- En tu configuración de Postfix aparecen algunas entradas que deberían levantar sospechas

virtual_mailbox_domains = mysql:/etc/postfix/maps/sql-domains.cf
virtual_alias_domains = mysql:/etc/postfix/maps/sql-domain-aliases.cf
virtual_alias_maps = mysql:/etc/postfix/maps/sql-mailboxes-fix.cf, mysql:/etc/postfix/maps/sql-aliases.cf, mysql:/etc/postfix/maps/sql-domain-aliases-mailboxes.cf, mysql:/etc/postfix/maps/sql-catchall-aliases.cf
smtpd_recipient_restrictions = check_recipient_access mysql:/etc/postfix/maps/sql-maintain.cf, permit_sasl_authenticated, permit_mynetworks, reject_unverified_recipient, reject_unauth_destination
Si tú has creado el usuario en Modoboa y Postfix no se ha enterado, deberás investigar por qué. ¿Está en la base de datos correspondiente?, ¿hubo algún fallo al crear la entrada en la base de datos?, ¿lee postfix la información de la base de datos?, etc.

Respecto a que los correos sean marcados como SPAM, estás mandando señales contradictorias a los servidores de correo electrónico. Por una parte dices que eres localhost y por otra que estás autorizado a enviar correos electrónicos en nombre de midominio.es. Eso invita a pensar que alguien se ha hecho con los servidores de nombres y que los mensajes sean fraudulentos.

- Mandas correos electrónicos desde una máquina con nombre indefinido:

Received: from localhost (YY.ip-YY-YYY-YY.eu. [YY.YYY.YY.YY])
...
by localhost (Postfix)
¿Está todo congruente entre /etc/hosts, /etc/hostname y los parámetros myhostname y myorigin de /etc/postfix/main.cf?. ¿Has reiniciado postfix y el servicio de red para estar seguro de que la información se ha cargado correctamente?

Da la impresión de que no se ha definido el registro inverso de la dirección IP pública (el nombre de dominio asociado a tu IP). Prueba con dig -x IP desde consola de comandos.

Una vez resuelto lo anterior, una opción interesante para incrementar las posibilidades de que tomen tus correos electrónicos más en serio es usar DKIM.

Mi punto de vista es que los foros sirven para intercambiar conocimiento. Si alguna de las partes implicadas no está por la labor... ;-)

alvarofdogb
27/02/2015, 10:45
Hola dgranda, gracias por contestar, pensaba que los foros ya no servían para nada .

Pues en la máquina el usuario administrador no existe, ya que lo que hago es crear los usuarios de correo a través de la web de modoboa. Si también tengo que crearlos en la máquina, no sé qué ventajas tiene eso entonces...

Parte de la cabecera es la siguiente:

Delivered-To: micorreopersonal@gmail.com
Received: by 10.194.108.10 with SMTP id hg10csp1898350wjb;
Tue, 24 Feb 2015 04:16:30 -0800 (PST)
X-Received: by 10.180.126.98 with SMTP id mx2mr29699749wib.18.1424780190433;
Tue, 24 Feb 2015 04:16:30 -0800 (PST)
Return-Path:
Received: from localhost (YY.ip-YY-YYY-YY.eu. [YY.YYY.YY.YY])
by mx.google.com with ESMTP id eu4si23142177wib.107.2015.02.24.04.16.30
for ;
Tue, 24 Feb 2015 04:16:30 -0800 (PST)
Received-SPF: pass (google.com: domain of administrador@midominio.es designates YY.YYY.YY.YY as permitted sender) client-ip=YY.YYY.YY.YY;
Authentication-Results: mx.google.com;
spf=pass (google.com: domain of administrador@midominio.es designates YY.YYY.YY.YY as permitted sender) smtp.mail=administrador@midominio.es
Received: from MiPC (XXX.Red-XX-XX-XXX.dynamicIP.rima-tde.net [XX.XX.XXX.XXX])
by localhost (Postfix) with ESMTPSA id 00F361DE21B6
for ; Tue, 24 Feb 2015 13:16:29 +0100 (CET)
Como se puede ver, el spf lo marca como PASS.

Gracias de nuevo.

dgranda
27/02/2015, 10:26
Un par de preguntas sobre recibir correo electrónico en tu servidor:

- ¿Hay alguna cuenta en tu máquina cuyo nombre de usuario sea "administrador"?

- ¿Hay definido algún alias que se haga cargo del nombre de usuario "administrador"?

Tienes que plantearte qué estrategia quieres seguir, típicamente se suele jugar con alias y cuentas "catch all". Echa un vistazo a la documentación oficial:

Configurar destinatarios locales -> http://www.postfix.org/LOCAL_RECIPIENT_README.html [ENG]
Configurar direcciones virtuales (alias) -> http://www.postfix.org/VIRTUAL_README.html [ENG]

Respecto a que los mensajes sean marcados como SPAM en algunos servidores, echa un vistazo a las cabeceras ("ver mensaje en bruto" o parecido dependiendo del servidor) porque eso dará más información. Pueden ser múltiples factores: dirección IP origen, palabras clave, mensajes malformados, malconfiguración SPF/DKIM, etc.

alvarofdogb
24/02/2015, 17:05
Buenas a todos.

Tras buscar por Google sin parar y en este foro, he decidido registrarme aquí a ver si alguien pude ayudarme con el servidor de correo de mi VPS...

Mi problema es que, cuando envío correos desde Gmail/Outlook.com..., no llega al recipiente (mi servidor), dando como error en /var/log/mail.log lo siguiente:

Feb 24 16:45:21 vpsXXXXX postfix/smtpd[8150]: NOQUEUE: reject: RCPT from dub004-omc2s30.hotmail.com[157.55.1.169]: 450 4.1.1 : Recipient address rejected: unverified address: unknown user: "administrador"; from= to= proto=ESMTP helo=
Hay muchos temas en Google respecto a este tema, pero no encuentro la solución o no la aplico correctamente...

A continuación pongo el contenido de los ficheros que están implicados:

/etc/postfix/main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/ssl/certs/midominio.es.crt
smtpd_tls_key_file = /etc/ssl/private/midominio.es.nopass.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = midominio.es
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_transport = lmtp:unixrivate/dovecot-lmtp
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
relay_domains = *
virtual_mailbox_domains = mysql:/etc/postfix/maps/sql-domains.cf
virtual_alias_domains = mysql:/etc/postfix/maps/sql-domain-aliases.cf
virtual_alias_maps = mysql:/etc/postfix/maps/sql-mailboxes-fix.cf, mysql:/etc/postfix/maps/sql-aliases.cf, mysql:/etc/postfix/maps/sql-domain-aliases-mailboxes.cf, mysql:/etc/postfix/maps/sql-catchall-aliases.cf
smtpd_recipient_restrictions = check_recipient_access mysql:/etc/postfix/maps/sql-maintain.cf, permit_sasl_authenticated, permit_mynetworks, reject_unverified_recipient, reject_unauth_destination
virtual_mailbox_limit = 102400000
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_auth_enable = yes
content_filter = smtp-amavis:[127.0.0.1]:10024
smtpd_tls_auth_only = no
smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem
tls_random_source = dev:/dev/urandom
address_verify_map = proxy:btree:$data_directory/verify_cache
proxy_write_maps = $smtp_sasl_auth_cache_name $lmtp_sasl_auth_cache_name $address_verify_map
/etc/postfix/master.cf

#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - - - - smtpd
#smtp inet n - - - 1 postscreen
#smtpd pass - - - - - smtpd
#dnsblog unix - - - - 0 dnsblog
#tlsproxy unix - - - - 0 tlsproxy
#submission inet n - - - - smtpd
# -o syslog_name=postfix/submission
# -o smtpd_tls_security_level=encrypt
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
#smtps inet n - - - - smtpd
# -o syslog_name=postfix/smtps
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
-o content_filter=
-o receive_override_options=no_header_body_checks
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
relay unix - - - - - smtp
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# ================================================== ==================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
# lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
# mailbox_transport = lmtp:inet:localhost
# virtual_transport = lmtp:inet:localhost
#
# ================================================== ==================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus unix - n n - - pipe
# user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ================================================== ==================
# Old example of delivery via Cyrus.
#
#old-cyrus unix - n n - - pipe
# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ================================================== ==================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

submission inet n - - - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticate d,reject
-o milter_macro_daemon_name=ORIGINATING
smtp-amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes
-o disable_dns_lookups=yes
-o max_use=20

127.0.0.1:10025 inet n - - - - smtpd
-o content_filter=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_delay_reject=no
-o smtpd_client_restrictions=permit_mynetworks,reject
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o smtpd_data_restrictions=reject_unauth_pipelining
-o smtpd_end_of_data_restrictions=
-o mynetworks=127.0.0.0/8
-o smtpd_error_sleep_time=0
-o smtpd_soft_error_limit=1001
-o smtpd_hard_error_limit=1000
-o smtpd_client_connection_count_limit=0
-o smtpd_client_connection_rate_limit=0
-o receive_override_options=no_header_body_checks,no_ unknown_recipient_checks
/etc/postfix/maps/sql-maintain.cf

# This file was generated on 2015-02-24T11:12:31.129964 by running:
# modoboa-admin.py postfix_maps --dbtype mysql maps
# DO NOT EDIT!

user = postfix
password = postfix_clave
dbname = modoboa
hosts = 127.0.0.1
query = SELECT '450 Requested mail action not taken: mailbox unavailable' FROM admin_mailbox mb INNER JOIN admin_domain dom ON mb.domain_id=dom.id INNER JOIN admin_mai$
/etc/mailname

midominio.es
/etc/aliases

# See man 5 aliases for format
root: micorreopersonal@gmail.com
postmaster: root
clamav: root
/etc/fstab

proc /proc proc defaults 0 0
none /dev/pts devpts rw 0 0
tmpfs /tmp tmpfs noexec,nosuid,nodev 0 0
/var/run/mysqld /var/spool/postfix/var/run/mysqld bind defaults,bind 0 0
/etc/hosts

127.0.0.1 localhost
YY.YYY.YY.YY vpsXXXXX.ovh.net vpsXXXXX phpmyadmin.midominio.es
Estuve siguiendo este tutorial: http://gargamel.nu/my-mail-server-setup/, aunque he cambiado varias cosas tras buscar y rebuscar...

Aparte, cuando envío correos desde una cuenta que creo (cuenta@midominio.es), llega como SPAM a Gmail/Outlook.

En la Zona DNS de mi dominio del manager de OVH, mi configuración es la siguiente:

midominio.es. 0 NS dns200.anycast.me.
midominio.es. 0 NS ns200.anycast.me.
midominio.es. 0 MX 1 midominio.es.
_autodiscover._tcp.midominio.es. 0 SRV 0 0 443 mailconfig.ovh.net.
_imaps._tcp.midominio.es. 0 SRV 0 0 993 ssl0.ovh.net.
_submission._tcp.midominio.es. 0 SRV 0 0 465 ssl0.ovh.net.
midominio.es. 0 A YY.YYY.YY.YY
autoconfig.midominio.es. 0 CNAME mailconfig.ovh.net.
ftp.midominio.es. 0 CNAME midominio.es.
imap.midominio.es. 0 CNAME ssl0.ovh.net.
mail.midominio.es. 0 CNAME ssl0.ovh.net.
modoboa.midominio.es. 0 CNAME midominio.es.
phpmyadmin.midominio.es. 0 CNAME midominio.es.
pop3.midominio.es. 0 CNAME ssl0.ovh.net.
smtp.midominio.es. 0 CNAME ssl0.ovh.net.
www.midominio.es. 0 CNAME midominio.es.
midominio.es. 0 TXT "1|www.midominio.es"
www.midominio.es. 0 TXT "3|welcome"
www.midominio.es. 0 TXT "l|es"
midominio.es. 600 SPF "v=spf1 a mx -all"
modoboa.midominio.es es la dirección, vía web, por la que accedo a Modoboa, instalado según el manual del enlace que he puesto previamente.

En la pestaña "Redirecciones" del manager de OVH en mi dominio tengo lo siguiente:

midominio.es Hacia un servidor (IPv4, A) YY.YYY.YY.YY
autoconfig.midominio.es Hacia un dominio (CNAME) mailconfig.ovh.net
ftp.midominio.es Hacia un dominio (CNAME) midominio.es
imap.midominio.es Hacia un dominio (CNAME) ssl0.ovh.net
mail.midominio.es Hacia un dominio (CNAME) ssl0.ovh.net
modoboa.midominio.es Hacia un dominio (CNAME) midominio.es
phpmyadmin.midominio.es Hacia un dominio (CNAME) midominio.es
pop3.midominio.es Hacia un dominio (CNAME) ssl0.ovh.net
smtp.midominio.es Hacia un dominio (CNAME) ssl0.ovh.net
www.midominio.es Hacia un dominio (CNAME) midominio.es
Tengo Debian 64bits, con Postfix+Dovecot+MySQL+Amavis+SpamAssassin+ClamAV+N ginx+Modoboa.

Resumiendo, mis problemas son: cuando envío correos a Outlook/Gmail, llegan como SPAM. Cuando envío desde Outlook/Gmail a mi servidor, no llegan a ningún buzón.

Siento haber pegado tanta configuración y tanto fichero, pero estoy ya algo desesperado e intento solucionarlo cuanto antes, y para ello quiero poner todas las configuraciones que tengo para que algún experto pueda ayudarme o pueda ver dónde está el problema.

Muchas gracias.