We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Varias versiones de PHP con Plesk en VPS Cloud


cucurbita
18/04/2015, 10:53
Hola,

Me alegro de ello. Mi consejo es que, para todo aquello que no esté bajo tu control, tengas a mano alternativas, no vaya a ser que en la próxima ocasión/reinstalación tu problema vuelva a aparecer.

Saludos cordiales.

Mestor
17/04/2015, 08:21
Muchas Gracias por tu tiempo,

después de mucho trastear resulta que desde el panel de ovh he reinstalado el VPS y he comprobado que a fecha de hoy ya se instalan por defecto las versiones de PHP desde la 5.2 hasta la 5.6, así que me han solucionado el problema que tenía.

Solo me falta hacer funcionar el maldito Outlook...

Un saludo

cucurbita
01/04/2015, 11:31
Hola,

No he probado este sistema pero, según entiendo, se trata de un 'upgrade', así que me temo que tu versión anterior habrá sido sustituida por la nueva.

Para los casos de necesitar trabajar con más de una versión de PHP en Plesk, mi sistema favorito es descargarse el código fuente de cada nueva versión (o de las que te interesen) y compilarlo, siguiendo los pasos que se comentan en la entrada del foro que te indicaba antes. Si este sistema no te convence, en CentOS existen las 'software collections' que, en teoría, permiten trabajar con varias versiones de un mismo paquete (por ejemplo, PHP 5.3 y 5.4). Los detalles de como instalar el repositorio y los paquetes necesarios tendrás que buscarlos por tu cuenta pero serían algo parecido a esto:

Código:
yum install centos-release-SCL
yum install php54 php54-php-cli php54-php-mysql php54-php-gd
Hipoteticamente, ya sólo quedaría registrar la segunda versión de PHP en Plesk. Como inconveniente, dependerás de que alguien publique versiones actualizadas de PHP en el repositorio en cuestión.

Si tienes en mente efectuar una reinstalación de tu sistema operativo, este sería el momento propicio para probar lo anterior y todo lo nuevo que se te ocurra.

Saludos cordiales.

Mestor
31/03/2015, 20:16
Muchas gracias por tu ayuda.

El sistema operativo que tengo instalado es Centos 6 y el método que he usado es el que aparece en este link:

http://wpguru.co.uk/2014/02/how-to-u...k-11-5-centos/

¿Puedo aprovechar las dos versiones o ya me he cargado la 5.3 y tendría que reinstalar de nuevo el VPS o algo similar?

cucurbita
31/03/2015, 18:03
Hola,

No indicas cual es tu sistema operativo ni el método de instalación que has empleado para instalar/actualizar tu versión de PHP (según los pasos seguidos, puede que tu versión anterior ya no este disponible). Si trabajas con Linux, esta entrada del foro podría serte de ayuda:

http://foros.ovh.es/showthread.php?1...5-4-20-o-5-5-2

Saludos cordiales.

Mestor
31/03/2015, 09:21
Buenos días,

tengo un VPS Cloud y veo que por defecto viene con la versión PHP 5.3.3

Para los nuevos gestores de contenidos tipo Joomla no es complatible así que he instalado la versión 5.4

Todo funciona perfectamente pero hay algo que me gustaría hacer.

A la hora de seleccionar la versión de PHP desde plesk en cada suscripción solo tengo opción a elegir esta ultima que he instalado, es la única que aparece en la lista.

Internamente se que tengo las dos versiones instaladas porque no he borrado la anterior pero no se como debo hacer para poder disponer de ellas desde plesk y así poder elegir en cada suscripción la versión que necesito.

¿Alguien sabría decirme como puedo hacerlo?

Muchas Gracias por vuestro tiempo