We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Error al arrancar mi servidor


Macf
10/04/2015, 14:32
Mil gracias alvaroag, efectivamente habia varios dispositivos que comenzaban por md, en concreto md2 era la partición / y md3 /home, ya estan salvados los datos. Muchisimas gracias por tu ayuda.

Un saludo

alvaroag
10/04/2015, 00:37
En /dev, no hay ningún dispositivo que comience con "md", seguido de un número? Según leo, el modo rescue de OVH debería estar configurado para reconocer los volúmenes RAID configurados previamente.

Macf
09/04/2015, 23:23
Buenas noches alvaroag, no soy Marc pero soy un amigo suyo y me ha pedido ayuda, ya habia intentado sin éxito montar la partición home /dev/sda2, el caso es que tampoco lo consigo:
root@rescue:~# mount /dev/sda2 /mnt/
mount: unknown filesystem type 'linux_raid_member'
He buscado en internet como solucionar el error, y poder montar las particiones del RAID 1 que esta configurado pero utilizan el comando mdadm sin embargo cuando yo lo utilizo con esa partición me dice:
mdadm: /dev/sda2 does not appear to be an md device
Espero que puedas aydarnos, gracias de antemano.
Un saludo.

alvaroag
09/04/2015, 22:54
Lo razoné un poco, y creo que omití un detalle clave.... /dev/sda es el disco duro en íntegro, pero eso no se puede montar. Lo que puedes montar son las particiones, que las encontrarás como /dev/sda1, /dev/sda2, y así sucesivamente.

Dependiendo de como lo hayas configurado al instalar, la raíz podría ser cualquiera. Puede ser util que revises /etc/fstab, donde encontrarás la lista de particiones con sus pontus de montaje predeterminados para tu instalación.

Marc Iglesias Hernández
09/04/2015, 19:50
rootfs / rootfs rw 0 0
none / tmpfs rw,relatime 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
XX.XX.XX.XX:/home/pub/rescue.v7 /nfs nfs ro,relatime,vers=3,rsize=8192,wsize=8192,namlen=25 5,hard,nolock,proto=udp,port=2049,timeo=11,retrans =3,sec=sys,local_lock=$
91.121.126.137:/home/pub/pro-power /power nfs ro,relatime,vers=3,rsize=8192,wsize=8192,namlen=25 5,hard,nolock,proto=udp,port=2049,timeo=11,retrans =3,sec=sys,local_loc$
XX.XX.XX.XX:/home/pub/commonnfs /common nfs ro,relatime,vers=3,rsize=8192,wsize=8192,namlen=25 5,hard,nolock,proto=udp,port=2049,timeo=11,retrans =3,sec=sys,local_lo$
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /dev tmpfs rw,relatime,size=10240k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode= 000 0 0
tmpfs /run tmpfs rw,nosuid,noexec,relatime,size=3283724k,mode=755 0 0
tmpfs /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
tmpfs /run/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=6567440k 0 0
rpc_pipefs /nfs/var/lib/nfs/rpc_pipefs rpc_pipefs rw,relatime 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0

alvaroag
09/04/2015, 17:36
Puedes mostrar el contenido de /proc/mounts?

Marc Iglesias Hernández
09/04/2015, 17:08
Muy buenas, ayer se me reinicio la maquina sin ningún tipo de aviso y al iniciar el sistema se encendió en modo rescate, yo la verdad no sabia que era eso y me estuve informando sobre eso. Tras buscar la información note que ese modo era cuando la maquina detectaba un error en el sistema y tenia que mirar los logs para poder solucionarlo, pero el problema es que no puedo montar los discos duros para poder ver los archivos logs del sistema he seguido la guía de OVH sobre montar disco en modo rescate y me dan errores como:

root@rescue:~# sudo mount /dev/sda /mnt/sda
mount: /dev/sda already mounted or /mnt/sda busy
root@rescue:~#

Usando el comando: sudo mount /dev/sda /mnt/sda

Me dice que ya esta montando y es mentira, la verdad no se que hacer y necesito una solucionar para poder encender la maquina de nuevo.
Espero que alguien me ayude con ese problema, Gracias