We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problema con dedicado


zheive
20/05/2016, 19:48
Cita Publicado inicialmente por Airdoll
Nada... después de unos cuantos chequeos, se ha terminado de joder, los sectores pendientes aumentan y los "reallocated". Envié un ticket hace 8 días y sin respuesta. Me deberían cambiar el disco...
¿Sigues esperando? Madre mía que desastre de soporte técnico el de esta gente.

Airdoll
31/08/2015, 12:58
Nada... después de unos cuantos chequeos, se ha terminado de joder, los sectores pendientes aumentan y los "reallocated". Envié un ticket hace 8 días y sin respuesta. Me deberían cambiar el disco...

alvaroag
23/08/2015, 21:06
"224 sectores pendientes"? Si te refieres a sectores defectuosos, eso podría explicar por que el kernel remonta la partición como sólo lectura. Has un chequeo de estado de SMART, puede que el disco esté mal.

Airdoll
23/08/2015, 13:48
Hola de nuevo,

Acceso al KVM no tengo por lo que no puedo ver el error que hace que no arranque correctamente el sistema.

Los test del modo rescue no dan problemas, aunque si es cierto que se tiró más tiempo en chequear la parte conflictiva /dev/sda1, pero fue todo correcto, excepto el SMART que vienen 224 sectores pendientes. No sé si eso es motivo suficiente para poner la partición en read-only. Otro detalle es que la swap está llena, tampoco sé si tiene algo que ver, que no creo. El tema es que si ya he rescatado lo que me interesa, qué puedo hacer para intentar arrancar normal una vez que ya me da igual que con cualquier intento fallido pierda los datos, pero si logro hacerlo me ahorro reinstalar el sistema completamente. ¿Montar en rw? ¿Algún chequeo especial?.

Gracias.

Airdoll
22/08/2015, 22:11
El tema es que es un kimsufi y ese en su panel de control no salen esas opciones... he dejado un ticket a soporte, espero que contesten.

Edito: sí tiene modo rescue, voy a ver cómo manejarlo...

Gracias!

alvaroag
22/08/2015, 21:29
El problema que tenías es que, por algún motivo, el sistrema de archivos "/" fué remontado como sólo lectura Ésto puede ocasionarte variedad de inconvenientes con diversas aplicaciones, así que es normal que apache2 y otras aplicaciones no iniciasen.

Una opción es que el propio kernel lo haya remontado como sólo lectura por algún fallo en el disco. Tienes dos formas de descartarlo:

- Si tu server es de cualquiera de las gamas OVH, tienes acceso por KVM, así que puedes mirar cualquier error que el kernel o GRUB, o incluso el BIOS arroje antes de que el sistema operativo inicie.
- En cualquier caso, puedes reiniciar en modo rescue. Prueba montando tu sistema de archivos, y si no funciona, prueba con fsck, talvez se han generado errores en las estructuras del sistema de archivos.

Airdoll
22/08/2015, 18:35
Buenas,

Resulta que quería reiniciar el sistema y me dio el siguiente error:

username@srv1:~$ sudo shutdown -r now
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system

Lo hice porque de repente me estaba dando ese tipo de error al parar/iniciar apache2 y con otras aplicaciones.

Entonces me dio por reiniciar mediante el panel de control... y creo que la he cagado, ahora no tengo acceso al server, no reinicia. La swap estaba al 99%... ¿lo he perdido todo? De todos modos he enviado un ticket a ver si me dicen algo los de OVH...

Gracias...