We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

4 ips en una maquina virtual [CentOS]


santi131
01/12/2015, 16:59
Cita Publicado inicialmente por alvaroag
Veamos, entiendo que tienes un servidor SYS cpn altun entorno de virtualización, y quieres que una VM con CentOS tenga varias IPs.

No veo mucho de util en que la VM tenga las IPs en varias interfaces, ya aue físicamente sólo tienes una interface. Además, al ser todas las IPs enrutadas al mismo servidor, todas comparten la misma puerta de enlace. Entonces, lo mas fácil es que coloques todas las IPs en la misma interface, eth0, y con una sola puerta de enlace. La primera de esas IPs, "eth0:0", será la principal, por la que saldrá todo el tráfico de las aplicaciones que no tengan la capacidad para seleccionar IP de tráfico saliente. Y en diversas aplicaciones de servidor, puedes hacer que escuchen en una, varias, o todas las IPs.
Necesitarían todas las ips la misma mac virtual?
¿Que tendria que poner en los archivos de configuracion? Me podria hacer un pequeño pasos a seguir o explicar algo mejor

alvaroag
26/11/2015, 11:54
Veamos, entiendo que tienes un servidor SYS cpn altun entorno de virtualización, y quieres que una VM con CentOS tenga varias IPs.

No veo mucho de util en que la VM tenga las IPs en varias interfaces, ya aue físicamente sólo tienes una interface. Además, al ser todas las IPs enrutadas al mismo servidor, todas comparten la misma puerta de enlace. Entonces, lo mas fácil es que coloques todas las IPs en la misma interface, eth0, y con una sola puerta de enlace. La primera de esas IPs, "eth0:0", será la principal, por la que saldrá todo el tráfico de las aplicaciones que no tengan la capacidad para seleccionar IP de tráfico saliente. Y en diversas aplicaciones de servidor, puedes hacer que escuchen en una, varias, o todas las IPs.

santi131
26/11/2015, 10:52
Buenas me surje un pequeño problema
Tenemos 4 ips configuradas "eth0","eth1","eth2","eth3" con su respectivas tarjetas de red configuradas
Y el problema que tenemos es que solo sale por la "eth0" solo da ping por esa IP y las de las otras tarjetas NO
¿Como podemos hacer para que salga por todas la tarjetas?
Gracias de antemano