We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

No se recibe correo


aromeroro
21/03/2016, 09:17
Eso creía yo por eso instale´la Release3 . El único cambio que he hecho es añadir mi dominio para que pueda recibir correos vía WebAdmin:

http://tucam.es/2016-03-21%2009_09_58.jpg

He mirado y remirado por internet y no encuentro cual puede ser el problema porque aparentemente todo está correctamente configurado, pero algo tiene que estar mal elementalmente. Enviar puedo enviar correctamente y llegan los mensajes pero recibir nada de nada.

Muchas gracias de nuevo.

alvaroag
21/03/2016, 02:48
Vale... lo que veo es que el postfix está desechando el correo por que hay varios problemas de configuración..... Se supon e que el Release3 de OVH está listo para puesta en producción; has hecho algún cambio manual en la configuración?

aromeroro
20/03/2016, 18:08
Este es el log de /var/log/maillog

Mar 20 17:51:53 tucam postfix/smtpd[4497]: connect from mail-wm0-f44.google.com[74.125.82.44]
Mar 20 17:51:53 tucam postfix/smtpd[4497]: warning: connect to Milter service inet:localhost891: Connection refused
Mar 20 17:51:53 tucam postfix/smtpd[4497]: setting up TLS connection from mail-wm0-f44.google.com[74.125.82.44]
Mar 20 17:51:53 tucam postfix/smtpd[4497]: Anonymous TLS connection established from mail-wm0-f44.google.com[74.125.82.44]: TLSv1.2 with ciphe$
Mar 20 17:51:53 tucam postfix/trivial-rewrite[4499]: warning: do not list domain tucam.es in BOTH mydestination and virtual_mailbox_domains
Mar 20 17:51:53 tucam postfix/smtpd[4497]: NOQUEUE: filter: RCPT from mail-wm0-f44.google.com[74.125.82.44]: : Recipient add$
Mar 20 17:51:53 tucam postfix/smtpd[4497]: 965C3A3B2C: client=mail-wm0-f44.google.com[74.125.82.44]
Mar 20 17:51:53 tucam postfix/cleanup[4505]: 965C3A3B2C: message-id=
Mar 20 17:51:53 tucam postfix/qmgr[1475]: 965C3A3B2C: from=, size=2869, nrcpt=1 (queue active)
Mar 20 17:51:53 tucam postfix/smtpd[4497]: disconnect from mail-wm0-f44.google.com[74.125.82.44]
Mar 20 17:51:54 tucam postfix/smtpd[4510]: connect from localhost.localdomain[127.0.0.1]
Mar 20 17:51:54 tucam postfix/trivial-rewrite[4499]: warning: do not list domain tucam.es in BOTH mydestination and virtual_mailbox_domains
Mar 20 17:51:54 tucam postfix/smtpd[4510]: 47EC8A3B2F: client=localhost.localdomain[127.0.0.1]
Mar 20 17:51:54 tucam postfix/cleanup[4505]: 47EC8A3B2F: message-id=
Mar 20 17:51:54 tucam postfix/smtpd[4510]: disconnect from localhost.localdomain[127.0.0.1]
Mar 20 17:51:54 tucam postfix/qmgr[1475]: 47EC8A3B2F: from=, size=3377, nrcpt=1 (queue active)
Mar 20 17:51:54 tucam postfix/trivial-rewrite[4499]: warning: do not list domain tucam.es in BOTH mydestination and virtual_mailbox_domains
Mar 20 17:51:54 tucam amavis[1429]: (01429-02) Passed CLEAN {RelayedInbound}, [74.125.82.44]:32877 [74.125.82.44] -> Mar 20 17:51:54 tucam postfix/smtp[4507]: 965C3A3B2C: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.78, delays=0.1/0/0/0.68$
Mar 20 17:51:54 tucam postfix/qmgr[1475]: 965C3A3B2C: removed
Mar 20 17:52:01 tucam postfix/local[4554]: fatal: open database /etc/mailman/aliases.db: No such file or directory
Mar 20 17:52:02 tucam postfix/master[1467]: warning: process /usr/libexec/postfix/local pid 4554 exit status 1
Mar 20 17:52:02 tucam postfix/master[1467]: warning: /usr/libexec/postfix/local: bad command startup -- throttling
Mar 20 17:53:02 tucam postfix/local[4599]: fatal: open database /etc/mailman/aliases.db: No such file or directory
Mar 20 17:53:03 tucam postfix/master[1467]: warning: process /usr/libexec/postfix/local pid 4599 exit status 1
Mar 20 17:53:03 tucam postfix/master[1467]: warning: /usr/libexec/postfix/local: bad command startup -- throttling

aromeroro
20/03/2016, 17:22
Hola,

Primero de todo muchas gracias por tu respuesta.
Cita Publicado inicialmente por alvaroag
Hola. Cuando envías un correo desde GMail por ejemplo, después de unas horas no te llega otro correo indicándote que tu primer correo no pudo ser entregado?

Has verificado que tengas los MX bien configurados? Si tienes configuración de firewall, has verificado que tengas el puerto 25 abierto?
Si he verificado que no me llega ningún correo indicando que no se ha podido entregar el mensaje, y mirando los logs si que llega el mensaje a mi servidor.

Cita Publicado inicialmente por alvaroag
Te dejo el enlace de una herramienta para probar servidores SMTP:

https://www.wormly.com/test_smtp_server

Ponle la IP de tu servidor, una dirección de GMail, y una dirección de tu dominio.
Este es el resultado que me da, en principio entrega el mensaje correctamente:

Connecting...
SMTP -> FROM SERVER:
220 c4m0n.localdomain ESMTP Postfix
SMTP -> FROM SERVER:
250-c4m0n.localdomain
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
MAIL FROM: aromeroro@gmail.com
SMTP -> FROM SERVER:
250 2.1.0 Ok
RCPT TO: soporte@tucam.es
SMTP -> FROM SERVER:
250 2.1.5 Ok
Sending Mail Message Body...
SMTP -> FROM SERVER:
354 End data with .
SMTP -> FROM SERVER:
250 2.0.0 Ok: queued as A9DD2A3ABA
Message completed successfully.

Cita Publicado inicialmente por alvaroag
Verifica también la configuración MX:

http://mxtoolbox.com/

Escribe tu dominio, y dale al botón. Te debe mostrar un único registro MX; dale a "SMTP Test" a la derecha de ese servidor.
Este es el resultado que me da, si que da un alert en SMTP Banner Check:

Test Result
SMTP Banner Check Reverse DNS does not match SMTP Banner More Info
SMTP Reverse DNS Mismatch OK - 51.255.69.50 resolves to ns3030018.ip-51-255-69.eu
SMTP Valid Hostname OK - Reverse DNS is a valid Hostname
SMTP TLS OK - Supports TLS.
SMTP Connection Time 0.844 seconds - Good on Connection time
SMTP Open Relay OK - Not an open relay.
SMTP Transaction Time 3.110 seconds - Good on Transaction Time

alvaroag
20/03/2016, 01:05
Hola. Cuando envías un correo desde GMail por ejemplo, después de unas horas no te llega otro correo indicándote que tu primer correo no pudo ser entregado?

Has verificado que tengas los MX bien configurados? Si tienes configuración de firewall, has verificado que tengas el puerto 25 abierto?

Te dejo el enlace de una herramienta para probar servidores SMTP:

https://www.wormly.com/test_smtp_server

Ponle la IP de tu servidor, una dirección de GMail, y una dirección de tu dominio.

Verifica también la configuración MX:

http://mxtoolbox.com/

Escribe tu dominio, y dale al botón. Te debe mostrar un único registro MX; dale a "SMTP Test" a la derecha de ese servidor.

aromeroro
19/03/2016, 21:52
Hola,

Tengo un servidor dedicado con la Release 3 y está configurado Postfix y Devecop con el dominio. He creado una cuenta de correo desde PostfixAdmin y se puede acceder correctamente desde Roundcube y se pueden enviar correos y llegan a cuentas por ejemplo de gmail pero no recibe ningún correo, lo mando de gmail y no lo devuelve pero en la bandeja de entrada de Roundcube no se recibe, he probado a configurar la cuenta por IMAP en un cliente y tampoco se recibe.

Soy un poco novato en esto de los servidor de correo.

Gracias de antemano.