We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Servidor SoYouStart Proxmox deja de responder tras actualizar a 4.2


j5boot
14/06/2016, 12:45
Llevo 33 dias con el kernel 4.4.8-1-pve y no ha dado ningun fallo, ni bloqueo, la verdad es que genial. En mi caso la actualizacion fue de PVE 4.1 a PVE 4.2 y el unico incidente que tuve fue relacionado con OpenVSwtich pero cosa de poco.

killexx
10/06/2016, 12:20
Con el log correcto encuentras los problemas, en mi caso como no soy tan experto dure unos 2 dias en dar con algo y luego googleando encontre pocos post sobre ello, pero dado que la version 4.x era nueva y no habia nada en concreto decidi bajar de version

luismi777
06/06/2016, 09:19
Pues seguramente sea tema del kernel del proxmox 4.2, que no se lleva bien con estas máquinas, pero no tengo ni idea de como buscar el problema.

Es cierto que si fuese así tendría que haber habido más reportes de gente con problemas, pero por alguna razón no he encontrado nada. Voy a ver si en los foros de Proxmox me pueden decir por donde se puede tirar para tratar de encontrar el problema.

killexx
06/06/2016, 03:29
Yo pase por una experiencia similar, me queme al actualizar a proxmox 4.x hace unos 2 meses y los dedicados se congelaban me cambiaron discos, controladoras raid y nada me funciono se repetía lo mismo a los días o a la semana, era terrible.

A la final tuve que moverme a otro servidor sp64 y instalar proxmox 3.4 y hasta ahora ni 1 caída.

luismi777
04/06/2016, 09:52
Pienso que no debería ser problema hardware, ya que ha funcionado muchísimo tiempo bien y los problemas empezaron al día siguiente de actualizar a Proxmox 4.2.

Estoy usando el último kernel que tienen en su repositorio: 4.4.8-1-pve. Había pensado ir hacia atrás un poco, para intentar usar algo un poco más estable, pero tampoco se hasta que versión tirar.

También había pensado contratar el servicio KVM IP para poder ver la pantalla de la máquina una vez se ha bloqueado, pero no se cuanto tardan en instalarlo desde que lo contrate. Son 25 € por un día, pero si tardan en instalarlo no puedo tener la máquina rota 3 horas... ¿Habéis contratado alguna vez ese KVM IP?

Saludos!

alvaroag
04/06/2016, 01:56
Pues nada interesante en los logs..... Prueba reiniciarlo en modo rescue, desde ahí mira las líneas finales de los logs a ver si hay algo importante. Además, estando en modo rescue, corre las pruebas de cpu y memoria, para descartar que haya algo mal por ese lado.

luismi777
03/06/2016, 21:49
Buenas noches,

A ver si a alguien se le ocurre donde puedo mirar:

Tengo un servidor SoYouStart en el que tenía desde hace 2 años un Proxmox 3.4 funcionando sin nigún problema en todo ese tiempo. El sábado pasado lo actualicé a Proxmox 4.2 (la última disponible) y la verdad es que me sorprendió lo bien que salió todo. Al terminar todas las máquinas virtuales (Linux y Windows) arrancaron sin ningún problema. Así que por esa parte, guay.

El problema es que en lo que llevamos de semana se ha bloqueado 3 veces. El síntoma es que OVH me manda correo de que hay un problema en el servidor y que no es accesible por ping. Efectivamente, no puedo conectar por ssh ni al Proxmox ni a ninguna de las VM, así que lo único que puedo hacer es lanzar un reinicio desde el panel SYS, y todo vuelve a la normalidad.

En /var/log/messages aparece esto de vez en cuando, pero no justo antes de petarse le servidor, y además creo que no tiene mucho que ver:

Código:
Jun  3 19:13:23 ns204651 kernel: [317241.406067] audit: type=1400 audit(1464974003.744:140): apparmor="DENIED" operation="sendmsg" profile="/usr/sbin/named" name="/run/systemd/journal/dev-log" pid=1174 comm="named" requested_mask="w" denied_mask="w" fsuid=106 ouid=0
En "dmesg" no hay cosas que canten demasiado, excepto esto que he leído en algún sitio que no era muy importante:

Código:
[   15.024434] EDAC MC: Ver: 3.0.0
[   15.029498] ACPI Warning: SystemIO range 0x000000000000F040-0x000000000000F05F conflicts with OpRegion 0x000000000000F040-0x000000000000F04F (\_SB_.PCI0.SBUS.SMBI) (20150930/utaddress-254)
[   15.029502] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   15.034041] EDAC ie31200: No ECC support
[   15.060346] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20150930/utaddress-254)
[   15.060350] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   15.060353] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[   15.060355] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\_SB_.PCI0.LPCB.GPBX) (20150930/utaddress-254)
[   15.060357] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   15.060358] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[   15.060360] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\_SB_.PCI0.LPCB.GPBX) (20150930/utaddress-254)
[   15.060362] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   15.060362] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[   15.060364] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\_SB_.PCI0.LPCB.GPBX) (20150930/utaddress-254)
[   15.060366] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   15.060366] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   15.089652] ppdev: user-space parallel port driver
¿Se os ocurre qué puedo hacer o donde puedo mirar?