We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

version obsoleta. Php v5.3.x


pepejlr
27/10/2016, 22:35
Por lo que he visto, Release 3 es Linux pero compilado por OVH. Debian 8 es la mejor opción para vosotros ya que tiene PHP 5.6.

socialeventus
27/10/2016, 09:22
Hola pepejlr
Inicialmente la usamos por la sencillez de esta distribución. Nos urge hacer la migración de nuestros sitios web.

Pero no tenemos que usarla sí o sí. Y después de leer y leer por todo el foro e internet, es obvio que ha sido una mala decisión nuestra usar la Release de ovh.
Teníamos entendido (después de informarnos) que ovh solo pone versiones desfasadas. ¿Cuál sugieres de las que comentas?

Y gracias por responder!

Respecto a lo que explicas alvaroag, es una opción estupenda a considerar y hoy mismo haremos pruebas en un servidor de respaldo.
cPanel y Plesk tienen una gran comunidad de soporte detrás y no las usamos en esta migración ya que queríamos ganar tiempo evitando instalar un servidor web (xampp, easy, etc), configurando servidores de mail, ftp, etc. Nuestro error.

Gracias alvaroag

Tendremos presente TODAS sus respuestas y sugerencias. Y también críticas. No nos importan las críticas por duras que sean si eso nos ayuda a mejorar. Seguiremos leyendo sus opiniones a lo largo del día de hoy (en caso de haya más comentarios) para estar informados y mañana comenzaremos con todo

alvaroag
27/10/2016, 06:20
Cita Publicado inicialmente por socialeventus
Hola alvaroag

Gracias por contestar

Esperaré algunas respuestas más sobre mi consulta relacionada con la Release 3 de ovh.

Y por supuesto, tendré presente tu sugerencia. Al respecto he leido que algunas distribuciones de cpanel que vienen con php 5 preinstalado, cuando actualizas su versión de php y mysql el cpanel deja de funcionar o malfunciona. Nuestro temor es que pase lo mismo con plesk

Es que cuando leemos lo que ofrece OVH al respecto: Servidor operativo para alojamiento (Apache 2, PHP 5, MySQL 5, correo...) pues nos entra el miedo en el cuerpo al pensar que pasará exactamente lo mismo. Una versión defasada de php y mysql y que si la actualizamos el panel plesk quede inoperativo.

Sabes algo al respecto?

Muchas gracias
Lo que te recomendaría es que instales el panel (cPanel o Plesk) en una distribución base limpia, actualizada al 100%, utilizando el script de instalación oficial del panel. Recién, después de eso, agrega todos tus sitios web y lo que necesites. Así evitarás potenciales problemas durante las actualizaciones.

Aún así, los errores que se dan al actualizar versiones suelen ocurrir por configuraciones personalizadas, ya que los paneles comerciales como cPanel y Plesk suelen pasar controles de calidad bastante buenos.

pepejlr
27/10/2016, 01:11
Tienes que usar si o si la Release 3? Las últimas distribuciones de Linux estables llevan PHP 5.6.

socialeventus
26/10/2016, 16:29
Hola alvaroag

Gracias por contestar

Esperaré algunas respuestas más sobre mi consulta relacionada con la Release 3 de ovh.

Y por supuesto, tendré presente tu sugerencia. Al respecto he leido que algunas distribuciones de cpanel que vienen con php 5 preinstalado, cuando actualizas su versión de php y mysql el cpanel deja de funcionar o malfunciona. Nuestro temor es que pase lo mismo con plesk

Es que cuando leemos lo que ofrece OVH al respecto: Servidor operativo para alojamiento (Apache 2, PHP 5, MySQL 5, correo...) pues nos entra el miedo en el cuerpo al pensar que pasará exactamente lo mismo. Una versión defasada de php y mysql y que si la actualizamos el panel plesk quede inoperativo.

Sabes algo al respecto?

Muchas gracias

alvaroag
26/10/2016, 15:02
Hola. Lo primero que haría es mirar si hay alguna actualización de paquetes de la Release 3. Para ello, tendrías que probar con los comandos del package manager que corresponde a la distribución sobre la cual se base la Release 3.

Otra opción, que podría intetesarte, es utilizar Plesk. Todos los dedicados de OVH tienen incluída la licencia Plesk Web Pro, que te permite gestionar hasta 30 dominios. Y claro, Plesk siempre va a estar más actualizado que la Release 3.

socialeventus
26/10/2016, 13:32
Hola buenos días.

Después de batallar y perder el tiempo hablando con soporte técnico hemos optado por comentar aquí en el foro nuestra inquietud

Primero fue un hosting perfomance 2 con varias bases de datos y una de 4 gb. Esta base de datos se está comportando EXAGERADAMENTE lenta con solo poco más de 1gb ocupado. Mirando por la web de ovh vimos que sugieren SQL Privado acorde a nuestras necesidades. Lo contratamos y tampoco funciona como debería, todo va exageradamente lento y muchas veces sin tiempo de respuesta.

Al final optamos por un servidor dedicado…y lo entendemos, por supuesto. Ya tenemos mas de 250.000 usuarios (que son empresas) y el uso se hace intensivo.

El servidor contratado en base a las sugerencias del técnico (queríamos rendimiento sobre todo) fue:
Servidores ENTERPRISE:
Intel Xeon E3. E3-1231v3 4c/8t 3,4 / 3,8 GHz 32 GB RAM DDR3 ECC 1600 MHz 2x480GB SSD SOFT

No nos quejamos, va bien. Si vamos creciendo y necesitamos más…pues ya veremos

A lo que voy. Como distribución optamos por la reléase 3 de ovh por su simplicidad.
En su página dice: https://www.ovh.es/servidores_dedicados/distribuciones/release_3.xml
Una vez entregado, su servidor estará operativo para el alojamiento con Apache 2, PHP 5 y MySQL 5. La interfaz de administración OVHm le permite configurar en unos pocos clics sus dominios y servicios.

Y pensamos…no es la 7, ok, no pasa nada. Al ser la versión 5 damos por sentado que sea más reciente. La 5.6.x

Pero NO. No es así. Es la versión 5.3.x. Una versión que aunque redhat ha aplicado los patch necesario es una versión SIN soporte y con solo fix para aquellos bug críticos. Y por supuesto, ninguno de nuestros sitios web funciona correctamente con versiones obsoletas por muchos y diversos motivos, entre ellos sentencias depreciadas y auditorías de seguridad en la empresa

Nos comunicamos con soporte técnico y nos dejan claro que tenemos que apechugar con esta versión obsoleta y nos la apañemos solos. Ojo…al inicio pensamos que era una máquina la que respondía nuestros tickets ya que las respuestas eran…como decirlo…mecánicas y sin sentido
En mi opinión es una falta de respeto vender un servidor dedicado con una versión obsoleta y con errores de seguridad conocidos y sin soporte oficial (independiente de los patch necesarios que no la convierten en retroactiva)

Pues ya nos la apañaremos nosotros entonces. Qué remedio. Pensaba que los comentarios de las personas que se quejan de ovh de su mal servicio y atención eran exagerados. Ya vemos que no.

En todo caso deseamos nos indiquen alguna manera correcta de actualizar a php 7 y la version mas actual de mysql. Y también saber si cuando lo hagamos dicha versión es compatible con la Release 3 de ovh

Hasta ahora a todos nuestros clientes, siempre que nos han preguntado hemos sugerido ovh como referencia. Y aseguramos que lo hemos hecho con más de 600 clientes al menos. A nosotros mismos nos sugirieron ovh. No obstante después de esta irrespetuosidad y falta de profesionalidad dudamos que aconsejemos a nuestros clientes usar ovh

Muchas gracias por leernos