We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Instalar Osticket en Hosting compartido de OVH


alvaroag
19/12/2016, 21:14
Puede ser. PHP7 es reciente, y no son precisamente pocas las aplicaciones que aún tienen problemas. Pero es un camino que recorrer... Poco a poco, todos itrán migrando a PHP7.... Me hace recordar que yo aún tengo que ver eso con muchas aplicaciones....

pepejlr
19/12/2016, 18:15
Quizás en próximas actualizaciones de Osticket, si soporten PHP7 en su totalidad.

alvaroag
16/12/2016, 14:00
Es probable. PHP7 incluye muchos cambios, entre ellos que elimina funciones obsoletas que sí estaban disponibles en PHP 5.6

unwired
16/12/2016, 10:56
Hola de nuevo, he puesto la version LEGACY de PHP 5.6 y ahora la versión 1.9.15 de Osticket si funciona. Parece entonces que Osticket 1.9.15 y 1.10 no son compatibles con PHP 7.

unwired
16/12/2016, 10:50
Buenos días, he mirado en el log de errores que ustedes me indican y en el logging de errores no me aparece nada realtivo al osticket. No obstante en el otro log siguen apareciendo los mensajes de entrega de error 500 del servidor. He tratado de instalar la versión 1.10 y 1.9.15 de Osticket. ¿Podria ser algun problema con el PHP? Actualmente uso la 7.0

pepejlr
15/12/2016, 22:44
Cita Publicado inicialmente por unwired
Hola, los logs los he sacado de esta ubicación https://logs.ovh.net/mi.dominio/osl/...15-12-2016.log
¿No son estos?
Un saludo
Como te han dicho, esos logs son de acceso. Queremos saber el logging de errores.

unwired
15/12/2016, 20:36
Hola, los logs los he sacado de esta ubicación https://logs.ovh.net/mi.dominio/osl/...15-12-2016.log
¿No son estos?
Un saludo

alvaroag
15/12/2016, 14:22
Hola. Ese es el log de acceso, que sólamente confirma el error 500 que ya habías indicado anteriormente. El que se necesita para esto es el error log. Lo puedes conseguir en logs.ovh.net, e incluso puedes mirarlo en tiempo real, en la misma web, dandole click a "error" a la derecha de "Click here to see raw logs in real time".

unwired
15/12/2016, 11:45
Hola alvaroag,

Muchas gracias por tu respuesta, es lo primero que mire, pero no me resulto de mucha utilidad, te adjunto lo que me devuelve el log, para ver si alguien del foro sabe porque puede ocurrir.

0.0.0.0 mi.web - [15/Dec/2016:11:36:43 +0100] "GET / HTTP/1.1" 302 29 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:36:44 +0100] "GET /setup/ HTTP/1.1" 500 20 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:36:45 +0100] "GET /setup/ HTTP/1.1" 500 20 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/ HTTP/1.1" 200 1602 "http://www.google.com/search" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/css/wizard.css?901e5ea HTTP/1.1" 200 2194 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /css/flags.css?901e5ea HTTP/1.1" 200 1537 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/js/tips.js?901e5ea HTTP/1.1" 200 1089 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/js/setup.js?901e5ea HTTP/1.1" 200 355 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/logo.png HTTP/1.1" 200 36597 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /js/jstz.min.js?901e5ea HTTP/1.1" 200 1775 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /js/jquery-1.11.2.min.js?901e5ea HTTP/1.1" 200 33282 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /css/font-awesome.min.css HTTP/1.1" 200 4390 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/grey_btn_bg.png?1312910883 HTTP/1.1" 200 3098 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/cog.png?1312913866 HTTP/1.1" 200 2353 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/no.png?1312906277 HTTP/1.1" 200 1396 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/background.jpg?1312906017 HTTP/1.1" 200 21319 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/images/yes.png?1312906296 HTTP/1.1" 200 1274 "https://mi.web/setup/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /setup/ HTTP/1.1" 200 1602 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
0.0.0.0 mi.web - [15/Dec/2016:11:38:25 +0100] "GET /setup/ HTTP/1.1" 500 20 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"
0.0.0.0 mi.web - [15/Dec/2016:11:38:18 +0100] "GET /favicon.ico HTTP/1.1" 404 183 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"

Un saludo

alvaroag
15/12/2016, 01:10
Hola. Tienes que mirar en los logs del servidor. Ahí es donde vas a encontrar el error exacto.

unwired
14/12/2016, 21:04
Hola,
Estoy intentando instalar Osticket en hosting compartido de OVH pero no hay manera, tras subir los ficheros y visitar la web me sale un error 500 y no se puede seguir, he cambiado los permisos de todos los ficheros a 777 (solo por probar) y me sale el siguiente error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.


¿Alguien mas lo ha intentado? Abri un ticket hace 3 días pero aun no ha sido respondido.

Un saludo