We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Fallos actualizando la Release 2


Rarok
21/04/2008, 19:26
el problema al parecer es ese, que ya tengo el paquete llama ovh-php5 y al parecer el problema que me comentó es que por eso estaba el problema porque los overlays tendrían que tener el mismo nombre (no lo entiendo muy bien, al final me dijo que pusiese el phpmyadmin en el package.mask para poder actualizar las demás cosas)

EDITO:
Otro error

Código:
 * 
 * ERROR: net-misc/curl-7.17.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2346:  Called die
 * The specific snippet of code:
 *           die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1';
 *  The die message:
 *   ldap and kerberos (gssapi) not playing nicely try version >=7.18.1
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/curl-7.17.1/temp/environment'.
 * 
 * Regenerating GNU info directory index...
 * Processed 98 info files.

Vidal OVH
21/04/2008, 19:16
Intenta actualizar la Release 2 con el patch-all :

http://guias.ovh.es/ReleasePatchSeguridad

y vuelve a intentarlo.

De todos modos, creo que el PHP que viene en la Release2 está modificado por OVH y el paquete no se llama php, sino ovh-php4 y ovh-php5 (hay dos versiones).

Podrías instalar/actualizar phpMyAdmin forzando las dependencias y debería funcionar.

Rarok
21/04/2008, 18:52
Estoy trabajando con la release 2 y a mitad del emerge --update world me ha saltado un:
Código:
* 
 * ERROR: dev-db/phpmyadmin-2.11.5.1 failed.
 * Call stack:
 *                    ebuild.sh, line   49:  Called pkg_setup
 *   phpmyadmin-2.11.5.1.ebuild, line   26:  Called require_php_with_use 'pkg_setup' 'pkg_setup' 'pkg_setup' 'crypt' 'ctype'
 *            depend.php.eclass, line  256:  Called has_php
 *            depend.php.eclass, line  180:  Called die
 * The specific snippet of code:
 *              die "Unable to find an installed dev-lang/php package"
 *  The die message:
 *   Unable to find an installed dev-lang/php package
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-db/phpmyadmin-2.11.5.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/phpmyadmin-2.11.5.1/temp/die.env'.
 *
Preguntando a un conocido por si me podía ayudar me ha pedido que le haga un eix al dev-lang/php y me ha puesto esto
Código:
eix dev-lang/php
* dev-lang/php
     Available versions:  
        (4)     [M]4.4.8_pre20070816 [M]~4.4.8
        (5)     [m]5.2.5-r1 [m]5.2.6_rc1-r1 [m]5.2.6_rc3 [m]~5.2.6_rc3-r1 [m]5.2.6_rc4
        {adabas apache2 bcmath berkdb birdstep bzip2 calendar cdb cgi cjk cli concurrentmodphp crypt ctype curl curlwrappers db2 dbase dbmaker dbx debug discard-path doc empress empress-bcs esoob exif expat fastbuild fdftk filepro filter firebird flatfile force-cgi-redirect frontbase ftp gd gd-external gdbm gmp hash hyperwave-api iconv imap informix inifile interbase iodbc ipv6 java-external java-internal json kerberos ldap ldap-sasl libedit mcal mcve memlimit mhash ming mnogosearch msql mssql mysql mysqli ncurses nls oci8 oci8-instant-client odbc oracle7 overload pcntl pcre pdo pfpro pic posix postgres qdbm readline recode reflection sapdb session sharedext sharedmem simplexml snmp soap sockets solid spell spl sqlite ssl suhosin sybase sybase-ct sysvipc threads tidy tokenizer truetype unicode wddx xml xmlreader xmlrpc xmlwriter xpm xsl yaz zip zip-external zlib}
     Homepage:            http://www.php.net/
     Description:         The PHP language runtime engine: CLI, CGI and Apache2 SAPIs.

[I] dev-lang/php4-ovh [1]
     Available versions:  4.4.8_pre20070816-r1
     Installed versions:  4.4.8_pre20070816-r1(14:41:46 19/04/08)(berkdb crypt gdbm iconv ipv6 kerberos ldap ncurses nls pcre readline session spell ssl truetype unicode xml zlib -adabas -bcmath -birdstep -bzip2 -calendar -cdb -cjk -ctype -curl -db2 -dbase -dbmaker -dbx -debug -doc -empress -empress-bcs -esoob -exif -expat -fdftk -filepro -firebird -flatfile -frontbase -ftp -gd -gd-external -gmp -hyperwave-api -imap -informix -inifile -interbase -iodbc -java-external -java-internal -libedit -mcal -mcve -memlimit -mhash -ming -mnogosearch -msql -mssql -mysql -oci8 -oci8-instant-client -odbc -oracle7 -overload -pcntl -pfpro -pic -posix -postgres -recode -sapdb -sharedext -sharedmem -snmp -sockets -solid -sqlite -suhosin -sybase -sybase-ct -sysvipc -tokenizer -wddx -xmlrpc -xpm -xsl -yaz -zip)
     Description:         The PHP language runtime engine: CGI

[I] dev-lang/php5-ovh [1]
     Available versions:  5.2.5-r1
     Installed versions:  5.2.5-r1(14:42:26 19/04/08)(berkdb crypt gdbm iconv ipv6 kerberos ldap ncurses nls pcre readline reflection session spell spl ssl truetype unicode xml zlib -adabas -bcmath -birdstep -bzip2 -calendar -cdb -cjk -ctype -curl -curlwrappers -db2 -dbase -dbmaker -debug -doc -empress -empress-bcs -esoob -exif -fdftk -filter -firebird -flatfile -frontbase -ftp -gd -gd-external -gmp -hash -imap -inifile -interbase -iodbc -java-external -json -ldap-sasl -libedit -mcve -mhash -msql -mssql -mysql -mysqli -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -posix -postgres -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -snmp -soap -sockets -solid -sqlite -suhosin -sybase -sybase-ct -sysvipc -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip -zip-external)
     Description:         The PHP language runtime engine: CGI

[1] /usr/local/portage-ovh

Found 3 matches.
Al parecer es debido a que los overlays están mal hechos... ¿es un problema exclusivo mío o le pasa a todos los equipo con la Release 2?
¿Es que hice yo algo mal o tengo que reportarle esto a ovh?