OVH Community, your new community space.

No puedo arrancar con el Kernel de OVH


josu
30/04/2008, 12:17
En mi opinión, Grub es mejor que Lilo, aporta más opciones durante el arranque y lo que es fundamental, no reescribe el MBR cada vez que instalas un nuevo núcleo con lo que minimizas los errores y simplificas el rescate del arranque en caso de problemas.

Pero al final tanto Lilo como Grub funcionan perfectamente para arrancar un núcleo Linux. Así que ante la posibilidad de perder el sistema netboot, me quedo con Lilo.

En cuanto a como instalar el Lilo en CentOS no puedo ayudarte, yo soy debianita... pero el proceso es complicado y es probable que te cargues el arranque del servidor.

Los pasos generales son:

* Instalar el paquete lilo.
* Editar o crear el archivo de configuración "/etc/lilo.conf."

Un archivo de ejemplo puede ser el siguiente, pero sustituyendo las opciones por los parámetros de tu servidor.
prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
lba32
append=""
#serial=0,9600n8

image=/boot/bzImage
label=linux
read-only
root=/dev/hda1

* Instalar el lilo: "/sbin/lilo -v"

REPITO, si no sabes lo que haces no lo intentes que te vas a cargar el arranque. Y los pasos generales que he puesto son eso, pasos generales.

Josu.

chrimasa
29/04/2008, 23:19
Y como hago para cambiarlo? Me lo recomienda?

ferranvillalba
29/04/2008, 21:42
Cita Publicado inicialmente por chrimasa
Puede ser, yo tengo instalado cPanel con CentOS 5

Que sistema de arranque utiliza CentOs 5 ¿?
CentOS utiliza Grub.

chrimasa
29/04/2008, 18:36
Puede ser, yo tengo instalado cPanel con CentOS 5

Que sistema de arranque utiliza CentOs 5 ¿?

josu
29/04/2008, 16:52
¿Que gestor usas de arranque? Lilo, Grub, ...

Casi todas las distribuciones se han decantado actualmente por Grub, yo lo instalé nada más empezar a trabajar con OVH y tuve que volver a poner Lilo por que no era compatible con el sistema Netboot. ¿Puede ser eso?

Josu.

chrimasa
28/04/2008, 18:13
NO puedo permitirme reinstalar ahora... demasiado informacion

thekeeper
28/04/2008, 17:34
reinstalando?

chrimasa
28/04/2008, 17:18
Hola bien, tengo un dedicado con cPanel y llevo 3 días intentando arrancar con netboot con el nuevo kernel de OVH, y las 3 veces los tecnicos han tenido que intervenir y arrancarlo desde HD.

El caso es que me dicen en un email:

Los administradores confirman que el arranque de este servidor se ha modificado de tal manera que es incompatible con el Netboot de OVH.
Yo les contesto diciendo que no hemos modificado nada y me dicen...

En ese caso ha sido una modificación por parte del panel o bien por parte de alguno de vuestros administradores (alguna modificación del kernel o similar).

En esta situación, el Netboot no puede usarse en este servidor y deberéis usar únicamente los kernels del disco duro.

Cordialmente, Rubén Vidal
Departamento técnico
¿Alguien tiene alguna idea de como solucionarlo?

Un saludo