OVH Community, your new community space.

¿Crear carpetas con permisos 777 desde PHP?


Anto
24/05/2008, 18:57
Vale, ya lo he solucionado.
Desde plesk tenía que ir al dominio>configurar y ahí tenía activada la opción ('modo_seguro' PHP activo ). La he desactivado y listo.

Igualmente gracias Mazmardigan por tu ayuda

Anto
24/05/2008, 17:56
Hola Mazmardigan.

Tengo apache, php y mysql instalado en mi ordenador. Ahora mismo estoy en windows y me funciona perfectamente. Pero en el servidor pasa aquello.

con phpinfo() me sale la siguiente información respecto al safe mode:


safe_mode:
Local Value: On
Master Value: Off

Mazmardigan
24/05/2008, 16:35
Ummmm, pues realmente no me lo explico, no es normal que te venga el safe mode activado por defecto. ¿Hay alguna posibilidad de que estés modificando el archivo equivocado? Me refiero al php.ini. Creo que puedes comprobar la ruta del php.ini creando un archivo en php con el siguiente código:
Código:
Esto pasa a veces si estás usando varias versiones de PHP. De todas formas, deberías considerar el seguir editando tu script en local, es decir, que te instales el Apache, MySQL y demás cosas que necesites en tu PC, de manera que sea todo mucho mas rápido que tener que actualizar el archivo en el servidor cada vez que hagas una modificación. Creo recordar que había un programa para Windows llamado EasyPHP o algo así, y se que había otro mejor, pero no recuerdo ahora el nombre. En el caso de que uses Linux, prueba con XAMPP (creo que se llamaba así).

Un saludo.

Anto
24/05/2008, 16:24
Me venía por defecto en off, Mazmardigan.
No he reiniciado porque no lo he modificado. ¿O con lo del htaccess que me has dicho había que reiniciarlo?

Pues tengo http://www.ovh.es/productos/kimsufi08xl.xml pero con las características que venían el año pasado. Con Fedora Core 4 instalada.

Mazmardigan
24/05/2008, 14:20
Una pregunta, despues de modificar el php.ini has reiniciado apache, ¿verdad? Por cierto, me parece extraño que teniendo un servidor dedicado tengas el Safe Mode activado, ¿qué distribución usas?

Anto
24/05/2008, 14:05
Gracias por responer Mazmardigan.
Pero he probado lo que me has dicho y me sigue dando el mismo error >_<

Mazmardigan
24/05/2008, 13:42
Prueba a añadir un fichero .htaccess en la carpeta donde tienes el script con el siguiente flag, que en teoría debe desactivar el safe mode:

Código:
php_flag safe_mode off
Creo que era así, que alguien me corrija si me equivoco.

Anto
24/05/2008, 13:06
Buenas.
Estoy desarrollando un programa en php y en una parte del código se crea una carpeta y a continuación envía un archivo.

Creo la carpeta de la siguiente forma:
mkdir("carpeta/".$numero,0777);
Pero en verdad me crea una carpeta con permisos 0755.

He probado de otra manera:
mkdir("carpeta/".$numero);
chmod("carpeta/".$numero, 0777);
Ahora me crea "aparentemente" una carpeta con los permisos 0777, sólo que tampoco me deja subir el archivo.


Si creo la carpeta desde el ftp de forma manual sí que me deja enviar los archivos. Pero yo quiero que la carpeta me la cree el script. El error que me da al enviar el archivo es el siguiente:

Warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 10005 is not allowed to access /var/www/vhosts/miweb.com/httpdocs/pruebas/fotos/1 owned by uid 48 in /var/www/vhosts/miweb.com/httpdocs/pruebas/enviar_fotografia.php on line 74
he leído en otros foros casos similares y que puede ser de que tengo activado "Safe Mode", pero en mi "php.ini", ubicado en la carpeta "/etc", me indica que está en Off.

A ver si alguien me puede ayudar.
Gracias por adelantado.