OVH Community, your new community space.

reiniciar servicio ssh desde usuario


CANDIDO
06/11/2008, 12:30
[root@xxxxxx xxxxxx]# /etc/init.d/ssh restart
bash: /etc/init.d/ssh: No existe el fichero o el directorio
[root@xxxxxxxxxxx xxxxxxxxx]# /etc/init.d/sshd restart
Parando sshd: [ OK ]
Iniciando sshd: [ OK ]

En efecto algo estaba escribiendo mal, lo único es que en esta maquina es sshd, no se por qué, pero funciona como tu bien me indicaste, muchisimas gracias, ahora probaré tambien "su -root" a ver que tal.

Así da gusto, el que no aprende es porque no quiere.
Un saludo.

ivanmh
05/11/2008, 21:32
Cita Publicado inicialmente por CANDIDO
En efecto no funciona:

[root@xxxxx xxxxxxx]# /etc/init/ssh restart
bash: /etc/init/ssh: No existe el fichero o el directorio
Haz mejor su de la siguiente manera:

[usuario@xxxxx xxxxxxx]$ su - root

De esta manera, coges las variables de entorno de root.

Por cierto, lo que te cito no funciona porque no lo has escrito bien. No es "init", sino "init.d".

Saludos.

CANDIDO
05/11/2008, 21:19
Cita Publicado inicialmente por CANDIDO
Es que cuando estoy como root funciona perfectamente así, el problema es cuando lo ejecuto desde el usuario com su. De todas formas voy a probar a ver, ya te contaré, gracias.
En efecto no funciona:

[root@xxxxx xxxxxxx]# /etc/init/ssh restart
bash: /etc/init/ssh: No existe el fichero o el directorio

CANDIDO
05/11/2008, 21:15
Cita Publicado inicialmente por ivanmh
[root@xxxxxxxx /]# /etc/init.d/ssh restart

Con el comando "netstat -atupn" podrás comprobar el cambio inmediatamente.

Creo que el problema está en que lo invocas a service como "sshd", cuando realmente es "ssh".

Saludos.
Es que cuando estoy como root funciona perfectamente así, el problema es cuando lo ejecuto desde el usuario com su. De todas formas voy a probar a ver, ya te contaré, gracias.

ivanmh
05/11/2008, 21:08
[root@xxxxxxxx /]# /etc/init.d/ssh restart

Con el comando "netstat -atupn" podrás comprobar el cambio inmediatamente.

Creo que el problema está en que lo invocas a service como "sshd", cuando realmente es "ssh".

Saludos.

CANDIDO
05/11/2008, 21:01
Hola a todos, a ver si alguien me puede ayudar, resulta que he cambiado el puerto del ssh, sin problema, me he creado una cuenta de usuario para despues dehabilitar la del root, pero me encuentro con que al querer reiniciar el servicio ssh desde el usuario identificandome com "su" por supuesto, pues que no me encuentra la ruta para ejecutar el service ssh restart, me dice lo siguiente:
[root@xxxxxxxx /]# service sshd restart
bash: service: command not found
¿como puedo ejecutarlo?
Gracias de antemano.