OVH Community, your new community space.

He reinstalado el SO y ahora el backup de las bases de datos no va


Peich
11/11/2008, 20:54
Cita Publicado inicialmente por il15
gracias por la respuesta, si tengo release 2

chmod 660 a cada tabla como lo hago¿? pongo chmod 660 nombretabla?
pues si el dominio es estudioi, te metes en /home/mysql/estudioi y haces un chmod 660 *, con lo que le darás permiso 660 a todas las tablas que están en esa carpeta.


tengo que parar el servidor mysql para lo de los permisos? es que escribo:
chown -R mysql:mysql estudioi (que es el usuario) y no pasa nada, es normal?
No, aparentemente no pasa nada, pero le has cambiado los usuarios a los archivos que están dentro de la carpeta.

Por último comprueba que la carpeta estudioi tiene permiso 700 (desde /home/mysql haces un chmod 700 estudioi)

El problema de restaurar archivos es que normalmente queda predeterminado como usuario el root o el usuario que utilices para logearte por ssh y los permisos no suelen ser los correctos. Todo lo que esté dentro de la carpeta de /home/mysql debe tener como usuarios mysql. Si haces un ls -al, fíjate que todos los archivos tengan mysql mysql. Por ejemplo:

-rw-rw---- 1 mysql mysql 2048 jul 24 06:38 blog_User.MYI

Si después de cambiar los permisos y usuarios sigue sin funcionar .... pues evidentemente será otra cosa, jejeje

Salu2

il15
11/11/2008, 17:04
tengo que parar el servidor mysql para lo de los permisos? es que escribo:
chown -R mysql:mysql estudioi (que es el usuario) y no pasa nada, es normal?

il15
11/11/2008, 17:00
gracias por la respuesta, si tengo release 2

chmod 660 a cada tabla como lo hago¿? pongo chmod 660 nombretabla?

Peich
11/11/2008, 16:39
he vuelto a reinstalar todo y ahora tengo todas las tablas pero aparecen como "read only"
Has probado a comprobar los permisos / usuarios (chmod / chown) de los archivos??

Para el caso de la Release 2 (que no sé si es el tuyo) deberías hacer un chown -R mysql:mysql usuariodominio en el /home/mysql/

y después un chmod 660 a las tablas de cada dominio.

Salu2

Thyng
11/11/2008, 16:29
viendo tus mensajes anteriores, si te cargastes más cosas de la cuenta al borrar logs ( que tampoco especificas que borrastes ... ) , y las bases de datos estaban en innodb, te veo un poco mal ...

il15
11/11/2008, 15:31
he vuelto a reinstalar todo y ahora tengo todas las tablas pero aparecen como "read only"

il15
11/11/2008, 10:29
He reinstalado el SO y al copiar los archivos de mysql correspondiente al dominio que tengo no me funciona.

Si me meto en phpmyadmin me sale el listado con todas las tablas pero cuando quiero hacer algo a las tablas me dice " Can't find the files" vamos que no lo encuentra, pero están ahi.

que puedo hacer, estoy desesperado ya no se que probar