OVH Community, your new community space.

Hacer Funcionar VMware


amorales
05/01/2009, 01:20
Cita Publicado inicialmente por camaleon
Hola, a esa pregunta no estoy muy seguro, es posible que el firewall te bloquee la entrada y salida, prueba a ver dezactivarlo.
Tambien decirte que he conseguido que cada reinicio se inicie los comandos automaticamente, lo unico que tienes que hacer, en centos por ejemplo, tecleeas: nano /etc/sysconfig/network-scripts/ifcfg-eth0 y al final del todo añades los comandos , que son estos:
/sbin/route add default dev eth0
/sbin/route add default gw dev eth0

y cada vez que reinicias se inicia automaticamente, por ejemplo reinicias desde ssh y esperas hasta que se cargue ya esta, no hace falta introduci esos commandos cada reinicio.
Saludos.

Edit...
ahora que lo pienso, como dices que el la maquina de vmware no entra ni sale a internet, ¿no habras reiniciado el servidor?, porque si no tienes que introducir en el servidor que tiene el SO debian, tienes que introducir: /sbin/route add dev vmnet1
Hola camaleon.

Para ubuntu o debian, ¿cual es la manera de ejecutar este script automaticamente en cada inicio?

El tema es que para ubuntu la ruta /etc/sysconfig/network-scripts/ifcfg-eth0 no existe.

acnet
27/11/2008, 16:10
No me funciona, y ya lo hago bien, lo he hecho funcionar antes y ahora no va, he probado de todo, y es un tema de HOST seguro. No se ....

camaleon
24/11/2008, 17:52
Cita Publicado inicialmente por acnet
Hola camaleon, no se por que motivo, la VM dejó de salir a internet y lo mismo con la entrada.

Creo que es cuando activé y configuré el firewall desde webmin, es posible?

Desde la VM veo la el host, y desde el host veo la VM, pero la VM no pasa del host.

Si al host le añado de nuevo los dos comandos de route, me los acepta sin problema después de reiniciar, pero no hay manera de pasar del host, por lo que deduzco que el problema está en la máquina madre (etch).

Que lio, puf ....

Alguna idea?


Gracias !!!
Hola, a esa pregunta no estoy muy seguro, es posible que el firewall te bloquee la entrada y salida, prueba a ver dezactivarlo.
Tambien decirte que he conseguido que cada reinicio se inicie los comandos automaticamente, lo unico que tienes que hacer, en centos por ejemplo, tecleeas: nano /etc/sysconfig/network-scripts/ifcfg-eth0 y al final del todo añades los comandos , que son estos:
/sbin/route add default dev eth0
/sbin/route add default gw dev eth0

y cada vez que reinicias se inicia automaticamente, por ejemplo reinicias desde ssh y esperas hasta que se cargue ya esta, no hace falta introduci esos commandos cada reinicio.
Saludos.

Edit...
ahora que lo pienso, como dices que el la maquina de vmware no entra ni sale a internet, ¿no habras reiniciado el servidor?, porque si no tienes que introducir en el servidor que tiene el SO debian, tienes que introducir: /sbin/route add dev vmnet1

acnet
24/11/2008, 14:17
Hola camaleon, no se por que motivo, la VM dejó de salir a internet y lo mismo con la entrada.

Creo que es cuando activé y configuré el firewall desde webmin, es posible?

Desde la VM veo la el host, y desde el host veo la VM, pero la VM no pasa del host.

Si al host le añado de nuevo los dos comandos de route, me los acepta sin problema después de reiniciar, pero no hay manera de pasar del host, por lo que deduzco que el problema está en la máquina madre (etch).

Que lio, puf ....

Alguna idea?


Gracias !!!

acnet
23/11/2008, 15:17
No se cuan el ha herramienta equivalente de update-rc.d en centos, pero ya lo buscaré.

Lo que no acabo de entender y me lia un poco es lo del cambio de nombre.

Gracias

camaleon
23/11/2008, 14:46
Cita Publicado inicialmente por acnet
En Centos no existe el comando update-rc.d .... miraré a ver si encuentro la equivalencia. Por otro lado, me he liado un poco con ese "cambio de nombre" .... ¿?
Hola,
Pues creo yo que en centos es mas o menos de esta manera,
creas un archivo inicio-ips y pones los comandos que tienes que poner cada reinicio, luego ese archivo lo copiar en /etc/init.d/ y le da permisos de 755 que seria de este modo chmod 775 inicio-ips y luego insertar este comando chkconfig --levels 235 inicio-ips on, creo que asi deberia funcionar, es que ahora no me puedo permitir reinicial centos para probarlo porque la maquina virtual la esta usando una amigo y no puedo reiniciar, pero de todos modos intentare en modo local, porque es una buena cosa, ademas que yo tambien uso centos.
Saludos.

acnet
23/11/2008, 14:23
En Centos no existe el comando update-rc.d .... miraré a ver si encuentro la equivalencia. Por otro lado, me he liado un poco con ese "cambio de nombre" .... ¿?

camaleon
23/11/2008, 14:07
Cita Publicado inicialmente por acnet
Hay algún modo de decirle al sistema que recuerde este comando después de reiniciar ? Siempre lo tengo que poner a mano después de reniciar, si no no hay conexión!

Gracias
Hola, creo que te refieres a que cuando reinicias por ejemplo la maquina virtual que ese codigo se ejecute automaticamente. Pues eso se puede hacer, lo que tienes que hacer es crear un archivo como la extension sh, por ejemplo inicio.sh y introducir los codigos que tienes que introducir a cada reinicio, ese fichero lo copias en /etc/init.d/ y le da permiso 0777, luego entras en /etc/init.d/ y ejecutas este comando update-rc.d inicio.sh defaults , si te fijas bien esta el fichero inicio.sh, eso lo tienes que cambiar por el nombre que has puesto antes, y luego reinicias y ese codigo se deberia ejecutar cada reinicio.
Espero que te funcione, yo no lo he probado, pero es asi, un amigo me lo dijo y lo usa.
Saludos.

Edit....
se me olvidaba decir que ese codigo esta hecho para ubuntu o debian, para centos o otro linux es mas o menos igual.

acnet
23/11/2008, 11:12
Cita Publicado inicialmente por camaleon
/sbin/route add default dev eth0
Hay algún modo de decirle al sistema que recuerde este comando después de reiniciar ? Siempre lo tengo que poner a mano después de reniciar, si no no hay conexión!

Gracias

amorales
23/11/2008, 02:43
Hola camaleon...

Si. Me funciona bien.

Me faltaba la linea del gateway (gw)

Ya puedo acceder mediante ssh con putty desde el exterior. La mayoria de las veces es mas comodo acceder por ssh en vez de tener que usar la consola de vmware.


Saludos y muchisimas gracias.

camaleon
22/11/2008, 21:17
hola, pues ahora te hare el manual, tardo 5 minutos, es facil, ademas yo tambien uso ubuntu desktop y lo he hecho funcionar, lo que te recomiendo es que no modifiques este archivo: /etc/network/interfaces, porque lo va ha modificar ubuntu a su manera y funcionando.
Bueno, lo primero:
1. conectarse a debian (el servidor) e introducir esto:
/sbin/route add dev vmnet1

2.loguearse a ubuntu mediante vmware , e ir a: Sistema - Administración – Red
ahora lo desbloqueas para tener acceso a el, ahora haces click en Conexion Cableada y luego en Propriedades.
Ahora cambias tot por esto:

Configuracion: Dirrecion IP Estatica
Dirrecion IP: // la ip failover que quieres tener
Mascara Sub-Red: 255.255.255.255
Dirección de la puerta de enlace: // tu ip del servidor no failover


Una vez hecho esto vas a dns y pones tambien la dirrecion ip de tu servidor, como servidor dns.

y lo ultimo de todo en el terminal pones estos dos comandos en orden:
/sbin/route add default dev eth0
/sbin/route add default gw dev eth0

recuerda, donde pone es tu ip real del servidor no failover.
bueno, si tienes cualquier duda dimelo, ademas estoy redactando un manual, con imagenes, etc..., lo unico malo estoy ahora por averiguar como hacer que esos dos comandos se ejecuten cada reinicio, porque cuando reinicias tienes que volver a introducirlos.
Saludos.

Edit.... y dime si te funciona o tienes algun problema, porque ami me funciona ubuntu desktop y centos perfectamente

amorales
22/11/2008, 20:20
Cita Publicado inicialmente por camaleon
pues ya lo he hecho funcionar, si quieres que te ayude dimelo es facil , es una cosa que a los de ovh se le olvidaron poner. ,yo lo he intentado con centos pero los pasos son casi iguales en debian, si quieres que te ayude dejame un mensaje en el foro y te are un minimanual.
Si te lo agradecería.

ya les vale no ponerlo en las guias.

camaleon
21/11/2008, 16:19
pues ya lo he hecho funcionar, si quieres que te ayude dimelo es facil , es una cosa que a los de ovh se le olvidaron poner. ,yo lo he intentado con centos pero los pasos son casi iguales en debian, si quieres que te ayude dejame un mensaje en el foro y te are un minimanual.

camaleon
20/11/2008, 23:40
hola, yo no he conseguido ni salido ni entrada en el servidor virtual, ahora me esta ayudando un amigo, haber si sale, te dare noticias, espero que funcione ya que estoy que me subo por las paredes ).
Saludos.

Edit....
se me olvidaba decir que yo no he intentado lo que dices tu, con servidor dns, habra que intentarlo.

amorales
20/11/2008, 23:38
He conseguido tener acceso a Internet desde la máquina virtual.

En la configuración de la conexión de red, selecciono como servidor DNS a la IP del host servidor.

Teniendo configurado la selección de Ip estática con las mismas Ips tanto para host como para puerta de enlace y 255.255.255.255 como puerta de enlace.

Aunque no puedo acceder desde el exterior. Por ejemplo por shell.

Saludos.

amorales
20/11/2008, 22:50
Camaleon...

Estoy probando como tu vmware (la versión que distribuye OVH) y me pasa lo mismo.

He creado una máquina virtual, Instalado en ella Ubuntu 8.04 LTS Desktop.

Asigno en el servidor principal la IP Failover a vmnet1 (host only).
/sbin/route add dev vmnet1

En la máquina virtual le asigno la ruta por defecto a eth0.
/sbin/ip route add default dev eth0

Después edito el siguiente fichero para que quede tal como dice el manual.
/etc/network/interfaces:

auto eth0
iface eth0 inet static
address # la dirección de la VM
netmask 255.255.255.255
post-up /sbin/ip route add default dev eth0

También en el servidor principal pongo en el archivo /etc/vmware/routes.conf la ipfailover que uso para la maquina virtual.

¿Que podrá pasar?

camaleon
20/11/2008, 17:00
Hola, Buenos Dias,
Estoy desde hace tiempo con vmware creando vps y intentando darles ips a los vps instalados, pero no funciona, he seguido el manual de ovh que esta en esta pagina: http://guias.ovh.es/ManualUtilizacionVmware , ademas he intentado como dice ahi, com debian como invitado, con su sistema vmware que trae ovh etc..., pero no funciona, me hecho una mano fametown con un manual, pero tampoco funciona, he buscado por internet y por lo que parece que com bridge funciona pero ovh lo dezactivaron y ademas si intentas instalar vmware 2 te da errores de kernel.
Y me gustaria saber si alguien me puede ayudar, lo que quiero hacer es tener por ejemplo en vmware debian y centos, y cada uno que tenga una ip failover, pero no se como hacerlo, lo he intentado como dice ovh y parece que no funciona, os pediria que me ayudais porfavor que estoy que me tiro de los pelos ).
Gracias, y espero que alguien me pueda ayudar.