We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ovh Gentoo??


Chichoplo
18/10/2007, 17:05
Rescato este mensaje porque tengo el mismo problema. Da igual lo que actualice con emerge, me dispara siempre el mismo error:
!!! All ebuilds that could satisfy "=www-servers/apache-2*" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-servers/apache-2.2.4-r8 (masked by: package.mask)
- www-servers/apache-2.2.4-r9 (masked by: package.mask)
- www-servers/apache-2.0.59-r2 (masked by: package.mask)
- www-servers/apache-2.2.4-r6 (masked by: package.mask)
- www-servers/apache-2.2.4-r7 (masked by: package.mask)
- www-servers/apache-2.2.4-r10 (masked by: package.mask)
- www-servers/apache-2.0.58-r2 (masked by: package.mask)
Y tengo instalados tanto el apache2 de ovh, como el suphp de ovh(versión 0.6.2). Alguien sabe qué puede estar pasando? He probado a hacer unmerge y luego volver a instalar el paquete suphp-ovh, pero nada, sigue igual. Querríá evitar el hacer unmasking de ese paquete de apache que menciona...

Saludos

Vidal OVH
06/08/2007, 13:39
Hola,

El paquete :

suphp-ovh

corresponde a la instalación de PHP en modo CGI en modo doble versión (puedes cambiar entre PHP4 y PHP5 para cada dominio) y en modo "user" (con los permisos del login del propio usuario).

Este paquete está realizado y depurado personalmente por los administradores de OVH.

No debería darte mayores problemas, ya debería estar funcionando en tu Release2 (naturalmente depende del apache2).

Mientras no borres el apache2 que tienes ya instalado, no habrá problemas.

phluisma
31/07/2007, 12:47
Bueno la release última esa la tengo instalada pero para actualizar los paquetes, se supone que debo hacer

# emerge --sync
así actualizo el arbol de ports

y ahora hago una actualización
#emerge --update --deep world

Pero obtengo un problemita........
Calculating dependencies /
!!! All ebuilds that could satisfy "=www-servers/apache-2*" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-servers/apache-2.2.4-r8 (masked by: package.mask)
- www-servers/apache-2.2.4-r9 (masked by: package.mask)
- www-servers/apache-2.0.59-r2 (masked by: package.mask)
- www-servers/apache-2.2.4-r6 (masked by: package.mask)
- www-servers/apache-2.2.4-r7 (masked by: package.mask)
- www-servers/apache-2.2.4-r10 (masked by: package.mask)
- www-servers/apache-2.0.58-r2 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "www-apache/mod_suphp-ovh-0.6.2" [ebuild])


Y he modificado el /etc/portage/package.keywords
añadiendo una línea del tipo

www-servers/apache ~x86 ~amd64

pero nada sigue con el mismo error,

Como no sé exactamente para que es el suphp-ovh pues ........ no sé que hacer. Alguna idea???

Vidal OVH
31/07/2007, 12:01
Yo veo los mismos cambios en la R1 (RedHat) que en la R2 (Gentoo).

ftp://ftp.ovh.net/made-in-ovh/releas...ELOG.release-2
ftp://ftp.ovh.net/made-in-ovh/releas...ELOG.release-1

No sé a lo que te refieres.

phluisma
30/07/2007, 20:12
ftp://ftp.ovh.net/made-in-ovh/release/CHANGELOG.release
pero solo veo que habla de la redhat 7.x
no de la gentoo.....

O ando perdido??

de la gentoo veo que hay algo pero es de hace meeeeeeeses

Vidal OVH
30/07/2007, 14:42
Buenas tardes,

Puedes aplicar el parche de la release 'patch-all' y posteriormente el portage para actualizar todos los paquetes que quieras.

Más información:
http://guias.ovh.com/ReleasePatchSeguridad

Un saludo

phluisma
29/07/2007, 12:01
Para cuando la nueva actualización¿????