OVH Community, your new community space.

Redirección de midominio.com a www.midominio.com en multidominios.


Vidal OVH
14/01/2009, 11:05
http://guias.ovh.es/MultiDom

y en concreto :
- Multidominio
  • Introduzca el nuevo dominio a añadir, con las www
Nota : Si desea que el dominio funcione con y sin las www, deberá crear dos multidominios diferentes, con y sin las www, apuntando a la misma carpeta.

Creo que has añadido el multidominio sin las www.

icenrg
13/01/2009, 22:51
Hola Xiretsa,

Espera a que se propaguen las DNS, seguramente es eso.

En cuanto a la configuración que te comenta Power es para un servidor dedicado, en tu caso no creo que tengas acceso a esos ficheros en un compartido.

Salu2

Xiretsa
13/01/2009, 17:41
Según me informó el soporte técnico, tengo que ponerlo así:

http://img.photobucket.com/albums/v2.../intento_1.jpg

Pero creo que tengo que esperar de 24 a 48 despues de cualquier modificación en las DNS. Esperaré a ver que pasa...

PD: Por cierto, yo en mis carpetas no veo nada como /etc/local/apache/conf/httpd.conf Yo estoy en servidor compartido con Ovh, el Plan 720.

Muchas gracias. Saludos.

Power
13/01/2009, 08:46
Lo primero, comprueba en http://network-tools.com/nslook/ poniendo en server "midominio2.biz" en el registro A qué dirección IP te da.
A continuación pruebas poniendo como server "www.midominio2.biz"

Si en ambos casos la dirección IP es correcta, vamos bien.

En ese caso, el problema es la configuración del servidor web.
En mi caso (servidor dedicado con CentOS) la configuración está en:
/etc/local/apache/conf/httpd.conf

Para cada dominio debe haber una sección con:
Código:

    ServerName midominio2.biz
    ServerAlias www.midominio2.biz
....
Si no está así, lo modificas, reinicias Apache y ya debe ir bien.

Saludos

Xiretsa
13/01/2009, 04:50
Gracias por responder, pero sigo teniendo problemas.

A ver, creé el multidominio (llamémosle midominio2.biz) y también añadí el dominio a las Dns.

Después de dar mil vueltas, lo máximo que he conseguido es esto:

Si lo pongo así...

http://img.photobucket.com/albums/v2.../intento_1.jpg

...lo que ocurres es que midominio2.biz sí me lleva a mi carpeta del servidor, es decir, funciona bien; sin embargo www.midominio2.biz me lleva al Webmail ese en francés.

Y sí lo pongo así....

http://img.photobucket.com/albums/v2.../intento_2.jpg

...me pasa lo contrario:esta vez es www.midominio2.biz el que sí me lleva a la carpeta, pero midominio2.biz me lleva al Webmail.

Lo intenté mil maneras, pero no lo conseguí por más que probé. ¿Qué debo hacer exactamente para que en las dos direcciones salga lo correcto?? A ver, por favor, si alguien me puede ayudar, porque me estoy volviendo loco...

Gracias. Un saludo.

Power
12/01/2009, 08:21
Hola,

Eso tiene pinta de ser porque no esté definido, en la zona de DNS de midominio2.com, el subdominio www.

Saludos

Xiretsa
12/01/2009, 05:06
Hola. Tengo el siguiente problema: En mi domininioprincipal (midominio1) no tengo problemas con midominio.com y www.midominio1.com; sin embargo, en los multidominios creados, cuando voy a midominio2.com me sale lo de Webmail en francés, mientras que en www.midominio2.com sí que aparece lo que hay en la carpeta del dominio (o la página que le meta). ¿No se autoredirecciona? ¿Porque sin las www me sigue saliendo lo de Webmail en francés?

Gracias. Un saludo.