OVH Community, your new community space.

Sabe alguien porque???


BoRoU
02/02/2009, 23:55
Bueno en un principio parece que todo ha vuelto a la normalidad y el servidor vuelve a ir como un tiro...
GRACIAS POR LA AYUDA.

BoRoU
31/01/2009, 10:41
El consumo de cpu no suele rondar el 30-40% con algun pico de 60-70%, pero esporádico. La ram suele rondar el 50% y llega a picos del 70-80%...
El Mysql lo tengo configurado tal cual me dijeron en vbulletin, y creo que no es por esa configuración porque es la que más he cambiado y probado.
Las cargas del loads cpu no pasan del 2.
Lo que no he configurado es el apache, ya que el httpd lo tiene vacío y no se si es bueno meterle lo que yo vea...
En cuanto a los puertos como lo puedo comprobar? recuerdo que habia una aplicacion que te hacia un checkeo de todo pero no recuerdo el nombre... en el manager lo he mirado pero no me aparece ninguno de esos abiertos, solo el mysql el del apache, el del proftpd, sshd y un par de puertos más....

Voy a ir leyendo algo más sobre la configuración para el apache.

EDITO para decir que ya he configurado el apache, le he cambiado en el apache2.conf estos valores, que tambien son los que me comentaron en vbulletin...
7. Edit httpd.conf values to following and restart apachee for each change to take effect

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 3

##
## Server-Pool Size Regulation (MPM specific)
##

# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves

StartServers 15
MinSpareServers 15
MaxSpareServers 25
MaxClients 180
MaxRequestsPerChild 1000

Diablo48
30/01/2009, 21:23
Posiblemente despues de la primera tarde menos porque el timeout que le tendras puesto no lo habra superado, cuando lo supera por eso vuelve a tardar, lo mas provable es que no tendras optimizado el apache o la configuracion no sera la correcta ( lo mismo con el MySQL).

Ademas repito que tendrias que ver que procesos son los que se estan comiendo la CPU, porque alomejor se suma el numero de usuarios online, con que el server no esta muy optimizado, con que alomejor algun servicio no lo tienes bien protegido (vease por ejemplo el SMTP abierto o similares) y claro da como resultado lo que te esta pasando.

BoRoU
30/01/2009, 17:55
Nada, joder.... Me sigue pasando lo mismo... cuando hay cierta cantidad de gente conectada, que coincide con ciertas horas de la tarde, me pasa lo mismo, la primera pagina tarda bastante en cargarse, y luego si haces clik rápido en los enlaces funciona perfecto, pero como estés unos segundos sin hacer ningun clik vuelve a tardar mucho en cargar....
Porque puede ser esto??? Sinceramente ya no se por donde más mirar.....

Gracias.

BoRoU
30/01/2009, 00:06
Si, me dan 4 ipfailover....
De todas formas creo que lo voy a dejar así de momento para no marear más a los pobres usuarios...
Haber si mañana ya se conectan los que se suelen conectar y pruebo de una vez por todas el servidor...

Diablo48
29/01/2009, 16:44
La primera vez no, es un cambio de DNS normal y corriente, las siguientes veces si es instantaneo porque lo unico que haces es mandar una IP failover que apunta a un servidor a otro a traves del panel de ovh (obviamente esa ip hay que configurarla en el servidor nuevo antes de hacer el cambio, sino el cambio al ser instantaneo la web dejaria de verse).

Dificil de hacer no es, tienes que saber crear dns en el servidor, y usar las ips failover que te pertenezcan por comprar un servior que creo que alguna te toca, sino si no te dan ninguna (alomejor en tu paquete solo te ofrecen 1) pues necesitarias comprar alguna, pero supongo que te daran mas de 1 si el servidor es medianamente potente.

BoRoU
29/01/2009, 12:01
Joer pues eso sería más interesante ya que estoy algo frustrado con que la gente no se pueda conectar....
Eso es muy complicado de hacer?
Si lo hago es instantáneo el que vean de nuevo la pagina?

Gracias de nuevo.

Diablo48
29/01/2009, 11:06
Si la primera si es si ese es el nombre de tu maquina (cuando te lo dan por defecto o entras por ssh te lo pone) la segunda no estoy seguro ya pero creo que tambien, yo esque uso dns propias con las ip failover que asi para cambios de servidor es mas comodo porque las mueves de un servidor a otro por el panel de ovh y no hay caida ni necesitas andar a cambiar las dns ni nada, es todo automatico y no hay perdida de tiempo.

BoRoU
29/01/2009, 10:02
Pues si, la verdad es que no lo relacionaba por eso... De todas formas todavía no he podido hacer bien las pruebas porque con el cambio de DNS aún no a entrado la cantidad de gente habitual...Es más ahora mismo que le he cambiado al dominio las 2 DNS no me entra ni a mi mismo, espero que se cambien pronto...
Ya que estamos las DNS para mi dominio son estas?
ns351666.ovh.net Esta la DNS primaria
sdns1.ovh.net y esta la secundaria
Tienen que ser así no?

Gracias.

Diablo48
28/01/2009, 22:55
Me alegro de que encontraras el error pues.
Pero era problema de DNS que se sobrecargara el servidor a partir de las 4 de la tarde? no creo me suena raro eso :S

BoRoU
28/01/2009, 20:48
No, creo que ya he dado con la solución...y era el tema de las DNS secundarias que no las había puesto y todavía estaba configurado el domino en el otro servidor....Mira que le habia dado vueltas a todo, menos repasarme bien el manager...XD

En fin haber si sigue como me va hoy...

GRACIAS.

donpaco
28/01/2009, 11:16
Seria interesante saber algunas cosas

Que script usa el foro?
Cuantos visitantes simultaneos tiene?
Que maquina estas usando?

Los foros tienden a consumir bastantes recursos, en especial memoria para el MySQL, dado que dices que te ocurre a partir de las 4 de la tarde me inclino a pensar que el problema es de recursos, a partir de esa hora empieza a entrar bastante gente en las webs

Diablo48
28/01/2009, 10:06
Mira que procesos se estan comiendo la CPU en ese momento, no solo importa el my.conf eso es la configuracion del MySQL pero el servidor puede irte por otras cosas lento, si la CPU ya esta a tope por mucha optimizacion que metas en el my.conf va a ir mal.

BoRoU
27/01/2009, 23:13
Bueno pues me estoy volviendo loco y parece ser que es cosa mía...
El tema es que por las mañanas el foro va como un tiro. En cambio a partir de las 16:00 más o menos el foro empieza a tener un comportamiento extraño... La primera vez que le doy para que cargue se tira mucho rato mucho me refiero a 30 o 40 segundos. Una vez cargada la pagina (sea cual sea del servidor) luego TODOS los enlaces que hay en el foro funcionan perfectamente, a la velocidad normal... luego si estoy 1 minuto más o menos sin hacer clik en algún enlace, se vuelve a hacer lento, y otra vez lo mismo esperar casi 1 minuto a que cargue la pagina.

He estado probando muchas configuraciones para el my.cnf y nada siempre hace lo mismo....

Alguna idea?

GRACIAS.