OVH Community, your new community space.

ubuntu 8.04 activar desktop


lonas
07/02/2009, 15:43
puedes volver a instalar el scritorio asi : sudo apt-get install ubuntu-desktop

aunque te instalara el escritorio completo y eso para los servidores web no es muy recomendable por lo que yo haria de nuevo esto : sudo apt-get install x-window-system-core gnome-core

y si utilizas el server 8.04 esto : sudo apt-get install xorg gnome-core

luego al poner startx ya deveria de salirte,aunque todo esto supoongo que ya lo habras intentado.

tambien esta luegho el tema de ponerlo en español :

sudo apt-get install language-pack-es
sudo apt-get install language-pack-es-base
sudo apt-get install language-pack-gnome-es
sudo apt-get install language-pack-gnome-es-base
sudo apt-get install language-selector
sudo apt-get install language-support-e


Finalmente es necesario instalar gksu para que funcionen correctamente los menús:

sudo apt-get install gksu

Para que instale Herramientas de red hacemos :

sudo apt-get install gnome-system-tools gnome-nettool

y nos queda instalado Gnome con lo mínimo necesario


igual si empiezas y lo haces de nuevo asi te funciona.

yo tengo dos servidores en casa con ubuntu server y los dos lo tengo de la misma forma y sin problemas.

erielrojo2
07/02/2009, 15:07
reboot o shutdown -r now, lo primero
reiniciar el servidor fue lo segundo

despues instale kdm y he probado con gdm y kdm, con gdm no conecta y con kdm el cliente si conecta pero se queda la pantalla en negro..

he matado todo los procesos uno a uno y he reiniciado, pero no se lo que es

lonas
07/02/2009, 15:00
has probado a hacerle un reboot o entrar al manager y reiniciar el servidor completamente?

erielrojo2
07/02/2009, 13:52
admin@xxxxxx:~$ ps aux | grep gdm
root 8606 0.0 0.1 14336 1736 ? Ss 14:51 0:00 /usr/sbin/gdm
root 8609 0.0 0.3 18080 3488 ? S 14:51 0:00 /usr/sbin/gdm
root 8613 1.8 0.6 12984 6736 tty9 Ss+ 14:51 0:01 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt9
gdm 8690 1.8 2.2 33184 22196 ? Ss 14:51 0:01 /usr/lib/gdm/gdmgreeter

erielrojo2
07/02/2009, 01:57
si ejecuto--> admin@nsxxxxx:/etc/nxserver$ sudo nxserver --restart
NX> 100 NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 123 Service stopped
NX> 122 Service started
NX> 999 Bye

conecto con el cliente nx pero se queda en negro.


si ejecuto--->/etc/nxserver$ sudo gnome-startup.sh

X: warning; process set to priority -1 instead of requested priority 0

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Ubuntu (xorg-server 2:1.4.1~git20080131-1ubuntu9.2)
Current Operating System: Linux ksXXXXX.kimsufi.com 2.6.28.1-xxxx-std-ipv4-32 #2 SMP Fri Jan 30 09:55:02 UTC 2009 i686
Build Date: 13 June 2008 01:08:21AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 7 02:53:33 2009
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
(EE) SIS(0): Illegal video RAM size (0K) detected, using BIOS-provided info
(II) Module "ddc" already built-in
(II) Module "ddc" already built-in
(II) Module "ddc" already built-in
expected keysym, got XF86KbdLightOnOff: line 70 of pc
expected keysym, got XF86KbdBrightnessDown: line 71 of pc
expected keysym, got XF86KbdBrightnessUp: line 72 of pc
expected keysym, got XF86KbdLightOnOff: line 70 of pc
expected keysym, got XF86KbdBrightnessDown: line 71 of pc
expected keysym, got XF86KbdBrightnessUp: line 72 of pc
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
[config/hal] couldn't initialise context: (null) ((null))
xterm: bad command line option "xterm"

usage: xterm [-/+132] [-C] [-Sccn] [-T string] [-/+ah] [-/+ai] [-/+



Ya no se me ocurre nada más. :confused:

erielrojo2
06/02/2009, 22:29
Hola me ha pasado una cosa curiosa, instale ubuntu y me va iba muy bien hasta que por un descuido en vez de apagar mi escritorio, apague el de ubuntu, ahora no puedo acceder con el cliente NX, puedo acceder por ssh pero cuando hago sudo nxserver --start, no arranca. ¿hay algún comando para reactivar el modo gráfico?

También lo he reiniciado con sudo shutdown -h now, pensando que se activaría pero tampoco.

Todvía no he accedido al webmin, no se si es que no me lo han activado o es que con esta distro no se puede.

Gracias.