We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Release 2 Gentoo - "Unable to find an installed dev-lang/php package"


rbns
03/05/2009, 16:14
Buenas a todos!

"Unable to find an installed dev-lang/php package"

Ya me he encontrado un par de veces con este error
al hacer un emerge. Segun entiendo al contener el
fichero package.provided la linea dev-lang/php-X.X.X

Código:
ksXXXXXX ~ # cat /etc/portage/profile/package.provided
www-servers/apache-2.0.58
dev-lang/php-5.2.1
mail-mta/qmail-1.03
net-www/apache-2.0.59
el portage deberia dar como instalado el PHP y permitirme
el emerge de paquetes que dependen de PHP, pero no
funciona.

Como nota decir que las versiones de PHP que tengo
instaladas con la Release 2.16 son:

Código:
ksXXXXXX ~ # php5 --version
PHP 5.2.5-pl1-gentoo (cgi) (built: Apr  1 2008 12:57:10)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
Código:
ksXXXXXX ~ # php --version
PHP 4.4.8_pre20070816-pl1-gentoo (cgi) (built: Apr  1 2008 11:46:26)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
żAlguien sabe, por favor, decirme cual es la manera de
actuar en esta situacion?

Si es necesaria alguna otra informacion, no duden en
solicitarla.

Muchas gracias
rbns.-