We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

[mini how-to] Levantar BIND tras la instalación de IPSCP OMEGA en OVH


luis_sanz
23/03/2010, 20:32
Cita Publicado inicialmente por Arturoap
Listo


Cuando tenga un ratillo, dejo el primer post con la info de tu post añadida!



PD: Gracias por el apunte!
pues yo lo veo bien asi, mejor que reeditado con la info de adriangam!

asi cada uno, responde si quiere por su explicacion

como interesado, en el post, prefiero que no lo edites mas

Arturoap
23/03/2010, 20:14
Listo


Cuando tenga un ratillo, dejo el primer post con la info de tu post añadida!



PD: Gracias por el apunte!

adriangam
23/03/2010, 16:41
Cita Publicado inicialmente por Arturoap
Me refería a eso, y por eso he puesto un título así de fácil, la única intención del how-to es para los usuarios más noobs que yo (que ya es decir) pudieran almenos no enfuscarse al ver que en ISPCP no funcionan los dominios.
¡¡¡Pero no debes dar una solución a algo dejando un agujero de seguridad!!! Edita el post con lo que comenté en el segundo post.

Saludos.

Arturoap
23/03/2010, 15:38
Cita Publicado inicialmente por Aleks
Creo que lo que quiere decir es que ISPCP Omega lo detecta como caido en el Informe de servicios que da.
Me refería a eso, y por eso he puesto un título así de fácil, la única intención del how-to es para los usuarios más noobs que yo (que ya es decir) pudieran almenos no enfuscarse al ver que en ISPCP no funcionan los dominios.

adriangam
23/03/2010, 12:43
Cita Publicado inicialmente por Aleks
Creo que lo que quiere decir es que ISPCP Omega lo detecta como caido en el Informe de servicios que da.
De todos modos, lo que hace al cambiar ese parámetro es abrir la puerta a posibles ataques al servidor.

Sea como sea, es erróneo (más bien peligroso).

Saludos.

Aleks
23/03/2010, 12:38
Creo que lo que quiere decir es que ISPCP Omega lo detecta como caido en el Informe de servicios que da.

adriangam
23/03/2010, 10:02
No. Lo que comentas es incorrecto.

Bind no está caído, lo que hace

Código:
listen-on { 127.0.0.1; };
no es ni más ni menos que dejar el bind escuchando en localhost. Lo que tú haces es abrir el servidor para que cualquiera pueda usar tu servidor dns para resolver cualquier dominio. Te gustaría que yo utilizase tu servidor como dns primario? Y si lo usamos 100.000 personas? Te sobrecargaría el servidor...

Mejor aún, y si te hago un ataque DDoS a tu bind por tener eso abierto? Imagino que ya no te gusta tanto lo que lees y estás pensando en dejarlo como estaba, a que sí? Pues te voy a dar la solución óptima:

C&P:

Cita Publicado inicialmente por http://www.isp-control.net/documentation/doku.php?id=howto:security:make_ispcp_more_secure
10.) Securing Open DNS server (BIND 9)

After a clean install of a Debian server, dnsstuff.com reports the server as an open dns server(anyone can query the server about any domain ⇒ high load and high transfer). 2 steps for fixing this problem:

a. first edit /etc/bind/named.conf.options (or /etc/named/named.conf for other distros, options paragraph) and add:

Código:
allow-recursion { localnets; }; //only act as resolver for itself.
transfer-format many-answers; //this is for speed up the transfer to a secondary dns.
b. we need to modify the template used by ISPCP to generate to zone files, on Debian this is /etc/ispcp/bind/parts/cfg_entry.tpl. The file after modification should looks like:

Código:
zone "{DMN_NAME}" {
         type    master;
         file    "{DB_DIR}/{DMN_NAME}.db";
         notify  YES;
         allow-query {
                 any;
         };
};
Restart BIND:

Código:
/etc/init.d/bind9 restart
Fuente: Documentación de ispCP.

Por favor, antes de decidiros a hacer un howto, leed un poco la documentación.

Please, edita tu post para no llevar a confusión a más gente y que tengais vuestros servidores como open dns consumiendo tráfico que seguro no queréis que se consuma y/o recibiendo ataques de denegación.

P.D.: bind está levantado, así que el título del hilo es erróneo.

Saludos.

Arturoap
22/03/2010, 17:10
Hola,

uno de los problemas que almenos a mi siempre me ha pasado en ovh tras la instalación de ISPCP OMEGA es que los dominios no funcionan, y esto es porque bind está caido, lo único que hay que hacer es lo siguiente:

##########################################
¡ATENCIÓN! El siguiente tutorial solo sirve para realizar pruebas pre-producción, ya que según nos comunica el usuario adriangam, las DNS quedan vulnerables para el disfrute de cualquier hacker. Para poner el servidor listo para producción leer el comentario 2 de este mismo post
##########################################



Editar:

Código:
/etc/bind/named.conf.options
Borrar esta línea:

Código:
listen-on { 127.0.0.1; };
Sustituir por la siguiente:

Código:
listen-on { any; };

A continuación reiniciamos el servicio y listo.

Código:
/etc/init.d/bind9 restart

Suerte!