OVH Community, your new community space.

Fallo al calcular la firma con SHA1 para el TPV Virtual de CECA


Dardy
25/05/2010, 11:05
También he hecho eso ya ... a ver que dicen... pero gracias igualmente jeje

Power
25/05/2010, 10:52
Hola,

Habla con los de la CECA.
Posiblemente no te tengan activado el SHA1, como me ocurrió a mí al principio.

Saludos

Dardy
25/05/2010, 10:42
Cita Publicado inicialmente por Power
Hola,

Yo lo tengo montado y en funcionamiento.
Te recomiendo que leas detenidamente todos los mensajes del post:
http://foros.ovh.es/showthread.php?t=6343

Saludos
La cosa está en que en teoría lo tengo como ponéis vosotros y a mi me sigue fallando. No se por dónde tirar ya...

Power
25/05/2010, 10:25
Hola,

Yo lo tengo montado y en funcionamiento.
Te recomiendo que leas detenidamente todos los mensajes del post:
http://foros.ovh.es/showthread.php?t=6343

Saludos

Dardy
25/05/2010, 08:07
Buenos días,

tengo un problema con el TPV Virtual de CECA y es que estoy intentando calcular la firma con el comando SHA1, pero no hay manera de hacerlo funcionar. Este es el código del formulario:

Código PHP:
echo $Cifrado ?>"> 
echo $Firma ?>">
Parte del código PHP
Código PHP:
$Cifrado "SHA1";
$Referencia ""
$Firma sha1($Clave.$MerchantID.$AcquirerBIN.$TerminalID.$Num_operacion.$Importe.$TipoMoneda.$Exponente.$Referencia.$Cifrado.$url_OK.$url_NOK); 
En teoría por lo que visto por la red, así debería funcionar, pero no. Cuando entro en el formulario el TPV me muestra el siguiente error "La transacción no se ha podido realizar. Agotado el número máximo de intentos.Error: Firma...".
He enviado un mail a soporte de CECA pero suelen tardar bastante en responder (por si hubiera algo desactivado).

Alguien ha montado con éxito el TPV de CECA? alguien sabe que le pasa a mi tpv?

Bueno, gracias por adelantado

Un saludo