We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

PowerStack: las últimas versiones de Apache + MySQL + PHP en tu CentOS


Demiurgo
16/01/2012, 17:55
al usarla sobre kloxo no he tenido apenas problemas, pero claro yo lo utilizo para cosas concretas, no como reseller;

al actualizar php xcache me ha dado problemas con la versión Zeon, sencillo de solucionar

he visto que los paquetes se mantienen actualizados, sin ir más lejos hoy has actualizado la última versión de php que lleva solamente 6 días fuera, ¡grandísimo!

santisaez
24/11/2011, 01:39
Buenas,

PowerStack ahora también es compatible con CentOS-6, he creado un nuevo post con los detalles:

http://foros.ovh.es/showthread.php?p=58938

Saludos,

luis_sanz
22/06/2011, 23:58
Cita Publicado inicialmente por racamet
Parece una tonteria pero habeis probado "powerstack+kloxo" y "kloxo+powerstack"?

Lo digo porque el script de kloxo cambia (desinstala e instala) determinados paquetes que usan para funcionar
hola raca
la idea es esa, probarlo
yo ahora estoy en powerstack+kloxo y aunq no tengo ningun problema aun, no estoy completamente convencido de que no lo haya, sobre todo porque kloxo tambien usa repositirio propio y no se si tendra conflicto con algo.
Cuando estes test termine lo hare al contrario kloxo+powerstack y comprobare si todo queda igual, supongo que tu idea era esa, instalar primeramente el repo y luego el panel e instalar primeramente el panel y luego actualizar con el repo.. ¿no?

racamet
22/06/2011, 17:16
Parece una tonteria pero habeis probado "powerstack+kloxo" y "kloxo+powerstack"?

Lo digo porque el script de kloxo cambia (desinstala e instala) determinados paquetes que usan para funcionar

santisaez
22/06/2011, 14:18
Muy bien Luis!

Aprovecho para dar las gracias a todos los que nos estáis haciendo llegar feedback de PowerStack (ya sea de la integración con Kloxo o de cualquier otro tipo).. las sugerencias, comentarios, bugs, etc. siempre son muy bienvenidos, gracias!!

Saludos,

luis_sanz
22/06/2011, 13:43
Gracias santi, ya me extrañaba a mi, porq no encontraba rastro de la librería 5.0.92 pero como no soy un experto, pues que surgio duda, pero genial! ya estoy trasteando kloxo con powerstarck y por ahora lo unico raro fue el mensaje porq el resto funciona al 100%



ya que trae lighttpd el kloxo este, podrian haber dejado algo para cambiar completamente a lighttpd en vez de usar apache por un lado y lighttpd por el otro pero bueno no esta nada mal el panel este.

santisaez
22/06/2011, 12:49
Cita Publicado inicialmente por luis_sanz
Probando una instalacion limpia PowerStack + Kloxo al entrar en phpMyAdmin:

Su versión de librería PHP MySQL 5.0.92 es distinta de aquella de su versión de servidor MySQL 5.5.13. Esto puede ocasionar un comportamiento impredecible.

Luis, puedes estar tranquilo y hacer caso omiso de la alerta, supongo que pasará lo mismo que en el panel de control Plesk, la explicación aquí:

http://woop.es/2011/02/presentacion-...ment-182489864

Se trata de un warning que te indica que el PHP que está ejecutando phpMyAdmin está utilizando las librerías de MySQL 5.0.92 (paquete mysqlclient15) y difiere con la versión del servidor (5.5.13, el equivalente a mysqlclient16).

El PHP de PowerStack está compilado con las últimas librerías de MySQL así que el problema no puede venir por aquí. Si utilizas Plesk esta sería la explicación: el phpMyAdmin no lo sirve el Apache + PHP del sistema, lo sirve el panel de control, que al final es un lighttpd que ejecuta los scripts PHP del panel como CGI, este binario si está compilando "contra" librerías 5.0.92, aquí tienes un pantallazo:

http://filesocial.com/3dv7cfu
En cualquier caso, tal y como he comentado por aquí.. voy a meter más caña a la integración de PowerStack + Kloxo, y así tratar de evitar estos pequeños detalles (en el caso de Plesk no se puede hacer nada), gracias por el feedback!!

Saludos,

luis_sanz
22/06/2011, 11:48
probando una instalacion limpia con powerstack + kloxo al terminar la instalacion y entrar en phpmyadmin tengo el cartelito:

Su versión de librería PHP MySQL 5.0.92 es distinta de aquella de su versión de servidor MySQL 5.5.13. Esto puede ocasionar un comportamiento impredecible.


no me gustan este tipo de avisos

santisaez
20/06/2011, 19:47
@joxean, gracias por tus comentarios

El phpMyAdmin que instala Plesk está modificado/parcheado por Parallels y no te recomiendo su uso vía enlaces tal y como propones.

En cualquier caso, en CentOS + Plesk los ficheros de están en el directorio:

Código:
/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin
Mi recomendación es que hagas una instalación manual de phpMyAdmin individualmente sobre cada alojamiento y protejas el acceso por contraseña.

phpMyAdmin está en el roadmap de PowerStack, pero todavía no está empaquetado, por lo que mi recomendación sería utilizar el de EPEL o bien descargar las fuentes desde phpmyadmin.net.

Saludos,

joxean
17/06/2011, 00:21
Y sigo:
Por plesk, no tengo ningun problema para llegar a MySQL por medio de phpMyAdmin, pero me gustaría lograr una solucion en la que indicando:
Midominio.com/phpbasesdatos/
en cualquier explorador pudiera llegar a poder trabajar mis bases de datos..

He leido en algun post de internet lo siguiente, y es que introduciendo la orden siguiente:
ln -s /usr/share/phpMyAdmin /var/www/html/phpmyadmin

dejariamos accesible la aplicación desde una url publica pero en mi caso ni coincide la ubicación del phpMyAdmin ni la de la url.
salu2
y agradecimientos de antemano
si alguien puede contestar y ayudarme me alegrare enormemente.
un saludo
eta ondo izan (podríamos traducirlo como "seguir bien")

joxean
17/06/2011, 00:10
Hola SantiSaez mi nombre es joxean y soy el responsable o culpable de la administración y mantenimiento de un pequeño instituto del Pais Vasco (170 cpus más o menos, mas bien más que menos).
Por cuestiones que no son muy interesantes hemos acabado contratando un server dedicado en 1and1 (Ahora es cuando vienen abucheos etc... que no tendremos en cuenta), la cuestión es que este servidor es un servidor con sistema operativo CentOS. He actualizado PHP a la versión 5.2.10 y me ha parecido todo un logro, lo que para vosotros que leeis (la gran mayoría) este mensaje os parece una tontería, conclusión, no tengo ni pajolera idea de linux ni de Unix.
Buscando por internet la manera de saber si phpMyAdmin estaba instalado en el sistema CentOS me he encontrado con tu post y aqui estoy intentando entender y aprender un poquito.

santisaez
10/06/2011, 12:35
Hola,

Acabamos de liberar una nueva versión de PowerStack que soluciona todos los problemas que nos habeís reportado desde los foros de OVH, así como todas las sugerencias que nos habeís hecho llegar:

- PHP 5.3.6, MySQL 5.5.13 y Apache 2.2.19
- Mejorar el stack LAMP de CentOS (mas seguro, mejora de un 30%-40% en el rendimiento)
- Nuevos paquetes (Varnish, memcached, nginx, Keepalived, etc.)

Listado completo de los cambios de PowerStack 0.2:

http://kcy.me/3nmv

Si tenéis algún problema no dudéis en comunicarlo por aquí o escribirme directamente a mi, muchas gracias!

Saludos,

fbnet
09/06/2011, 02:36
No funciona con VirtualMin, una pena

is83
28/05/2011, 12:56
Hola, resulta que también recibo esta advertencia cuando accedo a las bases de datos mediante phpmyadmin...

Su versión de librería PHP MySQL 5.0.67 es distinta de aquella de su versión de servidor MySQL 5.5.12. Esto puede ocasionar un comportamiento impredecible.
Al parecer por lo que he podido leer, por lo que he podido entender que, este warning es debido a que php esta compilado con una librería de mysql teniendo una versión diferente a la de mysql-server, solo podría ser solucionado desinstalando php, y recompilarlo con la librería correcta.

(corregidme si estoy equivocado, nunca me había pasado y he podido encontrar esta información en el foro de drupal.org, de un usuario que le paso lo mismo con otras versiones anteriores.)

La opción que se me ha ocurrido es prescindir de mysql 5.5 y reinstalar mysql con la versión que corresponde a la libreria php-mysql.

Claro que si desinstalo MySQL server me pide también desinstalar 124 paquetes de plesk como psa-watchdog, psa-vpn... esto sería un problema o
¿es sencillo reinstalar esos paquetes despues de haber reinstalado el MySQL, con la versión que corresponde a la librería de php?
saludos.

is83
26/05/2011, 20:41
Hola SantiSaez, muchisimas gracias por el curro,

estoy ahora en la oficina, en cuanto llegue a casa lo hago y te cuento!

Edito: pues resulta que me da error php-sqlite2 (dependencia para site builder por lo que tengo entendido), desinstalando php-sqlite2 es la solución fácil, yo no uso sitebuilder de momento pero tengo pensado incluirlo para mis clientes en un futuro no muy lejano.
¿Se sabe algo al respecto?

este es el error que me tira, pero es muy raro porque me dice que php ha de ser igual o mayor que 5.2.0 para poder instalar php-sqlite2

Código:
 Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2-5.1.6-200705230937.x86_64 (installed)
Edito 2: despues de actualizar el cliente Atmail ha dejado de funcionar, sin embargo no ocurre lo mismo con horde que este si funciona correctamente.
este es el error que me tira cuando intento conectar por webmail utilizando atmail 1.02

Código:
unable to get webmail password!
no es por poner mal la contraseña ya que directamente me sale este mensaje error sin darme posibilidad a introducir ningún dato de acceso.


Saludos y gracias de nuevo!


Cita Publicado inicialmente por chencho
Un apunte, la versión de mysql es la 5.5 que con joomla 1.5 da problemas al instalar nuevos módulos; los que ya están instalados funcionan sin problemas, tiene el fallo al crear las tablas.
Hola, ostras y eso porque? te da algún error en clave al crear tablas?

Saludos.

chencho
26/05/2011, 18:07
Un apunte, la versión de mysql es la 5.5 que con joomla 1.5 da problemas al instalar nuevos módulos; los que ya están instalados funcionan sin problemas, tiene el fallo al crear las tablas.

santisaez
26/05/2011, 13:50
Hola is83,

Sí, son muchos los usuarios que están utilizando el combo Plesk + PowerStack y hasta la fecha no nos han reportado ningún problema.

Para actualizar a PHP 5.3 en servidor con Plesk, en tu caso sería tan sencillo como:

Código:
rpm -Uvh http://now.powerstack.org/
yum update
Si tienes cualquier problema me avisas

Saludos!

santisaez
26/05/2011, 13:47
Hola chencho!

Perdona el retraso en contestar..

Como bien indicas, supongo que el problema viene por tener el paquete "mysql" instalado dos veces, para i686 y x86_64.

Cuando instalo una CentOS de 64 bits suelo seguir estos consejos de la FAQ para convertir CentOS en una distribución "pura de 64 bits":

Código:
yum remove \*.i\?86
Así que la solución debería pasar por borrar el paquete "duplicado".. ¿al final has podido solucionar el problema? Si no es así avísame para ver si podemos hacer algo ;-)

En cualquier caso no tenemos experencia del combo Virtualmin + PowerStack, así que el feedback será muy bienvenido!

Saludos y muchas gracias!

is83
24/05/2011, 22:58
Hola, muchas gracias por la ayuda!

puedo actualizar tranquilamente en un centos 5.5 x64 con plesk 9.5.4 y php 5.1.6 ???


gracias de nuevo.
un saludo!

chencho
24/05/2011, 16:58
Usando con Centos 5.6 x64

Código:
Transaction Check Error:
  file /etc/my.cnf from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/bin/mysqlaccess from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/my_print_defaults.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysql.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.5.12-1.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386

Error Summary
No sé porqué leches tengo la versión i386 instalada (será cosa de virtualmin?)

Código:
yum remove mysql.i386

santisaez
22/02/2011, 18:21
Giner, muchas gracias por el detalle

Giner OVH
22/02/2011, 16:29
Hola Santi, Gran trabajo!
Un placer tenerte por aquí.
Muevo el hilo al foro "How-To" que le va mejor.

Un saludo!

santisaez
21/02/2011, 17:44
kennysamuerto, que buena noticia!

Si tienes cualquier problema no dudes en avisarme :cool:

kennysamuerto
21/02/2011, 17:18
Hola Santi,

Añadida a 3 servidores CentOS que tengo "pelados".

Ya te comentare mis impresiones.

Gracias!

santisaez
21/02/2011, 12:36
Hola cmarchena,

Con las versiones que instala ahora mismo PowerStack (PHP 5.3.5 + MySQL 5.5.9 + Apache 2.2.17) Plesk funciona sin problemas, comprobado en las ramas Plesk 8-9-10.

Sin embargo, Plesk todavía hace uso de algunas directivas que están deprecated en MySQL 5.5.x, como por ejemplo "TYPE=InnoDB" en lugar de "ENGINE=InnoDB", etc.. tras varias semanas trabajando con el soporte de Parallels hoy me han confirmado que a partir de Plesk 9.5.5 se dejarán de utilizar (por si a alguien le interesa, el bug es el #64240).

He preguntado cuando está prevista la salida de Plesk 9.5.5... supongo que será cosa de 2-3 semanas, si me entero avisaré por aquí

Como mucha gente me lo está preguntando.. voy a preparar una página en el wiki explicando cuales son las diferencias de PowerStack y el resto de repositorios, por ahora seguir preguntando lo que queráis

Saludos!

cmarchena
21/02/2011, 11:52
Que tal es la compatibilidad con plesk?

Con attomic es buena salvo mysql que luego hay que actualizarlo a mano.

Un saludo

santisaez
21/02/2011, 10:37
Hola!

Quería presentar por aquí también un proyecto en el que he estado trabajando los últimos meses: PowerStack, un repositorio para CentOS con las últimas versiones de Apache + MySQL + PHP.

Veo por aquí muchos usuarios de CentOS y creo que podría ser útil. Si a alguien le interesa, en mi blog he dejado algo más de información:

http://woop.es/2011/02/presentacion-powerstack/

Si alguien se anima a probarlo el feedback será muy bien recibido, gracias!!

Actualización 2011-04-01: he preparado un video que explica como instalar PowerStack en CentOS para actualizar el stack LAMP a las últimas versiones: PHP 5.3 + MySQL 5.5 on CentOS-5 with PowerStack, el resumen:

Código:
rpm -Uvh http://now.powerstack.org/
yum update
Saludos,