We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox: Montar /var/lib/vz a posteriori


chencho
16/10/2011, 14:35
Bueno, al montar la partición no se había borrado la carpeta original por lo que el disco seguía lleno.

He tenido que desmontar la partición , borrar el directorio y volver a montar

chencho
11/10/2011, 17:17
Estoy copiando, pero tengo el siguiente problema:

/ está ocupado al 99% todavía, pese a que /var/lib/vz esta montado fuera

S.ficheros Tamaño Usado Disp Uso% Montado en
/dev/sda1 30G 28G 449M 99% /
root@xxx:~# df -h /var/lib/vz
S.ficheros Tamaño Usado Disp Uso% Montado en
/dev/mapper/pve-lv1 1,2T 26G 1,1T 3% /var/lib/vz

Giner OVH
01/10/2011, 22:19
Hola, copia con

cp -prf

principalmente con -p para que te guarde permisos, fechas, usuarios, etc...

Un saludo.

chencho
28/09/2011, 16:18
Mi duda era si se podía copiar a pelo, por ejemplo, que veo que si teniendo la precaución de parar las máquinas antes.

Gracias!

yo_david
28/09/2011, 11:37
o no entiendo tu pregunta o algo me pierdo porq sigo viendolo una tonteria, pero bueno te respondo.

1º con todas las maquinas paradas logicamente, mueves /var/lib/vz a /backups y ya tienes tu copia.
2º eliminas /var/lib/vz
3º creas la particion que te falta y montas en ella /var/lib/vz y copias todos los archivos de /backups/vz dentro de esta carpeta.

arranca tus maquinas y veras q todo va..

sigo sin entender cual es tu problema!!

chencho
28/09/2011, 08:52
Hola a todos.

En la última instalación de proxmox seguí los pasos que sigo habitualmente, incluyendo los de montar /backups y /var/lib/vz en dos particiones LVM.

Pues bien, empiezo a mover máquinas y a la tercera me avisa de que no hay disco y se paran todas las máquinas.

Haciendo un df, veo montado /backups correctamente, pero no /var/lib/vz. Reviso las particiones por webmin y veo que está en lv1.

Lo único que se me ocurre es que no haya clickado el "create filesystem" y se me haya pasado ese paso.

La pregunta es... ¿qué hago para montar esta partición y no perder las máquinas que ya hay creadas? ¿Me toca hacer un backup de las máquinas en /backups, darle a create filesystem, comprobar que esté montado y restaurar?