We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Fallo de session en webmail cpanel al cambiar IP


Power
17/10/2011, 11:20
Hola,

Al parecer, una vez más, los chicos de cPanel han dado en el clavo.
Me alegro de que se te solucione el problema de esa manera.

Saludos

xsi
17/10/2011, 11:05
Ok, solucionado.

Accediendo desde http://webmail.dominio.com no funciona, pero desde http://dominio.com:2095 sí que funciona.

La solución y la razón nos la dieron en el ticket abierto en cPanel:

"http://domain.com:2095/ is the actual URL of the webmail server. http://webmail.domain.com/ uses mod_proxy to proxy connections through apache to the webmail server."

xsi
10/10/2011, 11:33
Ok, ya he abierto ticket, la primera respuesta ha sido muy rápida, pero es la misma que la del foro de cpanel.

Por otro lado, ¿podría instalar un servicio de proxy como squid en nuestro propio servidor dedicado para evitar el problema? En ese caso el propio servidor haría de proxy para conectar a sí mismo.

Gracias de nuevo y saludos,

Power
10/10/2011, 10:32
Cita Publicado inicialmente por xsi
Ah, gracias, pero ticket no he abierto ¿crees que contestarán algo diferente que en el foro? ¿Cómo se abre el ticket?
Hola,

Las opiniones y ayudas en los foros de cPanel no tienen el grado de seriedad que tiene un ticket.
Incluso cuando ya te han atendido y cerrado el ticket, tienes que hacer una valoración de la atención recibida por parte del técnico.
Si la valoración es baja, se pondrá en contacto contigo algún superior para informarse de lo ocurrido y por qué no has quedado satisfecho con la atención.
La verdad es que el soporte de cPanel es alucinante en todos los sentidos.

Puedes abrir un ticket directamente desde el WHM, sección Support >> Support Center, opción Contact cPanel.

Te ofrecen un tratamiento urgente de pago.
Pero no es necesario.
El tratamiento normal, gratuito, es superrápido y completo.
Incluso aunque la licencia sea la gratuíta de pruebas o comprada a un revendedor.

cPanel es otro mundo.

Saludos

xsi
10/10/2011, 09:36
Ah, gracias, pero ticket no he abierto ¿crees que contestarán algo diferente que en el foro? ¿Cómo se abre el ticket?

Power
10/10/2011, 09:24
Cita Publicado inicialmente por xsi
Lo comenté en http://forums.cpanel.net/f43/webmail...ed-236991.html, pero después de probarlo todo la única solución que me han dado es acceder a través de proxy.
¿conocéis alguno aunque sea de pago?
Hola,

¿Y al ticket qué te han contestado?

Saludos

xsi
10/10/2011, 08:51
Lo comenté en http://forums.cpanel.net/f43/webmail...ed-236991.html, pero después de probarlo todo la única solución que me han dado es acceder a través de proxy.
¿conocéis alguno aunque sea de pago?

xsi
07/10/2011, 08:36
Gracias, probaré a consultar con cpanel.

Por cierto, una de las soluciones temporales q comentan puede ser acceder al
webmail a través de proxy, ¿conocéis alguno gratuito y fiable?

Power
06/10/2011, 19:47
Hola,

Teniendo cPanel, yo no lo dudaría: abriría ticket a soporte de cPanel.
Son unos técnicos extraordinarios y te ayudan en todo lo que pueden, incluso aunque el problema no sea específicamente de cPanel.

En pocas horas tendrás un técnico analizando el tema y buscando una solución.
(Aunque sea Domingo a horas nocturnas)

Incluso puedes escribir el ticket en castellano.
Se buscan la vida y te responde un técnico en castellano.

Saludos

xsi
06/10/2011, 17:12
Gracias por contestar xenomm, usamos http.

Siguiendo indicaciones de otros colegas, en /usr/local/cpanel/base/horde/config/conf.php hemos cambiado:

$conf['auth']['checkip'] = true;

a

$conf['auth']['checkip'] = false;

pero sigue sin funcionar.

Siguiendo indicaciones de http://forums.cpanel.net/f5/issues-l...tml#post780381, también hemos cambiado en el WHM la opción "Cookie IP validation" a "loose", pero nada.

xenomm
06/10/2011, 15:07
usas acceso http o https ?

xsi
05/10/2011, 09:41
Hola a todos, a ver si nos podéis ayudar con un problema que tenemos.

Tenemos un servidor CentOS con cpanel y los 3 webmails Horde, Roundcube y Squirrelmail.
Un cliente nuestro tiene dos líneas ADSL y mediante un balanceador utilizan cualquiera de las dos en cualquier momento. El problema es que cuando inician sesión en cualquiera de los 3 webmails, muchas veces no se ven los iconos y a los pocos clicks los tira fuera. Suponemos que la sesión se inicia desde una de las ip's pero después las peticiones se hacen indistintamente desde cualquiera de las dos, con lo que cuando cpanel detecta la otra ip los tira fuera o no muestra las imágenes de la otra session.

Sé que es una situación anormal pero el cliente dice que les va bien así desde hace 5 años, no deben utilizar muchos servicios externos con autenticación de sesión.

Lo más gracioso es que los acabamos de migrar desde un Windows 2003 Server donde nunca han tenido problemas con el webmail del servidor de correo Mailenable. :confused:

Así que hemos de encontrar una solución, y volver al Windows ya no es posible. Una de estas dos soluciones nos satisfaría:
- Que el webmail aguante la session desde diferentes IP's.
- Que la petición se haga siempre desde una misma IP.

A ver si alguien nos puede ayudar, muchas gracias y saludos,